#mer-meeting: Mer QA meeting 12/4/2012

Meeting started by E-P at 12:01:21 UTC (full logs).

Meeting summary

    1. http://mer.bfst.de/meetings/mer-meeting/2012/mer-meeting.2012-04-12-12.01.log.txt to catch up, for those late joining (Stskeeps, 12:05:19)

  1. QA Process (E-P, 12:05:38)
    1. http://wiki.merproject.org/wiki/Quality/Terminology helps at least (Stskeeps, 12:15:57)
    2. http://mer.bfst.de/meetings/mer-meeting/2012/mer-meeting.2012-04-12-12.01.log.txt to catch up, for those late joining , mdfe (Stskeeps, 12:16:09)
    3. http://wiki.merproject.org/wiki/Architecture (Stskeeps, 12:19:28)
    4. http://mer.bfst.de/meetings/mer-meeting/2012/mer-meeting.2012-04-12-12.01.log.txt to catch up, notmart (Stskeeps, 12:29:39)
    5. Mer Core would have change and release testing (E-P, 12:40:41)
    6. Change testing is lighter than release testing (E-P, 12:41:24)
    7. Release testing contains test for changed packages + Core test set (E-P, 12:41:52)
    8. The test:package mapping needs more sophistication than <pkgname>-tests:<pkgname> (lbt, 12:44:14)

  2. Tools and tests (E-P, 12:47:40)
    1. tests should ideally be run at a discrete point in the process, not just/always inside the build environment (lbt, 13:00:28)
    2. tests should be easy to execute, eg using zypper to install them and then just 'executing' (E-P, 13:01:14)
    3. QA tools should go into Mer:Tools (E-P, 13:02:27)
    4. QA tests should go into Mer:QA (E-P, 13:02:39)
    5. work on bringing 'eat' up to mer/systemd ability (Stskeeps, 13:04:08)
    6. innovative ideas welcome on how to extract tests made during the build process, to be run later on actual hardware (lbt, 13:04:50)
    7. ACTION: Create git and OBS projects for QA tools and tests (E-P, 13:05:28)
    8. goal for nextg week: we make it possible to add testability enabled images we can actually run simple tests against (Stskeeps, 13:06:53)
    9. ACTION: E-P to document a little about how the CI testing was done in Maemo (lbt, 13:09:21)
    10. OBS Publish process should distribute test packages to the right repos (cf -cross) (lbt, 13:10:12)


Meeting ended at 13:11:34 UTC (full logs).

Action items

  1. Create git and OBS projects for QA tools and tests
  2. E-P to document a little about how the CI testing was done in Maemo


Action items, by person

  1. E-P
    1. E-P to document a little about how the CI testing was done in Maemo


People present (lines said)

  1. Stskeeps (82)
  2. lbt (67)
  3. E-P (59)
  4. mdfe_ (15)
  5. timoph (11)
  6. iekku (4)
  7. Kaadlajk (3)
  8. MerBot (2)
  9. Sage (1)
  10. vgrade (1)
  11. notmart (1)


Generated by MeetBot 0.1.4.