#mer-meeting: Mer QA meeting 19/4/2012

Meeting started by E-P at 11:00:56 UTC (full logs).

Meeting summary

  1. Follow up and current status (E-P, 11:01:11)
    1. Maemo QA process described in http://wiki.merproject.org/wiki/Quality/Test_processes (E-P, 11:03:37)
    2. timoph submitted first QA tools to Mer:Tools:Testing (E-P, 11:04:34)
    3. http://gitweb.merproject.org/gitweb?p=mer-tools/testrunner-lite.git;a=summary (lbt, 11:08:58)
    4. Git repositories created for testrunner-lite and test-definition under mer-tools (E-P, 11:13:05)
    5. https://bugs.merproject.org/show_bug.cgi?id=308 (E-P, 11:16:24)
    6. Initial eat package has been submitted to Mer:Tools:Testing (E-P, 11:16:59)

  2. Test package mapping (E-P, 11:20:05)
    1. http://wiki.merproject.org/wiki/Quality/Test_processes#Test_mapping (E-P, 11:20:14)
    2. http://wiki.merproject.org/wiki/Architecture as a reference (Stskeeps, 11:38:38)
    3. Test mapping defines what tests to run and in what order (E-P, 11:55:20)
    4. order comes from constraint, not mapping (lbt, 11:57:05)
    5. changed package list is delivered to the 'test planner' (E-P, 11:57:46)
    6. ACTION: E-P create a mapping file draft (E-P, 12:00:56)
    7. Tests need to provide constraints which are used to decide when to run them (eg need certain time, network connectivity, run on a real device etc) (lbt, 12:02:48)
    8. re-architected EAT -- to add test enablement to a device, add Mer:Tools:Devel, add eat-device in %packages and su -c 'eat-add-device-key' - root and for each of the users needing test login (Stskeeps, 12:05:28)
    9. logging in with EAT key, if a X session, will give you environment as inside the X session, Xauth + dbus sesssion etc (Stskeeps, 12:06:01)
    10. on host (sdk) you need to install eat-host and /usr/bin/eat-install-host-key to install the private EAT key (Stskeeps, 12:06:55)
    11. tested with testrunner-lite, testrunner-ui needs a UI part for selecting SSH private key (Stskeeps, 12:07:16)
    12. bug 315 (testrunner-ui ssh key) (Stskeeps, 12:12:53)
    13. The weekly QA meeting will be on Thursdays at 12 UTC (E-P, 12:20:25)


Meeting ended at 12:21:42 UTC (full logs).

Action items

  1. E-P create a mapping file draft


Action items, by person

  1. E-P
    1. E-P create a mapping file draft


People present (lines said)

  1. E-P (86)
  2. lbt (66)
  3. Stskeeps (42)
  4. mdfe_ (13)
  5. timoph (6)
  6. Sage (4)
  7. iekku (4)
  8. MerBot (2)
  9. jbos (2)
  10. niqt (2)
  11. dcthang (1)


Generated by MeetBot 0.1.4.