15:59:32 <vgrade_> #startmeeting MeeGo Community OBS Replacement Meeting 15/05/2012
15:59:32 <MerBot> Meeting started Tue May 15 15:59:32 2012 UTC.  The chair is vgrade_. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
15:59:32 <MerBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:59:59 <vgrade_> Welcome everyone I have the Agenda at http://www.mail-archive.com/mergeneral@lists.merproject.org/msg00496.html
16:00:04 <Stskeeps> o/
16:00:10 <vgrade_> Last meeting log at http://mer.bfst.de/meetings/mer-meeting/2012/mer-meeting.2012-04-24-16.00.html
16:00:12 <Stskeeps> mer-general though
16:01:31 <vgrade_> Welcome everyone I have the Agenda at http://www.mail-archive.com/mer-general@lists.merproject.org/msg00496.html
16:01:43 <vgrade_> If you are new to this meeting give us a wave and a short intro
16:03:07 <vgrade_> #topic 1. Mer NFP Status including progress on Donation/Sponsorship Procedures
16:03:18 <vgrade_> lbt, Could you let us know the current status?
16:03:28 <lbt> oop - sry
16:04:11 <lbt> We now have a bank account.
16:04:44 <lbt> Not only that, a member of the community not 100 miles from here has tested it works too
16:04:49 <lbt> Thanks vgrade_ :)
16:05:20 <lbt> I have not spent any time recently progressing the NFP status - too much to do with Tizen conf and Mer work
16:05:51 <vgrade_> NP I though that would be the case
16:06:01 <lbt> I did email my accountant today to verify how we could take donations from VAT registered companies and not incur VAT
16:06:40 <vgrade_> are the bank account details on the Wiki? Or would you prefer people to contact you direct?
16:06:47 <lbt> That looks reasonably easy and I'll let you know when I get confirmation
16:07:22 <lbt> You know, I don't know if posting the bank details online is safe
16:07:31 <lbt> I assume so ...
16:07:43 <lbt> for now I'd prefer direct contact though
16:08:44 <vgrade_> ok
16:08:57 <vgrade_> Some of the guys over at opentablets.org asked if we were planning a Mer paypal account they could use?
16:09:26 <lbt> hmm ... I think I can do that now
16:09:39 <lbt> will add to the list
16:09:49 <vgrade_> many have zenithink tablets and wanted to make a contribution direct as they did not buy a Vivaldi
16:10:15 <vgrade_> #info bank account now available
16:10:18 <lbt> *nod*
16:10:34 <vgrade_> #info contact lbt on #mer for details
16:10:54 <lbt> #info or at david@dgreaves.com
16:10:56 <vgrade_> #info a mer paypal account to be set up
16:11:03 <Stskeeps> just watch out with paypal, we had massive problems with them in my old open source project
16:11:29 <lbt> yeah, I've heard dubious things about freezing accounts and such
16:12:56 <vgrade_> did the donation policy get approved by the AB yet?
16:13:28 <lbt> I think it's up this week
16:13:57 <vgrade_> ok, I'll leave the wiki page update
16:14:28 <lbt> sadly, tightening up the rules has put one of our corporate donors off. I'll discuss that at the AB
16:15:04 <vgrade_> ok
16:15:11 <vgrade_> #topic 2. Legal Entity Progress
16:15:36 <lbt> what's the difference between topic 1&2 ?
16:16:14 <lbt> is this more about the potential need for 2 entities?
16:16:40 <vgrade_> 2 was looking at what entity would be representing the new OBS
16:17:00 <vgrade_> so may not be Mer
16:17:00 <lbt> right
16:17:16 <SD69> AIUI, a separate entity from Mer for cOBS
16:18:15 <lbt> so I haven't spoken to eV yet
16:18:46 <lbt> The NFP and this topic will be intertwined I think
16:19:06 <vgrade_> I'm guessing due to Tizen conf things have not moved on this
16:19:16 <lbt> correct
16:19:30 <vgrade_> I'm sure, I will combine them for next time
16:19:37 <SD69> lbt: I think they should be separate
16:20:01 <lbt> SD69: mmm
16:20:16 <lbt> you mean you think we should have 2 entities or 2 tasks?
16:20:47 <lbt> I see 1 task to determine the Mer NFP/OBS entity setup :)
16:21:19 <SD69> I think we should have 2 entities, and AIUI that was the preference of Mer as well so issues from cOBS could not adversely affect Mer
16:21:51 <lbt> yep - I expect that answer - I'm hoping to get eV to provide some legal advice
16:22:08 <lbt> Would one be a subproject of the other?
16:22:16 <lbt> how would finance sharing work?
16:22:57 <lbt> so I tend to agree we'd have to do that - but equally I would like the lower overhead of just one entity.
16:23:25 <SD69> the 2 entities would be legally independent, but the same individuals happen to be involved with both
16:23:54 <lbt> *nod* ... I expect so... but as I say, I'd like to get a legal assesment of the risk
16:24:34 <vgrade_> we can revisit this once we have taken advice
16:25:18 <SD69> should we discuss respective contributions - from maemo, from mer?
16:25:58 <vgrade_> financial or people
16:26:49 <SD69> both I would think
16:26:58 <lbt> FYI : http://www.38degrees.org.uk/pages/donations-to-38-degrees
16:27:54 <lbt> this talks about earmarking funds ... I doubt we can be quite so precise but I bet we can do something to allocate donations to pools
16:28:14 <lbt> ie "anything" "mer only" "cobs only"
16:28:52 <SD69> fyi:
16:28:57 <SD69> http://wiki.maemo.org/Task:Maemo_OBS#Goals
16:29:24 <lbt> ah, good - thanks
16:29:46 <vgrade_> #info http://wiki.maemo.org/Task:Maemo_OBS#Goals
16:31:54 <lbt> I have nothing else on #2 :)
16:33:10 <vgrade_> SD69: we don't have a Mer Wiki page with goals set out but this meeting I think shows we are willing to contribute
16:33:53 <SD69> vgrade:  we have to measure and weigh respective contributions
16:34:45 <vgrade_> indeed it needs to be balanced
16:35:45 <vgrade_> and not just between Mer and Maemo, others have shown an interest in using the OBS
16:36:05 <Stskeeps> co-operative fashion, if you use more, you're expected to contribute more..?
16:36:12 <vgrade_> I'm not sure how the commitment of people could be managed though
16:36:56 <lbt> I want to develop some monitoring for OBS anyway
16:37:17 <vgrade_> big brother :)
16:37:33 <lbt> IT capacity planning :)
16:37:39 <SD69> vgrade: what others? and what will they contribute?
16:37:48 <lbt> PA for example
16:38:24 <vgrade_> yes Aaron contributed to one our our earlier meetings
16:38:43 <SD69> what will PA contribute to the cOBS?
16:39:13 <lbt> they'd discussed financing it
16:39:49 <SD69> good, $$$ is always welcome
16:39:56 <vgrade_> A monetry contribution from the profits from Vivaldi tablet have been earmarked to be fed back into PA and Mer community
16:40:31 <vgrade_> see Aarons blog for details
16:40:47 <lbt> All accounts will be open too - we haven't decided how to deal with anonymity yet AFAIR
16:40:59 <SD69> I'm proceeding on the presumption that cOBS will be related but in some ways independent project
16:41:12 <SD69> from Mer
16:41:36 <lbt> SD69: yep - I kinda want to keep the funding in one place though
16:42:08 <lbt> I think an allocation policy like 38degrees will make this more palatable
16:42:30 <lbt> so PA and Maemo may decide to contribute funds earmarked only for c.OBS
16:42:41 <lbt> or 90% c.OBS or something
16:44:01 <vgrade_> I need to move things on to the last item
16:44:03 <vgrade_> #topic 3. Feedback from Maemo OBS discussions
16:44:14 <vgrade_> http://mg.pov.lt/maemo-meeting-irclog/%23maemo-meeting.2012-05-07.log.html
16:44:15 <SD69> we support Mer, but I hope you are not presuming that maemo is going to put its server/cOBS resources under Mer governance
16:44:29 <vgrade_> http://mg.pov.lt/maemo-meeting-irclog/%23maemo-meeting.2012-05-14.log.html
16:44:43 <lbt> SD69: yes we were assuming that
16:45:24 <lbt> can you clarify a bit?
16:45:32 <SD69> I hope nothing I have said has suggested that - I thought there would be separate entities
16:45:34 <Stskeeps> well, i think cOBS could have it's own governance as such, made up of the participants?
16:46:01 <lbt> hmm
16:46:16 <SD69> stskeeps: that's what I thought from previous meetings
16:46:20 <lbt> my head was in sysadmin space
16:46:54 <Stskeeps> i don't see any particular reason why it has to be mer governance, just that it has to be a shared effort (and cost)
16:46:57 <lbt> so I expected the cobs to be a part of the Mer infrastructure mgmt domain
16:47:12 <SD69> maemo is not going to donate $$ to cOBS (we don't have any)
16:47:26 <Stskeeps> cost being resources even, like workers
16:47:38 <lbt> in terms of organisational governance ... that's different
16:49:18 <Stskeeps> long story short: we just need some kind of governance on the cobs that works and is balanced and co-operative
16:49:39 <Stskeeps> if it's mer infra 'handling' the obs itself, by directives from governance.. sure, why not
16:49:43 * timoph is late
16:49:46 <Stskeeps> might even be KDE or maemo.org in the future
16:51:52 <Stskeeps> .. did i derail the conversation?
16:52:50 <SD69> stskeeps: i think i am in agreement with what you said
16:53:17 <vgrade_> I like the idea of balanced and co-operative
16:53:20 <Stskeeps> i can't but feel we need organisational diagrams by now.. :P
16:53:29 <SD69> except I think KDe might be an issue
16:54:12 <vgrade_> SD69:  why?
16:54:29 <SD69> vgrade: petty stuff
16:54:54 <Stskeeps> the important thing is to delegate a team that handles the community OBS, and it's as simple as that.. if the chosen implementation is by implementing it utilizing the Mer infra setup + some external maemo.org workers, then it's just that isn't it?
16:55:28 <timoph> have a sort of tsg for it to sort out differences when needed? presentation from eatch project. day-to-day admins can be different
16:55:40 <SD69> stskeeps: I think so, but no need to reach a decision today, is there?
16:55:58 <Stskeeps> correct
16:56:04 <vgrade_> no , we have a while yet to get the people round the table again
16:56:08 <lbt> we do have some security issues - I need the maemo workers to have very limited access
16:56:23 <Stskeeps> :nod:
16:56:36 <timoph> to what?
16:56:45 <timoph> mer core, etc?
16:56:49 <lbt> ie pretty much me + X-Fade + phaeron type people would be the only ones to be allowed root
16:57:00 <vgrade_> Stskeeps: can you take over and do the end meeting I have to catch a bus
16:57:03 * timoph got it
16:57:12 <Stskeeps> vgrade_: type #chair Stskeeps
16:57:23 <vgrade_> #chair Stskeeps
16:57:23 <MerBot> Current chairs: Stskeeps vgrade_
16:57:35 <vgrade_> thanks people
16:57:39 <vgrade_> bye
16:57:40 <lbt> thanks vgrade_
16:57:43 <timoph> o/
16:57:55 <SD69> bye
16:57:58 <Stskeeps> anyway, Feedback from Maemo OBS discussions
16:58:06 <lbt> SD69: so when you asked about governance ... that was in my mind
16:58:08 <Stskeeps> did you have a meeting revolving around technical issues, etc?
16:58:23 <timoph> Stskeeps: we did
16:58:48 <Stskeeps> #link http://mg.pov.lt/maemo-meeting-irclog/%23maemo-meeting.2012-05-14.log.html
16:59:03 <Stskeeps> i'm working on a new OBS SB2 approach that will make enabling fremantle and co a -lot- easier as well
16:59:45 <lbt> and I'd like to get some of the Maemo targets added to our OBS test suite
17:00:27 <timoph> so a minimal fremantle sysroot?
17:00:43 <lbt> timoph: that kind of thing
17:00:52 <timoph> dunno if it contains some closed stuff?
17:00:58 <timoph> might be an issue
17:01:28 <Stskeeps> not the deepest code that validates a build, at least
17:02:36 <Stskeeps> have you maemo.org guys managed to get any volunteers besides X-Fade to attempt any obs experiments yet?
17:02:38 <timoph> but anyway. the maemo obs thing is basically pending for X-Fade to resolve some issues with arm builds
17:02:39 <Stskeeps> or even QA people
17:02:55 * timoph volunteered
17:02:58 <Stskeeps> ok
17:03:39 <lbt> javispedro was in the 2nd meeting too
17:03:44 <SD69> stskeeps: we have just a couple
17:03:50 <javispedro> I also volunteered, mostly to try and fix potential packaging problems
17:03:51 <Stskeeps> anything above 0 is good :)
17:04:00 <timoph> :)
17:05:44 <Stskeeps> okay, so, anything else to report?
17:06:28 <timoph> not really
17:06:43 <Stskeeps> okay, if there's no objections, i'll close the meeting - thank you all for coming
17:06:57 <SD69> nothing else
17:07:03 <SD69> thanks
17:07:48 <lbt> SD69: could you have a think about what kind of governance you were thinking of
17:08:36 <lbt> and what kind of 'authority' a c.obs steering group should have
17:08:51 <SD69> lbt: I will talk some amongst maemo people
17:09:06 <lbt> who may be on it (ie major users/contributors whatever that means)
17:09:22 <lbt> ta
17:09:39 <lbt> I don't want to gloss over things that may matter to people :)
17:10:09 <Stskeeps> #action SD69 to think about what kind of governance he was thinking of
17:10:16 <Stskeeps> ok, closing
17:10:18 <Stskeeps> #endmeeting