11:01:42 <iekku> #startmeeting Mer Bug Triage 4/6/2012
11:01:42 <MerBot> Meeting started Mon Jun  4 11:01:42 2012 UTC.  The chair is iekku. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
11:01:42 <MerBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
11:02:00 <iekku> #topic We'll start with the new bugs:
11:02:00 <iekku> #link https://bugs.merproject.org/buglist.cgi?bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=trivial&bug_severity=enhancement&bug_status=NEEDINFO&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=TRIAGEDUPSTREAM&bug_status=REOPENED&email1=need-triage&emailassigned_to1=1&emailtype1=substring&query_format=advanced&order=bug_id
11:02:42 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=357  - update cmake to 2.8.8
11:03:18 <lbt> wow ... my browser is *slow*
11:03:44 <lbt> pretty recent, no CVE's etc - low
11:03:52 <lbt> task
11:04:05 <iekku> #info low, task
11:04:16 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=358 - update tmpwatch to 2.11 tmpwatch
11:05:04 <lbt> same
11:05:20 <iekku> #info low, task
11:05:34 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=359  - update libXdmcp to 1.1.1
11:06:02 <lbt> normal probably
11:06:19 <iekku> +1
11:06:37 <iekku> #info normal
11:06:46 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=360  - update libXft to 2.3.0
11:07:13 <lbt> same
11:07:25 <iekku> #info normal
11:07:37 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=361  - update libXaw to 1.0.10
11:07:48 <lbt> same :)
11:07:54 <iekku> :)
11:07:59 <iekku> #info normal
11:08:03 <lbt> hmm
11:08:13 <iekku> hmm?
11:08:15 <lbt> Xaw is the athena widget set ... why ?
11:08:55 <iekku> don't we need it?
11:09:18 <lbt> added a  note: Check with Stskeeps if/why this is needed.
11:09:35 <lbt> make it low
11:10:06 <iekku> #action lbt to check with Stskeeps if/why Xaw is needed (bug 361)
11:10:10 <iekku> #info low
11:10:24 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=362  - update libXau to 1.0.7
11:11:22 <lbt> normal
11:11:27 <iekku> #info normal
11:11:36 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=363  - update pulseaudio to 2.0
11:12:03 <lbt> mmm
11:12:21 <lbt> this is a non-trivial change
11:12:58 <lbt> adding Sage and Stskeeps to cc list
11:13:25 <iekku> #info non-trivial change, Sage and Stskeeps added to cc list
11:13:38 <iekku> more discussion and get back with this on next week?
11:14:05 <lbt> lets set it to normal
11:14:16 <iekku> ok
11:14:19 <lbt> the work needs doing - Stskeeps can decide when to accept it to core
11:14:22 <iekku> #info normal
11:14:26 <iekku> :)
11:14:40 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=364  -update systemd to 44 (or 183?)
11:15:41 <lbt> normal - despite newness, systemd is *very* fast moving at the moment
11:15:50 <iekku> :)
11:16:10 <iekku> #info normal - despite newness, systemd is *very* fast moving at the moment
11:16:20 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=365  - update swig to 2.0.7
11:16:30 <iekku> huge amount of updates btw
11:16:54 <lbt> in swig?
11:17:01 <lbt> or the bug list?
11:17:13 <iekku> bug list
11:17:33 <lbt> yeah - they're useful though
11:18:09 <lbt> thinking low
11:19:23 <lbt> yeah - android and some post Mer-version regression fixes
11:19:47 <iekku> :)
11:19:52 <iekku> #info low
11:20:05 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=366  - update tcl to 8.5.11
11:20:18 <lbt> tcl ... rly?
11:21:20 <iekku> low? :P
11:21:55 * lbt wants a clickable architecture/dependency tree (like the one we wrote for Nokia.,...)
11:22:15 <iekku> lbt, did you just volunteer to write one?
11:22:36 <iekku> but yeah, i agree, it would be usefull
11:22:37 <lbt> got the (gpl) source ... but it's a big package DB ...
11:23:53 <lbt> so low
11:24:38 <iekku> #info low
11:24:48 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=367  - update upower to 0.9.16
11:25:06 <lbt> normal - tracking power related packages is important
11:25:26 <iekku> #info normal - tracking power related packages is important
11:25:37 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=368  - update wayland to 0.85
11:27:10 <lbt> normal, wayland is strategic
11:27:23 <iekku> #info normal
11:27:32 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=369  - update m2crypto to 0.21.1
11:27:39 <lbt> nb... added a See Also to 274 ...lets see how it appears
11:28:21 <Sage> o/
11:28:25 <lbt> hey Sage
11:28:31 * Sage is having bad connection day
11:28:33 <lbt> I'm thinking high
11:28:45 <iekku> ok
11:28:48 <iekku> #info high
11:28:55 <lbt> ISTR some issues in mcrypto anyhow
11:29:08 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=370  - update libXv to 1.0.7
11:30:13 <lbt> normal - Xv is probably used by some vendors for mmedia
11:30:28 <iekku> #info  normal - Xv is probably used by some vendors for mmedia
11:30:37 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=371  - MIN has hardcoded paths to Python.h
11:31:04 <lbt> what's MIN ?
11:31:14 <iekku> i would say high, this might block testing
11:31:29 <iekku> tool used for logging and automated testing
11:31:38 <lbt> link?
11:31:58 <lbt> can I find it from here: http://wiki.merproject.org/wiki/Source
11:32:22 <iekku> http://en.wikipedia.org/wiki/MIN_Test_Framework
11:32:44 <lbt> E-P: ^^ can you add QA tools stuff to the wiki Source page
11:32:49 <E-P> iekku: normal
11:32:52 <iekku> ok then
11:33:04 <iekku> and +1 to lbt
11:33:07 <iekku> #info normal
11:33:07 <E-P> lbt: I can
11:33:27 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=372  - Utilizing 'vendor' term for hardware adaptation projects may hinder collaboration
11:33:57 <lbt> NEEDINFO !
11:34:27 <iekku> +1000
11:34:29 <iekku> :)
11:34:35 <iekku> #info needinfo
11:34:54 <iekku> #topic  Moving on to tasks: https://bugs.merproject.org/buglist.cgi?emailassigned_to1=1&query_format=advanced&bug_severity=task&bug_status=NEEDINFO&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=TRIAGEDUPSTREAM&bug_status=REOPENED&email1=need-triage&emailtype1=substring&order=bug_id
11:35:05 <iekku> #info no tasks
11:35:13 <iekku> #info  Task list is now: https://bugs.merproject.org/buglist.cgi?bug_severity=task&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&email1=not-taken%40&emailassigned_to1=1&emailtype1=substring&query_format=advanced&order=priority%2Cbug_id&query_based_on=
11:35:17 <iekku> #info   Not taken bugs: https://bugs.merproject.org/buglist.cgi?bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=trivial&bug_severity=enhancement&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&email1=not-taken%40&emailassigned_to1=1&emailtype1=substring&query_format=advanced&order=priority%2Cbug_id&query_based_on=
11:35:24 <iekku> #topic review the task list and adjust according to discussion and plans:
11:35:25 <iekku> #link https://bugs.merproject.org/buglist.cgi?bug_severity=task&bug_status=NEEDINFO&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=TRIAGEDUPSTREAM&bug_status=REOPENED&email1=not-taken&emailassigned_to1=1&emailtype1=substring&query_format=advanced&query_based_on=&columnlist=bug_severity%2Cpriority%2Cshort_desc%2Ccomponent
11:36:18 <lbt> I'm thinking we should have a bug review meeting
11:36:35 <iekku> not a bad idea
11:36:36 <lbt> we get a bit bored/jaded by the end of a triage
11:36:59 <lbt> and although today has been good, Stskeeps isn't around
11:37:06 <iekku> :nod:
11:37:39 <iekku> Stskeeps isn't available this week, so let's talk about that on next weeks meeting
11:37:40 <lbt> I also wonder about a bug-squash weekend?
11:37:48 <iekku> and agree timing
11:37:55 <lbt> it could be a useful training thing too
11:38:47 <iekku> :nod:
11:38:52 <lbt> #action arrange a multi-day bug-squashing session (spanning workday+weekend?) to a) fix bugs, b) provide 'training'
11:39:11 <lbt> iekku: would you like to take that?
11:39:16 <iekku> lbt, action for you or?
11:39:33 <lbt> if not then I can do it
11:39:34 <iekku> the problem is that next 3 weeks i have very limited online time
11:39:38 <lbt> sure
11:39:44 <iekku> during weekends
11:40:26 <lbt> yeah - the idea is to provide 'cover' so people who contribute from home or work can get involved
11:40:27 <iekku> lbt, if you could send a start mail?
11:40:48 <iekku> and let's see how people takes the idea
11:40:52 <lbt> will do
11:40:56 <iekku> thanks :)
11:41:42 <iekku> #action iekku to check when bug review meetings are needed and arrange them.
11:41:43 <lbt> OK ... any comments on the task/prio lists?
11:41:49 <iekku> not from my side
11:42:17 <lbt> mmm 230
11:42:26 <lbt> update udev to 181
11:43:40 <iekku> #link https://bugs.merproject.org/show_bug.cgi?id=230
11:43:48 <lbt> superseded by 364
11:45:09 <iekku> as there's not so much info in the bug 230, i would recommend to close that as a dup for 364
11:45:57 <lbt> yep  - was doing... dupe is a better fix than invalid too
11:47:10 <iekku> #info agreed bug 230 to be dup for 364. 364 is providing more information.
11:47:22 <iekku> anything else?
11:47:48 <lbt> no... will take some time to review
11:48:29 <iekku> let's talk about that next week, or in qa meeting
11:48:57 <lbt> ok
11:49:00 <iekku> #topic search for bugs that are assigned:
11:49:01 <iekku> #link  https://bugs.merproject.org/buglist.cgi?bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&columnlist=bug_severity%2Cpriority%2Cassigned_to%2Cbug_status%2Cshort_desc%2Ccomponent%2Cchangeddate&field0-0-0=assigned_to&field0-1-0=assigned_to&query_format=advanced&type0-0-0=notequals&type0-1-0=notequals&value0-0-0=need-triage%40merproject.org&value0-1-0=not-taken%40merproject.org&order=changeddate%2Cbug_id&q
11:49:14 <iekku> thanks for the meeting, see you next time
11:49:27 <iekku> #endmeeting