12:00:10 <E-P> #startmeeting Mer QA meeting 12/07/2012
12:00:10 <MerBot> Meeting started Thu Jul 12 12:00:10 2012 UTC.  The chair is E-P. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
12:00:10 <MerBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:00:21 <E-P> #topic Current status
12:00:50 <E-P> I made a task list for QA automation
12:00:53 <Stskeeps> #info copyproject finally works, we can now do per-change full repositories
12:00:56 <lbt> o/
12:01:22 <E-P> nice
12:01:25 <E-P> #link https://wiki.merproject.org/wiki/Quality#ToDo
12:01:56 * timoph is on a train with very sucky connectivity
12:02:17 <mikhas> timoph, pull the emergency breaks. priorities, you know
12:02:23 <timoph> :)
12:02:25 <E-P> timoph: you are refactoring the tr-ui?
12:02:33 <timoph> yes
12:02:41 <E-P> #info timoph is refactoring tr-ui
12:02:43 <timoph> going to rewrite the ui
12:03:25 <E-P> good to hear
12:03:26 <timoph> within the next 2 weeks
12:04:06 <timoph> I have some time to spend on it from my usual project work
12:04:24 <timoph> pays off to have shorter vacation than others :)
12:04:32 <E-P> hmm.. phaeron is missing, he was working with the vm image and automation?
12:05:44 <E-P> I should have also a bit more time during the next weeks
12:06:03 <E-P> I was planning to setup the QA-report and ots for my server for testing
12:06:05 <Sage_> o/
12:06:12 <Stskeeps> E-P: if you need a vm, let us know
12:06:39 <E-P> Stskeeps: ok, we will at somepoint
12:06:47 <E-P> I want to check couple of stuff before
12:07:09 <Stskeeps> :nod:
12:07:32 <E-P> OTS and QA-report have changed a bit since I last touched to them
12:07:53 * lbt would like to review OTS and how it fits with BOSS
12:08:01 <timoph> one more thing regarding tr-ui. if there's something in the ui that needs to be changed file a feature request
12:09:21 <E-P> lbt: yes, we discussed about that long time ago. I would like to get it first doing something and then we can change it
12:09:32 <lbt> *nod*
12:09:41 <E-P> I will add to the todo :)
12:10:32 <lbt> really it's about making a decision for the long term so we know what our goal is ... any short term steps in the right direction are fine
12:11:07 <E-P> nod
12:12:53 <E-P> anything else too add?
12:13:09 <Stskeeps> good progress going forward, i'd say
12:13:29 <E-P> oh, so what is the status about tdriver and ruby?
12:13:44 <Stskeeps> that everybody now hates ruby gems, but a workaround was found
12:13:56 <E-P> wuhuu :)
12:14:29 <E-P> so the ruby and some of the rubygems are made to rpm?
12:14:36 <E-P> for sdk?
12:14:57 <Stskeeps> yes
12:14:58 <lbt> I made them a release blocker for the SDK
12:15:10 <Sage_> Stskeeps: :)
12:15:11 <lbt> so they will be in the next one ... however long it takes
12:15:59 <E-P> #info workaround found for packaking ruby and ruby's gems, will be in the next SDK release
12:16:40 <Stskeeps> the goal for current mer release is to deploy in such a way that we can proper QA enabling
12:16:43 <Stskeeps> won't go out before
12:16:43 <Stskeeps> :P
12:17:07 <lbt> Yep, also I've been working on minimal Mer and part of that is enabling networking. So this allows wifi to be configured using config files on N00/ExoPC etc (essentially Connman)
12:17:11 <Stskeeps> E-P: was there ever anything about bug metrics, btw?
12:17:16 <Stskeeps> to trace quality in that area too
12:18:03 <E-P> Stskeeps: iekku had that idea long time ago, good that you raised it up
12:18:55 <E-P> I forgot it, but I will do that with iekku (she knows the best how to do that)
12:19:05 <Stskeeps> ok, let's #action that?
12:19:09 <E-P> for the next meeting I try to get some figures
12:19:42 <E-P> #action E-P Bug metrics for the next QA meeting
12:20:54 <E-P> we can maybe follow them bi-weekly or once in a month
12:21:08 <E-P> or after the releases
12:21:17 <Stskeeps> :nod:
12:21:28 <Stskeeps> if we can get towards a dashboard kind of thing, it'd help releases too
12:21:41 <Stskeeps> as the idea is to scale up and see input on various releases from vendors too
12:23:00 <E-P> do we have any plans about the daskboard? something like meego dashboard?
12:23:37 <timoph> do we have people who are able to work on it?
12:23:38 <Stskeeps> maybe
12:23:46 <Stskeeps> just conjuring up an idea
12:24:11 <E-P> but I like the idea, I was planning to implement similar for Qt Commercial releases
12:24:32 <E-P> (when I worked for them)
12:24:41 <mikhas> does mer do time-based releases?
12:24:56 <timoph> maybe add that to the todo list to be implemented after the prequisities for it are running
12:25:00 <Stskeeps> mikhas: general idea is that we release when stable, in a continous integration like fashion
12:25:18 <Stskeeps> mikhas: we try for 14-21 days, but as time goes, we might spend more time on stable-r branches
12:25:22 <mikhas> but when to integrate new vendor releases?
12:25:31 <E-P> Stskeeps: any task bug about the dasboard? i could add my ideas to it
12:25:38 <Stskeeps> E-P: no, feel free to make one
12:25:49 <Stskeeps> mikhas: vendor releases?
12:25:51 <E-P> Stskeeps: ok
12:25:56 <mikhas> err well, upstream stuff
12:25:58 <E-P> timoph: yep
12:26:27 <timoph> E-P: good thing to have in any case
12:26:28 <Stskeeps> mikhas: the goal is that if we can do it in a fashion that it does not cause regression, it gets included
12:26:37 <Stskeeps> mikhas: on stable branches there might be harder criteria
12:27:23 <lbt> the main issue then is defining and identifying a regression
12:28:18 <Stskeeps> mikhas: https://wiki.merproject.org/wiki/Process is a good read on where we're trying to go
12:32:10 <E-P> something else to report?
12:32:34 <lbt> I'd like to see a rolling task list
12:33:14 <lbt> I know we've been blocked on automated images ... but now theyr'e here... what next?
12:33:40 <timoph> get tests running?
12:33:42 <lbt> we may also want to identify core packages test coverage
12:33:58 <lbt> timoph: yeah - so which packages - and how do we run them?
12:34:08 <Stskeeps> start out simple, smoke test like?
12:34:15 <timoph> yeah. we need a coverage chart
12:34:20 <lbt> just noting that that is a task which wasn't blocked by lack of automation
12:34:34 <Stskeeps> yes, work to start making tests isn't blocked anymore
12:34:36 <lbt> so having a qa TODO list would really help
12:34:37 <timoph> lbt: for starters I'd use whatever we have available and works
12:34:56 <E-P> lbt: https://wiki.merproject.org/wiki/Quality#ToDo
12:35:01 <E-P> that is a simple todo
12:35:03 <timoph> just to see how the toolchain works
12:35:33 <lbt> E-P: OK - can we review and action it each week ?
12:35:53 <E-P> lbt: sure
12:36:20 <lbt> just so the meeting has some focus once we've done a round table :)
12:36:28 <timoph> :)
12:36:50 <lbt> timoph: adding a coverage chart/table to that list would be good
12:36:55 <E-P> #action E-P for the next QA meeting topic about QA todo list
12:37:06 <lbt> related to cor pkg + architecture grouping
12:37:10 <lbt> maybe
12:37:18 <E-P> lbt: yep, something like that
12:37:54 <lbt> then we can identify specific packages which need tests and action the,
12:37:55 <lbt> m
12:38:41 <lbt> we could also do with a document "so you want to add tests to a package... here's how"
12:39:00 <E-P> Stskeeps: you made some list about the core packages and their architecture groups?
12:39:12 <Stskeeps> yes, i have that
12:39:38 <Stskeeps> feel free to poke me at some point (not right now) and i'll fork it over
12:40:05 <E-P> Stskeeps: ok
12:41:06 <E-P> lbt: we can add all your ideas/wishes to the todo for the next meeting
12:41:37 <lbt> yep - just looking to identify some concrete and bite-sized QA tasks for contributors
12:41:40 <E-P> we have a process how to change/add tests
12:41:58 <E-P> lbt: good
12:43:31 * timoph ponders where all these broken pipes end up :p
12:44:33 <Paimen> I'll try to start contributing to tdriver side
12:45:01 <timoph> anyway, do we use bugzilla for the qa backlog?
12:45:11 <timoph> or something else?
12:45:13 <E-P> timoph: yes
12:45:19 <timoph> ack
12:45:28 <E-P> I will add to the wiki the main/major items, and link to bugzilla
12:46:01 <timoph> I'll try to add things I'm working on with tr-ui also there for visibility
12:46:26 <E-P> good
12:47:10 <timoph> not very detailed things but to give a general idea what's happening
12:49:03 <E-P> if nothing else then we are done for today
12:49:09 <Stskeeps> yep thank you for hosting :)
12:49:21 <E-P> for the next meeting we will have many topics
12:49:29 <E-P> thanks for participating!
12:49:32 <lbt> thanks
12:49:38 <E-P> #endmeeting