#mer-meeting: SailfishOS, open source, collaboration

Meeting started by tbr at 15:00:01 UTC (full logs).

Meeting summary

  1. 1. Introduction of meeting participants (tbr, 15:00:42)
    1. Carsten Munk - Chief Research Engineer @ Jolla (Stskeeps, 15:00:47)
    2. Thomas Ruecker, community person, Tieto employee, today not wearing any hats, just the meeting chair. (tbr, 15:00:55)
    3. lbt I'm a Mer co-founder and a Sailor too. I look after the public Mer infra, mer-tools and the Mer SDK which provide systems and tools to enable contributions. Systems includes stuff like bugzilla, gitlab, OBS, IMG, BOSS etc etc (lbt, 15:00:55)
    4. would like to consider myself a community member of mer/nemo projects doing mainly device adaptation work. Other hat, working with a vendor internally on a product based on Mer (vgrade_, 15:01:01)
    5. Marc Dillon (marc3, 15:01:08)
    6. Filip Kłębczyk, Upper Silesia region, Poland - feeling as a part of community, interested mainly in contributing to Nemo MW parts. Interested in all actions that would make Mer/NemoMW more contributor friendly. (fk_lx, 15:01:15)
    7. I am Developer, ex-Meego hacker and I have been lately playing with other half HW (Myhalf). I am here for curiosity in where is the community heading to and for being part of it. (JvD_, 15:01:18)
    8. Artem Marchenko: 6 apps in jolla store, 4 in ovi store, day job iOS app with thousands of daily users. Hope to hear abt final apps dev perspective: how community could work on adapting standard open source practices to harbour requirements (or adapt requirements to be easier). E.g. work on tools for bundling libs in, improving RPM checker rules, how-when-when-who to decide on access control. (artemma, 15:01:19)
    9. Raine Mäkeläinen - Engineer @ Jolla (rainemak, 15:01:28)
    10. Tommi Keisala (JvD_, 15:01:29)
    11. I'm working at Adeneo Embedded; my goal was to check how easy (or hard) it is to adapt Mer/Nemo on a board (Anarky, 15:01:32)
    12. w00t long-term Mer/Nemo contributor, Qt Project approver, and open source hacker. My most recent hat is that I'm one of the Jolla folks, since sometime in 2012. I hack on many things. (w00t, 15:01:33)
    13. Denis Zalevskiy, Jolla. cutes(-js), statefs, the-vault. Helps phdeswer with energy management sw stack maintenance (kernel/upower) (deztructor, 15:01:34)
    14. Pekka Lundström working on Jolla, mostly involved with dsme, mce, systemd and other non-UI parts (plundstr, 15:01:48)
    15. Iekku Pylkkä, head of developer affairs @ jolla, mer bugazilla maintainer and member of advisort board (iekku, 15:01:50)
    16. Christophe Chapuis - Jolla user, and also an open-source developer, and I'm here because I'm interested in the way Jolla can handle and improve the collaboration with open-source communities. (Tofe, 15:01:53)
    17. Antoine Reversat, community member, just here to see what is going to be said and maybe voice some concerns (crevetor, 15:01:54)
    18. Vesa-Matti Hartikainen, work for Jolla, developing Browser (veskuh, 15:01:55)
    19. Tommi Tauriainen, LTE SW Engineer @ Broadcom (_Razor_, 15:02:02)
    20. Here to spy where the community is going (squidd, 15:02:13)
    21. Aleksi Suomalainen Community member (locusf, 15:02:23)
    22. Lucien Xu, developer for Nemo / SailfishOS (Sfiet_Konstantin, 15:02:28)
    23. Timo Jyrinki has too many hats, but free software mobile phones development via Openmoko/MeeGo/Ubuntu and a happy Jolla user (Mirv, 15:02:40)
    24. Andrea Bernabei - Nemomobile contributor and Jolla user (faenil, 15:02:41)
    25. Marko Sauko - Chief Engineer @ Jolla. Also was maintaining Nemo Mobile project on my free time earlier. (Sage-, 15:02:41)
    26. Santeri Toikka, student, developer, working on paper about open software business models (sjtoik, 15:02:42)
    27. Philippe De Swert, Jolla, middleware and kernel engineer (phdeswer, 15:02:43)
    28. kontio Sailor @ Jolla, I have an eye on various QA issues... (kontio, 15:02:45)
    29. developer for nemo and sailfish (niqt, 15:02:54)
    30. Dumb user and linux embedded enthusiast ... Sysadmin in real life (dr_gogeta86, 15:02:54)
    31. Eric Le Roux Bugzilla + T.J.C admin @ Jolla (eleroux, 15:02:55)
    32. Steve Jayna, Jolla IT (sdjayna, 15:03:01)
    33. Pami Ketolainen, the Bugzilla guy @ Jolla (pketolai, 15:03:01)
    34. ZogG Maemo community member (ZogG_laptop, 15:03:05)
    35. Jarko Vihriälä - SailfishOS SDK (jake9xx, 15:03:13)
    36. Carol Chen, Community chief at Jolla, managing community related activities and events, social media, etc., assisting iekku in developer affairs when possible (cybette, 15:03:17)
    37. Student & Jolla user, following as a unix enthusiast and developer (Yaniel, 15:03:20)
    38. Pekka Vuorela - engineer at jolla, text input, calendar, settings etc. (pvuorela_, 15:03:21)
    39. Mohammed Hassan SW engineer @ Jolla and FOSS hacker/contributer (mostly listening) (MSameer, 15:03:32)
    40. Simonas Leleiva, in Mer/Nemo community since 2012, Nemo twitter account maintainer, SailfishForAndroid developer @ Jolla (sledges, 15:03:54)
    41. Giulio Camuffo, Sailor, qt5 and wayland (giucam, 15:03:59)
    42. Jukka Eklund, community guy, Jolla advisor (jukkaeklund, 15:04:15)
    43. Martin Kolman - community member & application developer (modRana flexible navigation system) (M4rtinK, 15:04:21)
    44. Olli-Pekka Heinisuo, developer, student, Jolla user, made the power half and solar half, interested in contributing (skvark, 15:04:35)
    45. Leif-Jöran Olsson foss developer, ported fbreader, listening mostly. (ljo, 15:05:03)
    46. Steph Gosling interested community member (stephg, 15:05:07)
    47. Soumya Bijjal, program manager/sailor (bijjal, 15:05:51)
    48. Lauri Nurmi, 1 app in jolla store; participating this meeting as only as observer, probably. (ln-, 15:06:00)
    49. Karl Granström, Jolla store & Harbour / sailor (grande_, 15:06:30)
    50. Kimmo just listening for now (until goes HW related) (kimmoli, 15:07:21)
    51. Jens Weller, C++ & Qt Developer + Meeting C++ website/conference (meetingcpp, 15:07:56)
    52. Stezz: Da board (stezz_da_board, 15:08:46)

  2. 2. When's the next meeting - Regular meetings every two weeks around the project? (tbr, 15:09:06)
    1. Jozef Mlich (xmlich02/jmlich) is developer of foursail; maintainer of czech and slovak translations in openrepos. Sometimes speak about jolla at local conferences (installfest, linuxalt) (xmlich02, 15:09:12)
    2. Ragnar Kurm Doing my first Jolla app, otherwise talking all major programming languages (ca 30) and doing websites on Drupal (ragnarkurm2, 15:09:39)
    3. so the idea is that while we have one meeting now, it seems like a good idea, because of the many diverse topics, that we do this every 14 days and the question is, is it a good time for people? are people interested in syncing about community's issues and so on? (Stskeeps, 15:10:18)
    4. inital proposal is every 14 days, MSameer proposes to have it initially every week until things are ironed out (tbr, 15:12:28)
    5. move around time within the day in the long run to accommodate other time zones (tbr, 15:14:41)
    6. AGREED: weekly meetings in the beginning (tbr, 15:15:12)
    7. AGREED: biweekly later (tbr, 15:15:20)

  3. 3. How to make contributing to Nemo/Mer/SailfishOS easier (tbr, 15:15:28)
    1. so long story short, a lot of the problems we have is because it is difficult to contribute to SailfishOS; this topic is a big one; and it needs to identify solutions and proposals for fixing these things (Stskeeps, 15:16:24)

  4. 3.1. Current problems and situation, potential solutions (tbr, 15:16:58)
    1. https://lists.sailfishos.org/pipermail/devel/2014-April/003915.html (vgrade_, 15:18:06)
    2. https://lists.sailfishos.org/pipermail/devel/2014-April/003829.html (tbr, 15:18:23)
    3. http://www.mail-archive.com/mer-general@lists.merproject.org/msg01426.html (Sfiet_Konstantin, 15:20:31)
    4. Information about what packages there are and what they do is needed (lbt, 15:30:26)
    5. Bugzilla should be used more (!) (lbt, 15:30:32)
    6. Roadmaps and direction needed for MW and core packaged (lbt, 15:30:37)
    7. Guidance on use of systems (lbt, 15:30:41)
    8. Contribution flow needs to be clearer (lbt, 15:30:45)
    9. more clarity in community contributed hw adaptations for sailfish (tbr, 15:31:12)
    10. from faenil: How are we/you going to handle issues/bugs of OSS components? From what I understood, Jolla is not using Nemo bugzilla at the moment, and not even GitHub...is that going to change? How? (tbr, 15:33:32)
    11. from fk_lx: if Jolla contribute, but should clearly inform about their future plans and explain design decissions whenever possible: "we chose X over Y, because X is faster, better" etc (Sfiet_Konstantin, 15:34:31)
    12. http://www.mail-archive.com/mer-general@lists.merproject.org/msg01426.html for context on Mer/Nemo merging, as well, to help clean up things a bit (Stskeeps, 15:34:47)
    13. w00t points out the lack of governance in Mer/Nemo at the moment (tbr, 15:34:59)
    14. <+kontio> a "How do I start to contribute" article on sailfishos.org (tbr, 15:38:50)
    15. < Sfiet_Konstantin> trying to follow fk_lx's ideas and w00t's, I think that features that future features that will be developed in Nemo MW should (must ?) be announced in the ML (tbr, 15:39:12)
    16. < fk_lx> open roadmap for each of open sourced components (Nemo MW, Sailfish Browser etc. etc.) (tbr, 15:39:32)
    17. architectural approval of new packages (business as usual) through mailing list.. (Stskeeps, 15:39:59)
    18. < meegobit> I suggest creating a meta-repo with subtree-merge of each projects repo, I've used this with great success (tbr, 15:40:49)
    19. <+jake9xx> get the tools and infrastructure in shape that such contribution is possible and not too hard (tbr, 15:41:03)
    20. <+jukkaeklund> open wiki to sailfish.org (tbr, 15:41:44)
    21. a clear path to becoming a regular contributor (& gaining rights to contribute), "governance revival", so to speak (w00t, 15:41:51)
    22. links that state what repos + git tags/commits are == to what's in sailfishos build at the moment (Stskeeps, 15:42:28)
    23. ask components maintainers to write architectural README, and doc if possible (Sfiet_Konstantin, 15:44:37)

  5. 3.2. Solution proposal: Minimal/practical openness requirements and process for open source components in Mer/Nemo/SailfishOS (tbr, 15:46:07)
    1. overview http://etherpad.dereferenced.net/p/SOSSPrep (tbr, 15:50:06)
    2. more permanent link: http://pastebin.com/zX1WUaY6 (w00t, 15:50:15)
    3. meego lover, sailfishOS developper in the making :) (after few years of Android experience) (meegobit, 15:55:50)
    4. README/doc gardening is an important thing; attention to it should be paid at the same level as developing (obviously, it doesn't require as much effort, it just needs conscious attention to improve) (w00t, 16:03:15)
    5. could autodoc help here, lbt and aard bring up this topic (tbr, 16:03:15)
    6. CVE tracking in components is important, and lacking (w00t, 16:04:11)
    7. CVE tracking on mer/nemo/sailfish level should be considered/automated (tbr, 16:04:40)
    8. TODO/ROADMAP information shouldn't be too granular, otherwise it risks becoming outdated easily or plain useless (w00t, 16:05:02)
    9. < meegobit> for someone arriving from Android, we'd look for some page which is visually appealing, easy to understand, with the relevant developper-work-flows exposed (tbr, 16:05:06)
    10. what-is-a-good-mainteiner - extra responsibilities, needed to be conveyed nicely chiefs of projects (so we have best yield in maintainers-volunteers) (sledges, 16:05:27)
    11. governance is, once again, a weak point (w00t, 16:05:54)

  6. 3.3 Action proposal: Participation and contribution policy for Jolla's open source contributors in open source projects (tbr, 16:06:05)
    1. One thing that has been brought up is the perceived attitude of Jolla's open source contributors and a bit unclearity of our intentions in open source - marketing vs factual action in open source. (Stskeeps, 16:07:04)
    2. To show we mean business in open source project participation, today we have published our participation and contribution policy for Jolla's open source contributors in open source projects at (Stskeeps, 16:07:09)
    3. https://together.jolla.com/question/39552/what-is-the-participation-and-contribution-policy-for-jollas-open-source-contributors-in-open-source-projects/ (Stskeeps, 16:07:14)
    4. It's meant as both an internal policy and something for community members and participants of open source projects to better understand how to deal with Jolla employees, their actions, statements, etc. where they're encountered, in and outside official communication channels. (Stskeeps, 16:07:24)
    5. This will of course also affect many other topics that we have discussed today - and drive the adoption of good open development. It aligns very much with the values of Jolla to do so. (Stskeeps, 16:07:31)

  7. 3.4 Wrap-up and finalizing action points (tbr, 16:12:02)
    1. https://www.youtube.com/watch?v=ZSFDm3UYkeE (fk_lx, 16:14:29)
    2. AGREED: Next meeting 2014-04-22T15:00 UTC (tbr, 16:16:49)
    3. discussion about time slot for the meetings that will follow to be held on the sailfish-dev mailing list (tbr, 16:17:15)
    4. next meeting will not be about following up on actions but remaining topics (tbr, 16:18:20)
    5. AGREED: next meeting agenda will be: community open source package repository (think maemo extras) and Closed bits of SailfishOS - why/where/how and relation to open source parts, and Plans on SailfishOS for Android (tbr, 16:22:03)
    6. meeting minutes will be posted to the sailfish-dev mailing list, follow up discussion there (tbr, 16:24:17)
    7. we need a chair for the next meeting, as tbr will NOT be available as chair for that one for topic discussion reasons (tbr, 16:24:50)
    8. AGREED: cybette chairs next weeks meeting (tbr, 16:26:54)
    9. from artemma: contributions to silica docs should go to the #info for an earlier topic (lbt, 16:29:42)


Meeting ended at 16:30:09 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. tbr (159)
  2. w00t (75)
  3. fk_lx (69)
  4. Sfiet_Konstantin (66)
  5. lbt (63)
  6. Stskeeps (58)
  7. faenil (45)
  8. artemma (39)
  9. MSameer (37)
  10. Yaniel (33)
  11. deztructor (18)
  12. dr_gogeta86 (18)
  13. iekku (17)
  14. meegobit (16)
  15. Tofe (15)
  16. stezz_da_board (14)
  17. stephg (13)
  18. ZogG_laptop (13)
  19. jake9xx (11)
  20. Aard (11)
  21. locusf (10)
  22. Uninstall (9)
  23. Sage- (9)
  24. sledges (9)
  25. cybette (9)
  26. veskuh (7)
  27. crevetor (7)
  28. marc3 (6)
  29. kontio (6)
  30. Anarky (6)
  31. M4rtinK (6)
  32. jukkaeklund (6)
  33. vgrade_ (5)
  34. squidd (5)
  35. ragnarkurm2 (4)
  36. eleroux (4)
  37. _Razor_ (4)
  38. niqt (3)
  39. grande_ (2)
  40. Merbot (2)
  41. meetingcpp (2)
  42. giucam (2)
  43. ljo (2)
  44. bijjal (2)
  45. JvD_ (2)
  46. skvark (2)
  47. goroboro (1)
  48. xmlich02 (1)
  49. sdjayna (1)
  50. kimmoli (1)
  51. Mirv (1)
  52. rainemak (1)
  53. pvuorela_ (1)
  54. Bundyo (1)
  55. phdeswer (1)
  56. ln- (1)
  57. debexpert (1)
  58. plundstr (1)
  59. pketolai (1)
  60. sjtoik (1)
  61. peppelakappa (1)
  62. Jolla (0)
  63. Community (0)


Generated by MeetBot 0.1.4.