#mer-meeting: SailfishOS, open source, collaboration, 13/May/2014

Meeting started by Stskeeps at 10:00:26 UTC (full logs).

Meeting summary

    1. Please when adding topics to the piratepad, add your name and a small description of the topic (so we can ask for elaboration), it helps to prepare for meeting (Stskeeps, 10:00:26)

  1. Quick introductions (5 minutes), prefix your info with #info (Stskeeps, 10:00:38)
    1. Carsten Munk, Chief Research Engineer @ Jolla (Stskeeps, 10:00:39)
    2. Aleksi Suomalainen Community Member (locusf, 10:01:07)
    3. Basil Semuonov, developer (BasilSemuonov_, 10:01:22)
    4. Steph Gosling, Community Member (stephg, 10:01:38)
    5. Filip Kłębczyk, blogger about Jolla, maybe still Jolla community, whatever you want to call me (fk_lx, 10:01:40)
    6. Lorn Potter, developer @ Jolla (lpotter, 10:02:16)
    7. Marko Saukko, worked with Nemo and Mer sometime ago. Now working for Jolla and contributing to Mer and Nemo when possible. (Sage-_, 10:02:31)
    8. Aaron McCarthy, developer @ Jolla Location, Connectivity, Qt. (amccarthy, 10:02:40)
    9. Mikko Ahlroth, software developer at Vincit Oy, developer of SailTime. Going to follow the discussion from the sidelines (Nicd-, 10:02:51)
    10. David Greaves - Mer infra and chum. Also Jolla sailor :) (lbt, 10:03:10)
    11. Carol Chen, community chief at Jolla (cybette2, 10:03:24)
    12. Eric Le Roux - Bugzilla & t.j.c admin (eleroux, 10:03:25)
    13. Iekku Pylkk�, head of developer affairs @jolla (iekku, 10:03:33)
    14. Denis Zalevskiy, Jolla, middleware etc. (deztructor, 10:03:41)
    15. Giulio Camuffo, developer @ Jolla, qt, wayland, other stuff if needed (giucam, 10:04:04)
    16. Simonas Leleiva, community member, Jolla sailor (sledges, 10:04:39)
    17. Soumya Bijjal, sw program manager @ jolla (bijjal, 10:04:43)
    18. vgrade, community, adaptations (vgrade, 10:05:09)

  2. Chum sync (lbt, basil, tbr) - 30 mins (Stskeeps, 10:05:27)
    1. This is more of a floor discusssion, lbt/Basil/tbr? - can we synchronise on what's been going on with Chum? (Stskeeps, 10:05:27)
    2. http://merproject.org/meetings/mer-meeting/2014/mer-meeting.2014-04-22-15.00.html minutes from last meeting where chum was discussed (Stskeeps, 10:09:03)
    3. Next steps for lbt: Assemble boss validation steps (Stskeeps, 10:09:25)
    4. merproject.org OBS upgrade, as it's currently ancient (Stskeeps, 10:09:34)
    5. Basil has been working on openrepos bridge to OBS: packages may be imported once builded, and if application is linked to obs, no manual rpm upload is allowed for that app. obs builded apps have own 'badge' that app is FOSS and builded on OBS infra. Warehouse by default can only show 'trusted' and 'obs foss' software, as safe for user. show all other packages can be enabled after warning banner (Stskeeps, 10:09:59)
    6. http://wiki.maemo.org/Extras-testing (Stskeeps, 10:13:04)
    7. ACTION: stskeeps to dig up copy of apps4meego qa material (Stskeeps, 10:16:59)
    8. It would be nice to support package priorities in rpmdb for resolver decisions. eg: 'update, and this 12 packages will be removed', or 'stay as is' (lbt, 10:28:40)

  3. More closed source discussion (Carsten) - how can the community help - 30 minutes (Stskeeps, 10:35:21)
    1. There was a bit on unclarity from my last meeting on what hat I was wearing, so I'm repeating it here with a Jolla hat. (Stskeeps, 10:35:31)
    2. Silica is not open source currently. State is that there's no exception granted (see policy for open source contribution listed in the other meeting) for open sourcing the current codebase, which is BSD-licensed QML and closed source C++, but there is a desire. Work to get that exception is ongoing. (Stskeeps, 10:35:34)
    3. This is more of a Q&A discussion, please ask some questions, let's see if we can answer right away, or need to get a better understanding and get back to the question (Stskeeps, 10:35:39)
    4. reply on sailfish-devel: Stskeeps: when we speak about closed source there's always a group of people of people who're interested in replacing closed components with open ones -- are there anybody here who are looking at alternatives? (sledges, 11:02:59)
    5. re: Jolla roadmap publishing: <bijjal> sledges: we are on it, there will be an email during this week (sledges, 11:03:36)
    6. ACTION: organisers for us to have an independent non-hat wearing moderator for each meeting (Stskeeps, 11:04:07)

  4. Accepting graphical contributions by community - 25 minutes (Stskeeps, 11:05:33)
    1. Could somebody explain what this is about? (Stskeeps, 11:05:33)
    2. ACTION: iekku to investigate how to handle icon themes in harbour + custom ambiances (sledges, 11:13:38)
    3. Regarding design stuff there are quite a few threads in TJC marked with ui ux tags that the Design team can take a look at. (Stskeeps, 11:21:00)
    4. Light backgrounds: quickly: a lot of icons are white instead of black (Stskeeps, 11:21:12)
    5. a lot of jolla guys are stuffed inside a room on next time for this meeting, we might have to limit topics/move some to another day (Stskeeps, 11:25:36)
    6. Move to non-date etherpad (Stskeeps, 11:30:25)


Meeting ended at 11:30:57 UTC (full logs).

Action items

  1. stskeeps to dig up copy of apps4meego qa material
  2. organisers for us to have an independent non-hat wearing moderator for each meeting
  3. iekku to investigate how to handle icon themes in harbour + custom ambiances


Action items, by person

  1. iekku
    1. iekku to investigate how to handle icon themes in harbour + custom ambiances
  2. UNASSIGNED
    1. stskeeps to dig up copy of apps4meego qa material
    2. organisers for us to have an independent non-hat wearing moderator for each meeting


People present (lines said)

  1. Stskeeps (119)
  2. SK_work (64)
  3. lbt (45)
  4. dr_gogeta86 (35)
  5. sledges (25)
  6. BasilSemuonov_ (25)
  7. alterego (19)
  8. NSA-Rep (14)
  9. deztructor (13)
  10. fk_lx (11)
  11. chriadam|meeting (9)
  12. javispedro (7)
  13. iekku (6)
  14. stephg (4)
  15. bijjal (3)
  16. lpotter (2)
  17. Merbot` (2)
  18. VDVsx (2)
  19. w00t (2)
  20. Nicd- (2)
  21. locusf (2)
  22. vgrade (1)
  23. cybette (1)
  24. Aard (1)
  25. Sage-_ (1)
  26. giucam (1)
  27. eleroux (1)
  28. cybette2 (1)
  29. amccarthy (1)


Generated by MeetBot 0.1.4.