10:00:00 <netzvieh> #startmeeting SailfishOS, open source, collaboration: 03-June @ 10:00 UTC
10:00:00 <Merbot`> Meeting started Tue Jun  3 10:00:00 2014 UTC.  The chair is netzvieh. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
10:00:00 <Merbot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
10:00:05 <netzvieh> #info Welcome to another week of SailfishOS OSS and collaboration meeting
10:00:05 <netzvieh> #info Meeting info and agenda: https://lists.sailfishos.org/pipermail/devel/2014-June/004454.html
10:00:05 <netzvieh> I'm the meeting chair for today and will be keeping time and order. Please behave and show mutual respect, and let's have a productive discussion.
10:00:11 <netzvieh> #topic Brief introductions (5 min), prefix your information with #info
10:00:18 <netzvieh> #info Sebastian Meyer, normally community member, hatless chair today
10:00:47 <tbr> #info Thomas Ruecker, community member, pushes open source and sometimes chum topics
10:01:02 <lbt> #info David Greaves - Mer guy and sailor
10:01:03 <sledges> #info Simonas Leleiva, member and sailor
10:01:15 <phdeswer> #info Philippe De Swert, sailor
10:01:22 <JvD_> #info Tommi Keisala, Jolla user and community member
10:01:38 <stephg> #info Steph Gosling, community
10:02:05 <Nicd-> #info Mikko Ahlroth, Jolla user, community member, developer of SailTime
10:02:07 <artemma> #info Artem Marchenko: Flashlight, Quick Launcher, Night Silence, HelloWorld Pro, etc. Managing iOS and Android apps and mobile sites in day time job. Mostly watching meeting for signs of commercial opportunities hoping to provide a greedy 3rd party dev perspective.
10:02:22 <coderus> #info Andrey Kozhevnikov, indie developer, opensource contributor
10:02:23 <leszek> #info Leszek Lesner, community member, jolla user, developer
10:02:47 <phaeron> #info Islam Amer, sailor
10:03:03 <VDVsx> #info Val�rio, open source contributor, sailor, mostly lurking today
10:03:11 <sdjayna> #info Steve Jayna, Infrastructure @ Jolla
10:03:17 <grande> #info Karl Granström, sailor
10:03:33 <cybette> #info Carol Chen, Community bunny @ Jolla
10:03:46 <sledges> *g*
10:03:52 <cybette> #info Iekku Pylkkä, Head of Developer Affairs @ Jolla, visiting doctor and will join meeting as soon as she can
10:03:52 <netzvieh> community bunny :D
10:04:09 <amccarthy> #info Aaron McCarthy, Position/Location, Connectivity, @ Jolla
10:04:13 <Sage_> #info Marko Saukko, sailor
10:04:16 <xfade_> #info Niels Breet, Store/services/infra @ Jolla
10:04:23 <artemma> that's an important first step towards a bunny community :)
10:04:29 <sledges> :D
10:04:33 <cybette> netzvieh: yeap, i hop around getting people excited about sailfish
10:04:49 <cybette> artemma: careful, we reproduce like crazy!
10:04:57 <netzvieh> hmm bartender economy and bunny community
10:05:05 <netzvieh> #topic Harbour and SailfishOS apps compatibility (30 min)
10:05:10 <faenil> #info Andrea Bernabei, nemomobile contributor with BIG adsl issues
10:05:11 <netzvieh> BasilSemuonov: would you like to address the topic?
10:05:15 <artemma> cybette: are you trying to scare me with the reproduction-related processes? :)
10:05:30 <faenil> I'm having big issues with my connection *right now* :(
10:05:47 <BasilSemuonov> i'm here, just joined
10:05:54 <BasilSemuonov> #info Basil Semuonov, developer
10:06:17 <BasilSemuonov> netzvieh, basically, all the info and statement are at agenda
10:06:21 <cybette> artemma: that's for me to know ...
10:06:31 <BasilSemuonov> if any info required, I can post here.
10:06:51 <netzvieh> BasilSemuonov: I'd like to have a short intro for the minutes and people here
10:06:52 <cybette> BasilSemuonov: will be nice to summarize as #info
10:06:52 <sledges> #link line 27 http://piratepad.net/SailfishOSSMeetings (or the one starting with "Harbour & SailfishOS apps compatibil...")
10:06:56 <cybette> netzvieh: +1
10:07:14 <cybette> sledges: the piratepad gets overwritten every week
10:07:20 <BasilSemuonov> okay, so
10:07:31 <sledges> whoops thanks :)
10:07:38 <BasilSemuonov> #info Statement: Problem with SailfishOS fragmentation is coming. Harbour/Store is not prepared for it.
10:07:49 <BasilSemuonov> Description: Now we have 1 device running official SailfishOS - the Jolla Phone. And one major SailfishOS version running on devices.
10:07:49 <BasilSemuonov> One day Jolla will release another device. Also, SailfishOS targets to be on android devices, and once SailfishOS will be ported, lots of supported devices will appear. This will cause fragmentation in terms of 'base' specs of devices. To make it clear, i'm not talking about 'this smartphone have an attachable DVD-ROM, and that will have ultra-3D-touch surface'. I'm talking about screen resolution & aspect, CPU & GPU performance, amount of RA
10:07:49 <BasilSemuonov> M. Most of devices will have 1gb+ ram, 2+ cores, 16:9/16:10 aspect.
10:07:50 <BasilSemuonov> Of course, SailfishOS versions will be different on all devices, since there are some hardware problems, or just timeframe related 'complication' issues during new SailfishOS version release time.
10:07:53 <BasilSemuonov> Every-day apps like notes/music player/etc will probably work just fine. Some of 3d enabled games will. But most of gorgeous apps would break the leg here: some should not be runned on square resolultion, some require atleast 2gb of RAM to work as expected and provide neat user experience. Or imaging 'streaming apps', that require LTE support for fast connection.
10:07:58 <BasilSemuonov> Also, SailfishOS is rapidly developing. Dont you say that you will always use Qt 5.2 core libs? What if Qt releases 6.x in a month with 'breaking quantum-state-processor support', and it will installed in every 2 of 3 flagship phones. What will happen to all already published apps, if you change some of core packages to new major version?
10:08:06 <BasilSemuonov> whops, but seems readable ;)
10:08:44 <BasilSemuonov> #info Possible solutions: for SailfishOS itself:  Introduce core meta packet(s) with sfos version, which, maybe, depend on target device(or its specs), so apps can depend on it.
10:08:50 <cybette> #info read full logs for detailed description
10:09:02 <BasilSemuonov> #info for Habour: Add target SailfishOS version/device specs for application, while publishing.
10:09:52 <BasilSemuonov> And someone added, that action (investigation) should have been taken regarding themes and ambiences publishing, which also can depend on that
10:10:03 <netzvieh> theats the next point
10:10:09 <BasilSemuonov> #info action 5b from  http://www.merproject.org/meetings/mer-meeting/2014/mer-meeting.2014-05-13-10.00.html 'icon themes and custom ambiences in the harbour'
10:10:45 <stephg> (that was me)
10:11:03 <BasilSemuonov> probably, thats all
10:11:03 <sledges> so two points here: API and UI scaling
10:11:13 <netzvieh> #undo
10:11:13 <Merbot`> Removing item from minutes: <MeetBot.items.Info object at 0x9517650>
10:11:13 <artemma> Android has a concept of minimal and target API versions, i.e. min and max API versions app was tested on. Works fine for them, but sure requires SDK that can switch APIs (e.g. via multiple virtual machines)
10:11:20 <BasilSemuonov> sledges, yes, 2 major points
10:11:27 <sledges> on API: iirc ability to restrict apps per sailfish version in harbour/store were already in the works, could another sailor confirm pls?
10:11:54 <coderus> UI scaling can't be issue on any way. QA should check if developer used scalable layouts or not
10:11:55 <phaeron> sledges: yes and deployed
10:11:58 <grande> sledges: yes we are currently working on that feature on the store side
10:12:00 <sledges> phaeron: \o/
10:12:11 <xfade_> Yes, we are working on API based filtering.
10:12:17 <phaeron> sledges: should start coming into effect next release. still needs some work on store frontend side
10:12:39 <xfade_> But the frontend part still needs quite some work
10:12:44 <BasilSemuonov> coderus, not all apps should be scalable, i.e. games, whatever sdl uis
10:12:57 <artemma> In BB10 and Android a developer is required to put a checkmark for which resolutions app supports. Works
10:12:57 <cybette> #info API based filtering is in the works on store side
10:13:01 <coderus> BasilSemuonov: let's talk about Silica-based first
10:13:05 <netzvieh> stephg: you're next on the agenda, if iekku is here by then, otherwise I'd push it a bit back ;)
10:13:40 <stephg> no probs
10:13:48 <sledges> (keep up the) good job guys
10:13:50 <artemma> iOS goes further by hard limiting the number of resolutions to just few. Can Jolla also fix aspect ratio for a while?
10:14:15 <coderus> BasilSemuonov: can't SDL applications be scalable?
10:14:15 <javisail> iOS might be relaxing that these days
10:14:34 <javisail> check rumors for scalable ipad sinulator
10:15:04 <artemma> iOS strongly encourages scalable layouts now, yes. It is still just few resolutions in the end with developer telling which layout supports which resolutions
10:15:06 <coderus> artemma: checkmark for resolutions +1
10:15:27 <netzvieh> artemma: I think that's impossible with sailfish for android if stores there in next sfos for android release
10:15:29 <leszek> #agree
10:15:43 <coderus> but for Silica all apps should be scalable after launching next Jolla generation and QA should reject / mark for Jolla 1 only
10:15:44 <xfade_> In theory Store currely already supports serving different versions of apps to different devices. Or limiting visibility based on a device.
10:15:51 <artemma> and seriously: it was always QML motto that it's supposed be super easy to rewrite. Easier than to make universal
10:15:56 <xfade_> We would need to see how this would be handled in Harbour though.
10:16:22 <javisail> i knew this would quuckly degrade into per-device,per-release packages
10:16:45 <sletta> BasilSemuonov: When it comes to Qt 6 or a similar library, we should be able to run those side by side. We can in theory run Qt 4 applications on the device right now and there is no reason why we wouldn’t be able to run Qt 6 apps as well. The Qt Platform Abstract (QPA) handles that part. Regarding upgrading what the system libraries use, that will have to come as a step in itself when we know what it looks like :)
10:16:50 <artemma> what's bad about per-device/release packages?
10:17:10 <xfade_> imaging 20 releases and 50 devices ;)
10:17:12 <BasilSemuonov> sletta, that leads to another problem:
10:17:15 <javisail> artemma: no one will care about anything other than the device they own
10:17:16 <xfade_> *imagine
10:17:42 <artemma> mapping 3 releases to 10 devices should be fine. One for small phones, one for big tablets
10:18:06 <BasilSemuonov> sletta, we have 2 sailfishos versions: ver5.0, and version6.0. in version 6.0 new library added (any kind). and your application use it.
10:18:11 <artemma> and then again, all qmls can live even within same binary and be selected at runtime
10:18:34 <javisail> artemma: i would actually prefer that
10:18:36 <tbr> you get the thing where Android sort of addresses run on every possible device, while e.g. iOS already by product line is very limited and thus more managed
10:18:38 <leszek> hmm... how about the silica api takes care of big screen devices like tablets (with a specific ui) and small screen devices (like smartphones)
10:18:54 <coderus> artemma: i dont think we're currently talking about suggestions for developers, just general case
10:18:57 <BasilSemuonov> sletta, since harbour validates agains latest sailfishos version, all going to be okay, but app will be non-installable/runnable on sfos ver5.0
10:18:59 <leszek> so that even when you wrote only for your smartphone it still should look good on a tablet
10:19:13 <javisail> what if I plug my jolla into 1080p lcd tv?
10:19:27 <artemma> let's be clear: if Sailfish ever becomes real popular, there will be a need for device specific binaries sometimes. Think games with many megs of device optimized resources
10:19:38 <leszek> javisail: it should switch to the tablet ui then
10:19:40 <artemma> that is to be discouraged, but possible
10:19:44 <coderus> issue (not an issue really) is changing graphics to low - mid - hi res
10:19:53 <sletta> BasilSemuinov: agreed. This is where minimal API version or separate binaries would be needed. And more flexible store intake
10:20:01 <netzvieh> 15 minutes left
10:20:21 <iekku> o/
10:20:29 <cybette> iekku: you made it!
10:20:31 <BasilSemuonov> sletta, thats what i'm talking about. core version package to depend against. if you depend you know what API is present.
10:21:03 <xfade_> We can already detect what api your app depends on, no need to add it specifically.
10:21:37 <iekku> :)
10:21:46 <BasilSemuonov> xfade_, in future releases sdl support will be added. you can detect linkage
10:22:18 * jake9xx joined as well (sorry, late) so - jake9xx,sailor, blaablaa sdk guy
10:22:28 <xfade_> If it gets added to core library set, sure.
10:22:32 <BasilSemuonov> I submit app with sdl support to harbour. it okay with sfos version >= 1.0.6.x and does not work with 1.0.5.x
10:22:54 <xfade_> BasilSemuonov: then you will not see it on 1.0.5.x in Store.
10:23:14 <xfade_> That is what we are currently working on
10:23:37 <BasilSemuonov> xfade_, and what about inapp '$APPNAME/libs' folder?
10:23:40 <iekku> i have really unstable connection, so i might drop (have done it already 2 times)
10:24:12 <BasilSemuonov> i can either ship own sdl or use system provided package (sdl is just an example)
10:24:39 <xfade_> BasilSemuonov: There is always static linking if you really want to go that way?
10:25:00 <xfade_> But I would suggest to do one step at a time.
10:25:16 <BasilSemuonov> xfade_, i'm talking about fallback solution in case if anything misses
10:25:28 <xfade_> Let's not try to cover the corner cases first.
10:26:15 <BasilSemuonov> xfade_, okay. I just proposed the solution as i see it
10:27:06 <xfade_> I suggest we do filtering based on API first.
10:27:30 <xfade_> Then we might want to look at device classes or something like that (eg. screen resolutions)
10:27:37 <netzvieh> #info <BasilSemuonov> I submit app with sdl support to harbour. it okay with sfos version >= 1.0.6.x and does not work with 1.0.5.x
10:27:47 <netzvieh> # <xfade_> BasilSemuonov: then you will not see it on 1.0.5.x in Store. That is what we are currently working on
10:28:00 <netzvieh> ähm
10:28:04 <netzvieh> #info <xfade_> BasilSemuonov: then you will not see it on 1.0.5.x in Store. That is what we are currently working on
10:28:09 <artemma> If every single Sailfish release is fixed, why not to limit based on API levels a'la Android? Will make it easier for testing apps on a standard fixed emulator/device image
10:28:23 <kimmoli> will the harbour QA take care of checking which sfos is supportes, or is it developers responsibility to inform that ?
10:28:51 <faenil_> :( sorry guys, I really think I won't be able to contribute, it keeps disconnecting :( gah
10:28:57 <coderus> kimmoli: Harbour
10:29:00 <leszek> I thought the api version used will define which sailfish os version it is compatible with
10:29:01 <xfade_> kimmoli: will be automatic
10:29:08 <kimmoli> ok
10:29:45 <kimmoli> is internet broken? lots of reconnects ..
10:29:47 <netzvieh> #info harbour automatic checking which sfos version an app supports
10:30:01 <netzvieh> 5 minutes left
10:30:01 <iekku> kimmoli, yes it is :)
10:30:11 <netzvieh> kimmoli: someone dropped it
10:30:22 <kimmoli> maybe i should learn it and fix it :)
10:30:36 * javispedro switched to cable, must be solar flares
10:30:37 <faenil_> kimmoli, it's my adsl which is nuts, as usual :( not an issue in the last 3 days, and since 2mins before the meeting it disconnects every few mins :(
10:30:43 <cybette> istheinternetbroken.com gives me no
10:30:58 <cybette> maybe that site is broken
10:31:01 <kimmoli> sorry for leading you OT, please continue
10:31:41 <cybette> how many marcs does it take...
10:31:45 <netzvieh> anything else to add? else we can cut it short
10:31:51 <iekku> cybette, :D
10:31:55 <BasilSemuonov> well, if sailors said they are taking some steps, topic seems resolved to me
10:32:00 <netzvieh> okay
10:32:02 <netzvieh> #topic Update on ambiences and icon themes (10 min)
10:32:02 <netzvieh> #info this was an action point for iekku on 2014-05-13
10:32:02 <netzvieh> #link http://www.merproject.org/meetings/mer-meeting/2014/mer-meeting.2014-05-13-10.00.html
10:32:02 <netzvieh> stephg: want to give us a quick intro and an overview what you tested?
10:32:11 <stephg> sure
10:32:19 <iekku> #info study is ongoing
10:32:28 <stephg> so broadly two things, was wanting an update to the info above
10:33:12 <xfade_> Ambiences basically need to have the ambience template added to the SDK. There is a planned task for that.
10:33:29 <iekku> and some work on harbour side too
10:33:29 <netzvieh> #info Ambiences basically need to have the ambience template added to the SDK. There is a planned task for that.
10:33:34 <faenil_> xfade_, I don't think that's the issue atm?
10:33:39 <iekku> and proper testing plan
10:33:44 <stephg> xfade there's enough out there from the TOH dev kit to make them work but there are harbour submission issues
10:33:45 <faenil_> wasn't the issue that ambianced needs root or something?
10:33:45 <xfade_> Harbour just needs another category
10:33:55 <stephg> ambiences currently cannot by definition pass the current validator
10:34:08 <artemma> Ambience app store?
10:34:14 <faenil_> stephg, ah right, the validator
10:34:19 <artemma> Let's get creative artists started
10:34:26 <netzvieh> #info <stephg> ambiences currently cannot by definition pass the current validator
10:34:30 <stephg> and if they're installed by any other method other than the store the behaviour for the user is different, without validator breaking hacks
10:34:48 <stephg> fwiw they fail the validator as they don't have a main executable
10:34:51 <xfade_> faenil_: yeah, validator needs a change, but afaik we have a 'better' template ambiences.
10:35:09 <stephg> and if you install them via kncon etc. you need a %post for ambiencd to pick them up, which is verboten
10:35:19 <faenil_> so it's just about changing the validator and adding a category in store
10:35:22 <coderus> i know a lot of icon artists want to draw new icons, if Sailfish will allow to select icons themes
10:35:23 <faenil_> seems a 30mins job to me? :)
10:35:29 <stephg> faenil_: potentially yeah
10:35:51 <iekku> faenil_, testing plan etc isn't 30 minutes job
10:36:16 <artemma> Maybe a whole theme template and themes section in the harbour? That may or may not include ambience as a part of a theme
10:36:18 <xfade_> Lot of corner cases to be checked.
10:36:39 <xfade_> For icon themes, I don't know. We don't have that ourselves afaik.
10:36:45 <kimmoli> also Ambience wizard for SDK would be really appreciated (tired to make one, but failed on spec file eols in windows, iirc this will be fixed in next sdk version though)
10:36:50 <coderus> and what about deploying own icons to /usr/share/themes/base/meegotouch/icons ?
10:37:09 <kimmoli> coderus: +1
10:37:29 <xfade_> Probably needs work on lipstick to properly support icon themes.
10:37:42 <coderus> kimmoli: side issue is refreshing cache, it probably did only at system restart
10:37:50 <xfade_> You don't want one theme to overwrite your exisiting icons and no way to go back etc.
10:38:14 <coderus> xfade_: using appname- prefixes will solve that
10:38:40 <netzvieh> #info <xfade_> Probably needs work on lipstick to properly support icon themes.
10:38:48 <coderus> and adding image://appname/icon appname image provider in runtime will solve that also
10:39:57 <Aard> in theory we do have proper icon theme support there (minus ability to switch without reboot), we just didn't test it for a very loooong time.
10:39:57 <stephg> I appreciate there's alot involved with the icon side, but do you have an ETA for harbour-ey ambience stuff?
10:40:00 <faenil_> coderus, +1
10:40:01 <netzvieh> 2 minutes left
10:40:12 <faenil_> Aard, yes, sailfish is using qtcomponents theme handler isn't it
10:40:15 <faenil_> just revisited maybe
10:40:27 <netzvieh> #info <Aard> in theory we do have proper icon theme support there (minus ability to switch without reboot), we just didn't test it for a very loooong time.
10:40:51 <MSameer> not entirely
10:41:01 <MSameer> we are missing some bits
10:41:18 <coderus> it's deeply legacy stuff obliviously, just need to renew some api for handling/changing caches
10:42:16 <netzvieh> seems there is no eta yet
10:42:18 <netzvieh> #topic Software sources and packages management build into system (10 min)
10:42:18 <netzvieh> coderus: would you give us an introduction?
10:42:45 <coderus> xfade_: and for that situation i'll prefer if some theme will change/override my icons by theme cache if icon artist want to replace all icons including 3rd party apps
10:42:46 <xfade_> Might make more chance of bringing it to production if someone would test all the parts available atm and map out the missing parts.
10:43:17 <tbr> Can we get some proper summary for this discussion subject as a start? I read the etherpad and am none the wiser.
10:43:18 <coderus> #info Software sources and packages management build into system
10:44:13 <coderus> as Sailfish OS is FOSS linux based OS it should keep some general mechanisms for managing packages and repositories
10:44:37 <coderus> As option it can be enabled under Developer mode page after enabling developer mode, but it shouldn't be excluded from OS at all
10:45:05 <coderus> Main problem is Sailfish OS currently ignoring 3rd party repositories at all. Harbour as main and the only software source with no choose
10:45:45 <Stskeeps> you should be able to add repositories manually with ssu ar in developer mode? (i may be misunderstanding)
10:45:46 <coderus> Ubuntu have ppa's and all users can manage is is Software sources settings
10:45:46 <tbr> if you turn on developer mode there is pkcon and ssu. you can use that to manage packages.
10:45:54 <coderus> i'm talking about UI side now
10:46:12 <leszek> yeah it needs an UI for that
10:46:14 <tbr> so a UI frontend to SSU?
10:46:14 <xfade_> coderus: isn't that what openrepos already does now?
10:46:31 <tbr> and it's also partly what would be covered by chum
10:46:31 <coderus> Sailfish should have page to observe all installed user-packages to see versions, descriptions, maintainer details and all rpm-stuff
10:46:46 <MSameer> xfade_: I think coderus wants a generic ui for managing repos
10:46:58 <tbr> rather sounds like a generic RPM ui
10:47:05 <MSameer> seems so
10:47:10 <coderus> And Sailfish should update 3rd party repositories and show updates not only for Harbour packages
10:47:11 <leszek> coderus: so an overview of all installed applications and information about where they were installed from besides the package info itself
10:47:27 <MSameer> something like fremantle HAM or harmattan app manager
10:47:27 <BasilSemuonov> startup your N9, navigate to Settings -> Applications. Where is same page in Jolla?
10:47:34 <coderus> Just look at Harmattan. Its excellent example.
10:47:36 <netzvieh> 4 minutes left
10:47:41 <coderus> BasilSemuonov: exactly
10:47:48 * tbr gets cold shivers thinking of HAM and how bad its performance was
10:48:13 <coderus> tbr: harmattan have slow dpkg/apt-cache system, its not an issue in current topic
10:48:15 <BasilSemuonov> tbr, performance depends on implementation
10:48:22 <MSameer> tbr: ham had +1K l10n packages to deal with :p
10:48:22 <tbr> no sh*t sherlocks
10:48:38 <tbr> way to pounce on a side comment...
10:48:40 <coderus> #summary:
10:48:41 * tbr shrugs
10:49:08 <KhertanAtwork> coderus, pkcon isn't faster
10:49:09 <KhertanAtwork> :
10:49:10 <KhertanAtwork> :)
10:49:20 <tbr> the home screen shows all installed GUI apps
10:49:29 <coderus> 1. UI for managing installed packages. Users should have option to check installed packages versions,informatino about maintainers and all existing information
10:49:40 <tbr> so it only becomes an issue once you have non-gui things that didn't come from harbour
10:49:41 <leszek> tbr: but it doesn't show for example how many space they eat
10:49:57 <stephg> IMO 1) up there isn't 'managing'
10:50:02 <KhertanAtwork> coderus, i would add permission check when something like that will be implemented
10:50:17 <netzvieh> 2 minutes left
10:50:22 <leszek> I agree with coderus this would also help getting rid of "about" pages in the apps if there is a listing which can show that
10:50:45 <coderus> 2. 3rd party repositories not handled automatically. Packages refresh updating only Harbour repo and not affect 3rd party ones. User will never get upgrade notification
10:50:59 <cybette> #info summary from coderus: 1. UI for managing installed packages. Users should have option to check installed packages versions,informatino about maintainers and all existing information
10:51:11 <cybette> #info 2. 3rd party repositories not handled automatically. Packages refresh updating only Harbour repo and not affect 3rd party ones. User will never get upgrade notification
10:51:15 <javispedro> basically a packagekit agent
10:51:31 <Aard> coderus: not entirely true, the whole repo is refreshed, but harbour uses a different channel to store for update notifications
10:51:41 <MSameer> isn't there a nemo package manager that could be adapted?
10:51:56 <coderus> It's all generic stuff for any linux-base OS. And Sailfish shouldn't ignore that and exclude that parts from OS. Harbour isnt only way for packages.
10:52:07 <xfade_> coderus: store-client isn't a package manager at all
10:52:09 <Aard> I see that as a task for a separate full-blown package manager, like a chum client
10:52:15 <tbr> from the end user perspective this would mean more confusion though, as then there would be a third place to list apps and each place would list different things
10:52:20 <coderus> Enabling developer mode and 3rd party sources settings should enable these options too
10:52:39 <MSameer> Aard: problem is such app is not allowed in harbour (according to coderus)
10:52:41 <netzvieh> giving 2 more minutes stolen from first topic
10:52:45 <MSameer> or last I heard
10:52:46 <tbr> I partly agree with Aard and would like to add that it sounds like a fairly big amount of work
10:52:53 <coderus> xfade_: this is certanly my point: Sailfish excluded that functionality fron OS
10:52:56 <coderus> from*
10:53:22 <coderus> Jolla Store handling only Harbour apps, it's okay.
10:53:34 <xfade_> Sound to me like a perfect community project which can be adapted whenever it reaches a certain quality?
10:53:44 <iekku> +1 for xfade_
10:53:57 <coderus> After enabling Developer mode Sailfish should handle everything and provide UI for managing ssu repos and user packages with all information about it contents
10:54:10 <coderus> xfade_: okay, i can take it
10:54:12 <tbr> #info <+xfade_> Sound to me like a perfect community project which can be adapted whenever it reaches a certain quality?
10:54:15 <Aard> MSameer: for a fully opensource community-managed app we probably can make an exception. the only problematic part there which I see is elevated privileges for talking to packagekit, it'd just mean additional audit effort on submission to make sure that it does not use anything other elevated
10:54:24 <coderus> just all API should be reviewed
10:54:24 <netzvieh> so times up
10:54:25 <Aard> or probably have jolla do the binary build for that
10:54:29 <netzvieh> #topic Updates on Action points of last meetings (5 min)
10:54:29 <netzvieh> this is from the PiratePad chat, right after last meeting. I gathered some points and will just ask everyone if there are updates.
10:54:36 <javispedro> supposedly pkkit simplifies those things, gnome-packagekit is around 20k lines of glib/c code
10:54:42 <netzvieh> lbt, tbr, Stskeeps, BasilSemuonov: any updates on chum? (e.g. policies, docs, qa (apps4meego qa material?), OBS upgrade, boss validation steps, openrepos-obs bridge)
10:54:42 <netzvieh> pvilja1, pvuorela: any update on community tool for l10n and keyboard layouts?
10:54:42 <netzvieh> bijjal: any (negative) feedback on roadmap mail?
10:54:42 <netzvieh> Stskeeps: any updates on OSSification?
10:54:42 <netzvieh> lbt, Aard: any update on (auto)docs + Silica docs?
10:54:53 <MSameer> #info <Aard> MSameer: for a fully opensource community-managed app we probably can make an exception. the only problematic part there which I see is elevated privileges for talking to packagekit, it'd just mean additional audit effort on submission to make sure that it does not use anything other elevated
10:54:57 <cybette> netzvieh: bijjal is on vacation
10:55:11 <MSameer> #info <Aard> or probably have jolla do the binary build for that
10:55:21 <lbt> netzvieh: http://autodoc.merproject.org/
10:55:23 <Stskeeps> netzvieh: we're doing OBS upgrade of mer OBS today, or rather, lbt is banging his head against the wall and doing it
10:55:27 <tbr> #info chum progressing slowly on my side. promoted a couple of apps to chum testing for U5
10:55:38 <coderus> MSameer: okay now i have topics for next meeting :)
10:55:41 <lbt> so that's DNS for it - and I'm going to co-locate autodoc on the repo meeting
10:55:49 <netzvieh> #info autodoc see http://autodoc.merproject.org/
10:55:51 <Aard> netzvieh: so far I've only seen positive feedback, but I guess we'll have to see how things develop
10:55:58 <MSameer> coderus: I hope I helped a bit :)
10:56:02 <netzvieh> #info <Stskeeps> netzvieh: we're doing OBS upgrade of mer OBS today, or rather, lbt is banging his head against the wall and doing it
10:56:09 <lbt> and yes, OBS upgrade is happening (but stalled due to f***ing LVM)
10:56:13 <MSameer> Welcome to autodoc.merproject.org. Press 'a' to continue....
10:56:21 <lbt> MSameer: does it work?
10:56:23 <cybette> #info community translation tool is still pending. IT team might have some time to work on it soon, but no updates at this pont
10:56:28 <MSameer> lbt: no
10:56:30 <lbt> MSameer: try again
10:56:36 <netzvieh> #info @roadmap mail <Aard> netzvieh: so far I've only seen positive feedback, but I guess we'll have to see how things develop
10:56:44 <tbr> #info chum still needs more volunteers to drive forward policies, process definition and also adaptation of the open repos client to the chum use case.
10:56:49 <MSameer> lbt: still no
10:56:55 <lbt> MSameer: hmm - keep trying
10:56:58 <Stskeeps> lbt..
10:56:59 <Stskeeps> :P
10:57:03 <lbt> *g*
10:57:04 <MSameer> lbt: :P
10:57:15 * MSameer tries with ab
10:57:59 <lbt> tbr: yeah - we've had some volunteers to start outlining but in the end I think it'll be down to the usual suspects :)
10:58:22 <tbr> I _might_ have some more time for that in the near future, remains to be seen
10:58:50 <lbt> tbr: happy to partner up on an ether/piratepad
10:58:54 <coderus> BasilSemuonov: what was your ideas about openrepos <-> chum communications?
10:59:20 <netzvieh> #help We need more volunteers for community repo surroundings
10:59:39 <BasilSemuonov> coderus, pulling info/packages from obs for autoupdates
10:59:39 <netzvieh> soo
10:59:52 <netzvieh> last topic for today
11:00:04 <netzvieh> #topic Community guidelines, communication channels and Jollas communication (30 min)
11:00:06 <netzvieh> #info continuing from last meeting
11:00:06 <netzvieh> #link http://merproject.org/meetings/mer-meeting/2014/mer-meeting.2014-05-27-15.00.html point 3
11:00:06 <netzvieh> cybette and iekku: would you like? :)
11:00:23 <cybette> iekku: are you there?
11:00:27 <iekku> cybette, if you could
11:00:38 <cybette> haha ok
11:00:51 <iekku> my connection may get lost again in any minute, lost on counts already
11:01:19 <cybette> #info we've discussed about keeping mailing list focused to SailfishOS deeveloper related conversations
11:01:42 <cybette> #info it will be moderated by Jolla sailors (selected) and communtiy members (no volunteers yet)
11:02:24 <cybette> #info nominations/volunteers for moderators to be sent to developer-care@jolla.com
11:03:08 <cybette> we'll also create a pirate pad to draft out mailing list rules, iekku will send that
11:03:23 <coderus> oh yes please, keep mailing list for developers questions only. i'm not the person giving feedbacks for personal questions, i'm just ignoring it in any cases, but sometimes it very annoying, you know
11:03:54 <mike7b4_on_x230> coderus: +1
11:04:05 <cybette> coderus: I think most of us are in agreement on this. it's ok to bring some topic up and bring it off the list when appropriate
11:04:15 * lbt thinks that despite all the bad stuff recently we've only just hit the limit of *actionable* (not acceptable) behaviour. We should be cautious about over-reacting with rules
11:04:23 <cybette> so some moderation to keep that in place
11:04:28 <iekku> lbt, +1
11:04:35 <netzvieh> cybette: any plans for multiple communication channels like suggested on the list?
11:04:35 <stephg> lbt: +1
11:05:22 <iekku> netzvieh, currently no
11:05:34 <coderus> and i have question about way for asking Jolla guys for API-related topics. while developing Mitakuuluu i'm using many undocumented features and have 50/50% success in contacting with Jolla developers. Sometimes they trying to help me, sometimes ignoring my questions. But it generally about nemomobile components. I'm using mails from sourcces copyright information.
11:05:39 <cybette> netzvieh: at this point we would like to focus on the mailing list, together.jolla.com and irc. We can work on improving these channels (setting up guidelines is a start) but spreading ourselves too thin at this point will not be beneficial
11:05:50 <iekku> nothing new, but making current ones as working better
11:05:58 <cybette> iekku: +1
11:06:15 <kimmoli> i'm desperatedly tried to start app-development related questions on TJC
11:06:45 <coderus> kimmoli: i'm trying to follow new question with that tag, but missing many
11:07:02 <netzvieh> #info <cybette> netzvieh: at this point we would like to focus on the mailing list, together.jolla.com and irc. We can work on improving these channels (setting up guidelines is a start) but spreading ourselves too thin at this point will not be beneficial
11:07:22 <sledges> ml is simply cleaner for dev questions (just think lkml)
11:07:27 <coderus> and what about #jolladev-meeting weekly? :)
11:07:42 <artemma> tech bug reporting channel would be nice
11:07:47 <coderus> we can ask short API questions to jolla developers and get fast answers
11:07:51 <netzvieh> coderus: the poor jollans :D
11:07:59 <cybette> speaking of moderators, we will also like community involvement as irc channel ops and TJC moderators. similarly, nominations/volunteers to developer-care@
11:08:01 <sledges> yet even more informal topics could go on tjc
11:08:03 <leszek> yeah that would be time consuming
11:08:28 <MSameer> coderus: did you get answers for your camera questions?
11:08:30 <artemma> you can post bugs to TJC, but.. they will be outvoted by gimme-more-stuff entries instantly and sometimes only one person cares to reproduce a specific issue
11:08:35 <netzvieh> #info <cybette> speaking of moderators, we will also like community involvement as irc channel ops and TJC moderators. similarly, nominations/volunteers to developer-care@
11:08:36 <tbr> cybette: would you prefer people to nominate others or people apply for themselves?
11:08:53 <cybette> tbr: both are welcome :)
11:08:54 <coderus> coderus: i just want to get feedback on my API questions about opensource/community libraries/components. I'm sad when developers ignoring my mails :(
11:09:00 <iekku> i would also adopt #mer rules to #sailfishos
11:09:03 <coderus> MSameer: no i didn't
11:09:14 <MSameer> iekku: ^^^
11:09:21 <iekku> basicly common sense needed
11:09:36 <lbt> iekku: the kde ones in that email were good too
11:09:49 <lbt> someone pointed them out to m
11:09:50 <iekku> lbt, :nod:
11:09:50 <lbt> e
11:10:42 <cybette> when we have a list of names we will have the voting (on piratepad or some suitable tool).
11:10:58 <netzvieh> regarding the piratepad for community guidelines, what steps are planned? discussion on a PP can get out of hand quickly? or at first use it just as dropbox for ideas?
11:12:06 <cybette> netzvieh: I think we will have a draft in place and for review and suggestions.
11:12:15 <cybette> iekku: maybe can comment more if this is the case ^^
11:12:28 <iekku> +1 for cybette
11:12:36 <netzvieh> #info @moderators <cybette> when we have a list of names we will have the voting (on piratepad or some suitable tool).
11:12:39 <MSameer> i wonder if piratepad would become a target for spam bots...
11:12:56 <netzvieh> #info @guidelines <cybette> netzvieh: I think we will have a draft in place and for review and suggestions.
11:13:01 <stephg> MSameer: seems to have gone unnoticed for this so far?
11:13:31 <stephg> (unless people are quitely, dilligently curating the meetings ones)
11:13:46 <lbt> netzvieh: ppad is simply to collaborate on a draft
11:13:56 <lbt> it should then go to a managed document
11:14:01 <lbt> wiki/git
11:14:03 <cybette> lbt: +1
11:14:17 <netzvieh> MSameer: well you need javascript to use it, that helps a bit
11:14:20 <iekku> i think we could have first draft at piratepad and when starting to be ready put it to tjc
11:14:24 <MSameer> aha
11:14:31 <coderus> can anyone clean http://piratepad.net/SailfishOSSMeetings please? I want to keep my ideas for next meeting before i forget them :D
11:14:35 <MSameer> stephg: netzvieh answered :)
11:14:49 <cybette> and some comments about IRC channels:
11:15:14 <netzvieh> coderus: done
11:15:24 <cybette> #info #SailfishOS on freenode is official IRC channel, however all sailors are community members there if not mentioned separately otherwise
11:15:45 <netzvieh> I made a local copy and paste back things needed
11:15:51 <cybette> #info we're proposing to adopt IRC guidelines from Mer: https://wiki.merproject.org/wiki/IRC_guidelines
11:15:57 <netzvieh> 15 minutes left
11:16:15 <cybette> #info sidenote, #jollamobile on freenode is unofficial, founded by Stskeeps and iekku, following Mer IRC guidelines
11:17:24 <tbr> if it's unofficial it should be ##jollamobile as per freenode guidlines
11:17:41 <tbr> unless of course jolla exerts administrative power over it, which makes it official
11:17:49 <tbr> might want to get that sorted
11:17:58 <iekku> tbr, good points
11:18:23 <tbr> you can't have the cake and eat it at the same time, essentially
11:18:36 <sledges> ^ action to eat the cake? ;)
11:18:38 <stephg> is #sailfishos official or not? topic doesn't indicate
11:18:39 <Stskeeps> noted, i'll see what i can do about that
11:18:59 <netzvieh> stephg: official see cybettes #info
11:19:09 <Stskeeps> and just to indicate, i meant that tbr's point is good
11:19:16 <iekku> stephg, i would say it's a community's official channel
11:19:43 <Stskeeps> there's always been a bit of a weird setup, for example in #maemo, which in practice was maemo's community intermixed with employees
11:19:48 * tbr would recommend to read the freenode guidelines and align jolla official stance. there should be wiggle room.
11:19:48 <iekku> (cybette is using memo i sent to her in case i can't participate)
11:19:56 <cybette> maybe official community-facing channel?
11:20:04 <Stskeeps> #action stskeeps to look into #jollamobile vs ##jollamobile
11:20:16 <stephg> iekku: netzvieh: k
11:20:31 <iekku> cybette, which one?
11:20:38 <cybette> iekku: #sailfishos
11:20:45 <iekku> +1
11:22:03 <cybette> iekku: anything else to add? I think the 3-strikes guidelines stuff can be shared later on the pirate pad
11:22:21 <iekku> +1
11:22:30 <iekku> i don't have anything else now
11:22:38 <sledges> would those guidelines apply only for irc?
11:22:39 <netzvieh> is there an ETA for that pirate pad?
11:22:53 <iekku> sledges, both
11:23:35 <iekku> netzvieh, not yet, i'm still having limited working hours because of my health issues, so i need to do heavy prioritation
11:23:46 <cybette> sledges: there will be some general guidelines to respect and treat each other nicely in the community, and there will be some mailing-list specific guidelines (e.g. going off topic) and some irc specific guidelines
11:24:00 <iekku> netzvieh, and developer-care@ is my priority 1
11:24:01 <cybette> iekku: I can help you with that
11:24:07 <iekku> cybette, <3
11:24:17 <netzvieh> #info no ETA on guideline pirate pad
11:24:32 <netzvieh> #action cybette supports iekku with PP
11:24:47 <sledges> lovely :)
11:24:52 <cybette> :)
11:25:01 <iekku> :)
11:25:21 <lbt> erm : http://piratepad.net/sailfish-community-guidelines
11:25:52 <cybette> lbt: we're not talking about just "creating" the PP link :P
11:25:57 <lbt> I'd say there's no ETA for publishing it though :)
11:26:02 <iekku> but making a draft
11:26:06 <cybette> yep
11:26:30 <MSameer> coderus: while you are here, consider emailing developer-care@ since you are still pending answers
11:26:34 * netzvieh takes his personal hat: I agree with lbt, that we shouldn't overmoderate - but I think guidelines are good, so people can take a look what's on topic and off topic
11:26:50 <sledges> lbt: netzvieh: +1
11:26:50 <netzvieh> so is this link set?
11:26:59 <iekku> coderus, please do so
11:27:16 <iekku> netzvieh, that's the idea
11:27:24 <cybette> netzvieh: I'd rather not #info the link now, let us establish some stuf there first
11:27:26 <coderus> MSameer: well, as already mailed to mailing list and Exter directly, should i also email ro developer-care?
11:27:34 <netzvieh> cybette: okay ;)
11:27:46 <cybette> netzvieh: thanks!
11:27:47 <MSameer> coderus: I really don't know :/
11:27:53 <coderus> iekku: ?
11:28:01 <netzvieh> 2 minutes left
11:28:09 <cybette> next meeting?
11:28:13 <cybette> time and date
11:28:18 <iekku> coderus, if you do that, i can personally take care of kicking. or if you send topic as a private to me, i will search it from ML and start kicking
11:28:20 <cybette> and chair
11:28:21 <netzvieh> #topic Next Meeting
11:28:51 <coderus> iekku: okay, developer-care@jolla.com ?
11:29:09 <iekku> coderus, yes plaase
11:29:12 <iekku> please
11:29:12 <coderus> thanks
11:29:17 <cybette> so next tuesday @ 10 or 15 UTC?
11:29:17 <netzvieh> date: 10 June? time: 15 UTC? chair: probably not me :)
11:30:00 <stephg> cybette: netzvieh: +1
11:30:02 <coderus> 15UTC
11:30:03 <cybette> I'll chair unless someone volunteers before Jun 10
11:30:39 <netzvieh> #agreed Next Meeting 10 June @ 15 UTC with cybette as chair unless someone volunteers
11:30:47 <netzvieh> #endmeeting