#mer-meeting: SailfishOS, open source, collaboration: 24-June @ 10:00 UTC

Meeting started by cybette at 08:44:58 UTC (full logs).

Meeting summary

    1. Welcome to another week of SailfishOS OSS and collaboration meeting (cybette, 08:45:03)
    2. Meeting info and agenda: https://lists.sailfishos.org/pipermail/devel/2014-June/004600.html (cybette, 08:45:09)

  1. Brief introductions (5 min), prefix your information with #info (cybette, 08:45:26)
    1. Carsten Munk, Chief Research Engineer @ Jolla (Stskeeps, 08:45:36)
    2. kimmoli, community member, just making some toh's (kimmoli, 08:45:48)
    3. Andrea Bernabei, Nemo contributor and Jolla user (faenil, 08:45:54)
    4. Carol Chen, Community chief at Jolla, hatless chair today (again...) (cybette, 08:45:56)
    5. Iekku Pylkk�, developer-care @ Jolla (iekku, 08:45:58)
    6. Simonas Leleiva, sailor and community member (sledges, 08:46:00)
    7. Thomas Perl, sailor and community member (thp, 08:46:19)
    8. Saija Saarenpää, sailfish app developer (matrixx, 08:46:42)
    9. David Greaves, Mer guy and sailor (lbt, 08:46:53)
    10. Eric Le Roux, Bugzilla & TJC admin @ Jolla (eleroux, 08:47:22)
    11. Chris Adams, sailor working mainly on sync / SoMe stuff (chriadam, 08:48:45)
    12. Tomi Virtanen, Software tester @ Jolla (cobu, 08:49:01)
    13. Giulio Camuffo, developer at jolla, working mainly on qt and wayland (giucam, 08:49:25)
    14. Thomas Ruecker, community member (tbr, 08:49:58)

  2. Nemo/Mer merge and bugzilla situation, faenil (30 min) (cybette, 08:50:22)
    1. Bob Jelica, spotify employee, community member (b0bben, 08:51:00)
    2. there were hiccups on OBS, disks failing etc. but all things are in place now and ready to go on with the merging (cybette, 08:53:04)
    3. I recently upgraded the OBS to 2.5 (and there's more work to do) but this forms a sane base to continue to develop Mer build infra as we merge stuff (lbt, 08:53:46)
    4. ACTION: Stskeeps to post instructions for people to help with the merge (cybette, 08:54:17)
    5. I've been working with Jolla bug people about extending their *internal* bz in a way that helps work better with Mer BZ (lbt, 08:54:44)
    6. ACTION: faenil to take disciplinary actions on Stskeeps if he fails to make progress on this topic (cybette, 08:54:49)
    7. ACTION: Stskeeps to send a list of blockers-to-a-Mer-release to the ml when he's at desk (lbt, 09:01:52)
    8. unless it's just python build error and ofono build (lbt, 09:02:12)
    9. ACTION: thp to look into the python build error (thp, 09:03:26)
    10. BZ has several aspects Mer Bugzilla; Nemo Bugzilla; SailfishOS public bugzilla; Working with Mer Bugzilla (lbt, 09:03:47)
    11. in addition to BZ, some projects have issue tracker on github, e.g. https://github.com/sailfishos/sailfish-browser/issues (cybette, 09:06:37)
    12. BZ discussion to continue after the meeting (cybette, 09:20:02)

  3. Betatesting program, faenil (20 min) (cybette, 09:20:23)
    1. (from faenil in pirate pad) what is the current situation, and how distant in the future is the reality where people will be able to opt-in for firmwares betatesting just like with the connman fix (cybette, 09:22:12)
    2. Opt-in feature testing (like connman) is doable for now, full firmware betatesting still needs feasibility consideration (cybette, 09:39:51)

  4. Updates on ambiances/icon packs in Harbour (5 min) (cybette, 09:40:23)
    1. work is ongoing, still need to figure out some things internally (including sdk update and serverside work), sailors starting vacations (cybette, 09:43:53)
    2. format of ambiences need to be stabilized and documented to make ambiences created future-proof (cybette, 09:44:31)

  5. Updates on Silica documentation improvements (5 min) (cybette, 09:45:17)
    1. there is nice progress in documentation updates in general, e.g. in nemo d-bus plugin (cybette, 09:47:58)
    2. not too many improvements to Silica docs recently, need Martin's and Joona's attention (cybette, 09:49:40)
    3. https://raw.githubusercontent.com/nemomobile/nemo-qml-plugin-dbus/master/docs/index.rst (sledges, 09:50:13)
    4. http://nemo-qml-plugin-dbus.readthedocs.org/en/latest/ (sledges, 09:50:16)
    5. https://sailfishos.org/presentations/qtdevdays_beijing_2013_jpetrell.pdf (thp, 09:50:29)

  6. Updates on autodoc situation (5 min) (cybette, 09:50:58)
    1. host is up, lbt was engrossed with obs work to do more (sledges, 09:54:05)
    2. http://autodoc.merproject.org/1;5C (sledges, 09:54:14)
    3. http://autodoc.merproject.org/ (sledges, 09:54:20)

  7. Updates on beta channel in Harbour / API versioning stuff (10 min) (cybette, 09:54:55)
    1. no news (iekku, 09:55:34)
    2. this will be available earliest in autumn as mentioned earlier (cybette, 09:57:23)

  8. SailfishOS open source lisensed sources, update by tbr (5 min) (cybette, 09:59:24)
    1. Sources (OSS licensed) of SailfishOS are now again available for download. (There was some server downtime due to physical move.) (tbr, 09:59:45)
    2. The proper URL to the sources is http://images.formeego.org/jolla/sources/ (tbr, 09:59:48)
    3. Stskeeps and Jope are so kind to directly provide the release ISOs and tarballs to that server. (tbr, 09:59:54)
    4. The code drops are provided by Jolla as is. (tbr, 10:00:00)
    5. Currently Available are the source drops for: 1.0.0.5; 1.0.1.10; 1.0.2.5; 1.0.3.8; 1.0.4.20 (other sources are due very soon) (tbr, 10:00:03)
    6. Would it be interesting to process the data from those drops to track changes etc? Most of those link to git repositories. (tbr, 10:00:06)
    7. If there is interest, then this needs several helping hands to happen. Please contact me (tbr) on IRC. (tbr, 10:00:09)
    8. Jolla is kindly requested to independently provide MD5 or SHA1 hashes for the files, so that people can independently verify their provenance. (e.g. by posting on dev ML or TJC or twitter or signing the hash with a known Jolla key) (tbr, 10:00:12)

  9. Wrap up and next meeting (5 min) (cybette, 10:04:17)
    1. Sailors are starting to go on their vacations soon, proposal to have less frequent meetings in July/August (cybette, 10:04:59)
    2. http://piratepad.net/SailfishOSSMeetings (cybette, 10:06:30)
    3. Next meeting Tues July-8 @ 15:00 UTC, Chairperson tbr (cybette, 10:09:51)


Meeting ended at 10:10:37 UTC (full logs).

Action items

  1. Stskeeps to post instructions for people to help with the merge
  2. faenil to take disciplinary actions on Stskeeps if he fails to make progress on this topic
  3. Stskeeps to send a list of blockers-to-a-Mer-release to the ml when he's at desk
  4. thp to look into the python build error


Action items, by person

  1. faenil
    1. faenil to take disciplinary actions on Stskeeps if he fails to make progress on this topic
  2. Stskeeps
    1. Stskeeps to post instructions for people to help with the merge
    2. faenil to take disciplinary actions on Stskeeps if he fails to make progress on this topic
    3. Stskeeps to send a list of blockers-to-a-Mer-release to the ml when he's at desk
  3. thp
    1. thp to look into the python build error


People present (lines said)

  1. faenil (115)
  2. lbt (113)
  3. cybette (76)
  4. tbr (62)
  5. thp (54)
  6. sledges (21)
  7. netchip (20)
  8. Stskeeps (18)
  9. iekku (18)
  10. eleroux (13)
  11. Jope (9)
  12. chriadam (8)
  13. M4rtinK_jolla_ (5)
  14. Merbot (3)
  15. cpeake (2)
  16. stephg (2)
  17. b0bben (1)
  18. kimmoli (1)
  19. cobu (1)
  20. giucam (1)
  21. phdeswer (1)
  22. matrixx (1)
  23. netzvieh (1)
  24. artemma (1)


Generated by MeetBot 0.1.4.