15:04:27 <Stskeeps> #startmeeting SailfishOS, open source, collaboration 19-August
15:04:27 <Merbot> Meeting started Tue Aug 19 15:04:27 2014 UTC.  The chair is Stskeeps. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
15:04:27 <Merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:04:32 <Stskeeps> #chair cybette
15:04:32 <Merbot> Current chairs: Stskeeps cybette
15:04:49 <cybette> Stskeeps: I'm here, sorry and thanks
15:04:53 <Stskeeps> good, please take over :)
15:04:58 <cybette> :)
15:05:24 <cybette> #info Welcome to another week of SailfishOS OSS and collaboration meeting
15:05:45 <cybette> #info Agenda today can be seen at https://lists.sailfishos.org/pipermail/devel/2014-August/004920.html
15:05:56 <cybette> #topic Quick introductions (5 min), prefix your information with #info
15:06:05 <tbr_> #info Thomas B. Rücker, community member
15:06:06 <Stskeeps> #info Carsten Munk, Chief Research Engineer @ Jolla
15:06:20 <SK_work> #info Lucien Xu, community member
15:06:22 <sledges> #info Simonas Leleiva, sailing community member
15:06:23 <tadzik> #info Tadeusz Sośnierz, Jolla enthusiast and developer wannabe
15:06:25 <locusf> #info Aleksi Suomalainen, community member
15:06:33 <cybette> #info Carol Chen, community chief @ jolla, today hatless chair
15:06:36 <eleroux> #info Eric Le Roux, Bugzilla & TJC admin @ Jolla
15:06:42 <vgrade_> #info Martin Brook , community member
15:07:18 <bijjal> #info Soumya Bijjal, SW program manager @ JOlla
15:07:22 <M4rtinK> info Martin Kolman, community member & modRana developer
15:07:34 <giucam> #info Giulio Camuffo, sw developer @ Jolla
15:07:39 <tbr_> you missed a # M4rtinK
15:07:48 <M4rtinK> oh
15:08:03 <M4rtinK> #info Martin Kolman, community member & modRana developer
15:08:17 <netzvieh> #info Sebastian Meyer, community member
15:09:20 <cybette> one more minute for intro
15:09:22 <w00t> #info Robin Burchell, sailor emeritus
15:10:17 <cybette> #topic Licensing issues with sailfishsilica-qt5 - tbr (30 min)
15:10:18 <javispedro> #info Javier S. Pedro, community
15:10:33 <javispedro> (always late)
15:10:47 <cybette> tbr: please go ahead :)
15:10:48 <tbr> so, this developed out of a community conversation
15:10:50 <kimmoli_sailing> #info kimmo lindholm, toh
15:10:53 <cybette> javispedro: better late than never :)
15:11:09 <tbr> people were saying that the silica sources are nowhere in a VCS
15:11:16 <tbr> so no handy reference to look something up
15:11:41 <tbr> I went and took the package (as also deployed in the latest update) and extracted all files
15:12:06 <tbr> while examining those files I noticed that some of the ui components, which were said to be permissively licensed had no headers
15:12:10 <tbr> this was likely a mistake
15:12:34 <tbr> but as licensing was unclear (the package also contains proprietary jolla IPR) I ommitted those
15:12:48 <tbr> hence arose the question to jolla about the license of those files
15:13:07 <tbr> also other (generated files) that might be potentially useful in a VCS checkin
15:13:30 <tbr> also the question is if jolla will offer those anciliary files that are not part of the GPL drop in some repository
15:13:47 <tbr> I also wrote up a TJC issue to have this all clearly stated
15:14:21 <cybette> is this the one? https://together.jolla.com/question/52712/licensing-issues-with-sailfishsilica-qt5/
15:14:23 <tbr> I meanwhile heard that the license headers were indeed just forgotten and this is being fixed, but some jolla representative might want to comment
15:14:32 <tbr> should be the URL, yes
15:14:50 <cybette> #link https://together.jolla.com/question/52712/licensing-issues-with-sailfishsilica-qt5/
15:15:17 <Stskeeps> yeah, so, maybe i can just start a little bit from the 'why' of it in first place - generally, it's not intentional that they're forgotten and they ought to be bsd/mit headers, it'll not be in next update (i believe) but likely one after that
15:15:31 <Stskeeps> given releasing schedules atm
15:15:47 <tbr> as this topic was alotted more time we might want to discuss related issues too
15:16:15 <Stskeeps> so, the reason why specifically the QML/js is BSD/MIT licensed is that it's typical and intentional use for silica or qml applications in general to customize individual components or derive from them .. hence you need to see how they work
15:16:22 <tbr> it's good to hear that this is the case Stskeeps, mind to #info that? :)
15:16:34 <Stskeeps> yeah, i didn't want to do a canned statement so i'll summarize in #info ;)
15:16:42 <tbr> roger
15:16:48 <Stskeeps> #info Missing license headers not intentional, they ought to be BSD/MIT headers
15:16:49 <tbr> just making sure we have meaningful minutes
15:17:19 <javispedro> so what's propietary then? just libsailfishsilicaplugin.so?
15:17:36 <Stskeeps> #info It's typical for QML/silica apps and intentional use to customize individual QML components or derive from them, hence you need to see how they work. And given that people have differnet licensed apps, they need to be fairly liberal licensed
15:17:50 <Stskeeps> copy-pasting is fairly normal
15:17:53 <tbr> there was also a host of auto generated(?) files without headers
15:18:12 <w00t> tbr: stuff like qmldir can't have license headers, if you mean that one
15:18:23 <tbr> I guess they might not have real value to developers but didn't want to make presumptions
15:18:33 <Stskeeps> yeah, javascript and other stuff that looks like they're related are likely BSD/MIT.
15:18:54 <Stskeeps> translations are a bit more curious as i presume they're in a binary format.. community translation tool should sort that out
15:18:59 <tbr> w00t: does it represent value to have it in VCS? if yes the license might be clarified in a additional file?
15:19:24 <tbr> also I took the result package content
15:19:56 <tbr> the question is if silica sources could be made available with proprietary files removed
15:19:59 <tbr> in the future
15:20:11 <Stskeeps> if i may ask, does a VCS solve anything that simply putting latest silica version on let's say, a referenced sailfishos.org indexer or directory?
15:20:18 <Stskeeps> VCS specifically, tha tis
15:20:21 <Stskeeps> as technology
15:20:31 <tbr> nah, a LXR or whatever is fine too
15:20:42 <tbr> so far there is nothing from the jolla side AFAIU
15:20:49 <SK_work> indeed, VCS is used for (open) developement, so maybe not that useful
15:20:52 <M4rtinK> a place to send patches to ?
15:20:56 <SK_work> github makes browsing easy though
15:20:56 <tbr> I'm still pondering to put the GPL tarballs through a LXR
15:21:28 <M4rtinK> or base patches against
15:21:29 <Stskeeps> it's a place to send patches though, yes, but at same time, from an entirely build engineer perspective/developer, seperating qml and c++ is a pain ,since you usually update them in parrallel
15:21:43 <Stskeeps> .. just thinking from a practical pov
15:21:49 <Stskeeps> i can see the value of it, however
15:22:01 <Stskeeps> (for the reasons above)
15:22:13 <tbr> if it's too hard then we maintain the community solution of e.g. me putting them in a VCS
15:22:50 <M4rtinK> well, it could just have branches for each update
15:22:56 <tbr> I guess this also means that there is no outlook/plan to opensource the c++ side?
15:23:18 <Stskeeps> there's an ongoing active discussion about sources for silica but sadly no news today, from a technical pov it'd be good to just have it in open to assist such valuable things as listed above
15:23:37 * w00t would like to see it open also. but I guess +1's don't really do much :P
15:23:39 <M4rtinK> would make life easier for proposing patches or for patchmanager stuff
15:23:40 <tbr> *nod*
15:24:06 <Stskeeps> we can start moodling around with git submodules and such but it may be more hassle than worth for everybody involved
15:24:12 <SK_work> M4rtinK: for patchmanager stuff, it is still hard to patch other QML files (homescreen)
15:24:30 <Stskeeps> as one way to seperate the qml out..
15:24:31 <M4rtinK> I'd note that opensourcing it might be a big boost for a runable Nemo
15:24:44 <SK_work> Stskeeps: dumping QML in a release would be nice
15:24:45 <Stskeeps> at same time, nemo has own component set/looks
15:24:52 <Stskeeps> (from what i understand)
15:25:01 <SK_work> M4rtinK: opensourcing might kill the whole nemo ui initiative
15:25:05 <SK_work> or help boosting it
15:25:06 <M4rtinK> no need to re
15:25:24 <M4rtinK> invent the whole wheel yet again :)
15:25:39 <cybette> DING -15 min left in topic
15:25:50 <AL13N_work> that's a lot of time
15:25:59 <Stskeeps> tbr: am i missing anything you brought up? i plan on adding to the TJC afterwards too
15:26:16 <cybette> we can wrap up sooner if there's no more comments
15:26:39 <eleroux> +1 for the TJC documentation :)
15:26:49 <tbr> Stskeeps: no that's covered
15:26:57 <Stskeeps> i think it's worth noting that people are missing a indexer / reference qmls for silica to look up things
15:27:00 <tbr> Stskeeps: we could now cover additional related topics
15:27:18 <tbr> Stskeeps: e.g. when we can expect a source dump from the latest update (IIRC not there yet)
15:27:35 <tbr> or the GPL files found in recovery recently by tuukkah
15:27:46 <Stskeeps> ah, that's on my list for this week
15:28:01 <Stskeeps> i've been erm, battling, with a fancy windows 8.1 machine lately.. not good dev environment
15:28:36 <Stskeeps> recovery may be better to work on to push as a git repo, but rebuildability is a bit of an issue
15:28:44 <Stskeeps> so that needs to be explored
15:28:46 <tbr> #info status quo - we continue with the current approach of community hosting the qml/js bits of silica until c++ side is opensourced
15:29:10 <Stskeeps> okay, i don't have anything else.
15:29:16 <tbr> #info a indexer/lxr would be desired by the community
15:29:18 <tadzik> is there an agenda on open-sourcing the C++ parts?
15:29:29 <tbr> tadzik: carsten said that above
15:29:31 <Stskeeps> at the moment there's a ongoing discussion, but no news today
15:29:34 <tadzik> oh, sorry
15:29:34 <SK_work> tbr: you can say "is desired"
15:29:36 <SK_work> tadzik: as said before, there are discussions
15:29:39 <tadzik> must've missed that
15:29:44 <tbr> #undo
15:29:50 <tbr> ah, can't, cybette
15:30:29 <tbr> cybette: ?
15:30:31 <cybette> #undo
15:30:31 <Merbot> Removing item from minutes: <MeetBot.items.Info object at 0x8b80d90>
15:30:36 <tbr> #info a indexer/lxr is desired by the community
15:31:19 <tbr> Stskeeps: well gpl bash scripts don't need to be built, do they? :)
15:31:30 <M4rtinK> maybe add a “silica c++ opensourcing“ tracker item to tjc ?
15:31:38 <Stskeeps> naah, but it would be nice if you don't have to sacrifice a goat to install the results..
15:31:47 <tbr> but then again you'd have some bits and pieces of source that cause you trouble in the workflow
15:32:10 <tbr> what are the thoughts on a LXR?
15:32:25 <sledges> tbr: would autodoc (next topics) handle indexing?
15:32:25 <tbr> anything to be expected from Jolla or community effort necessary?
15:32:35 <M4rtinK> whats LXR ?
15:32:39 <tbr> sledges: I don't know
15:32:40 <sledges> linux cross reference
15:32:51 <Stskeeps> i like the thought, but it kinda follows along with oss dumps too
15:32:57 <tbr> sledges: I thought that was a documentation only thing
15:33:09 <M4rtinK> oh
15:33:23 <sledges> tbr: ok, blurred lines :)
15:33:40 <Stskeeps> we do have a 'internal' lxr (man, that word sucks..) using gnu global
15:33:47 <tbr> M4rtinK: it's what people used for referencing source code before github was cool. ;)
15:33:49 <Stskeeps> so setup wise it shouldn't be bad
15:34:17 <tbr> Stskeeps: you have the benefit of everything being accessible as a VCS though
15:34:50 <SK_work> sledges: autodoc is not that nice for code browsing, docs != code
15:34:53 <tbr> on the other hand some _service parsing magic might help here
15:35:31 <Stskeeps> true
15:35:51 <cybette> DINg - 5 more min
15:35:54 <sledges> SK_work: that's right, i browser kernel code much more often than read Documentation/ ;) depends on component
15:36:01 <tbr> which would only leave a hand full of inaccessible repos to be fed by hand
15:36:34 <Stskeeps> nod
15:36:38 <Stskeeps> worth a thought
15:36:41 <tbr> do we have a consensus on a way forward for a lxr-type-o-thing? community or jolla-the-company?
15:37:05 <Stskeeps> i'd say let's talk about it during week, i'm not sure we have IT capacity for jolla-the-company right now, all that effort should go into community tool
15:37:08 <Stskeeps> for translation
15:37:17 <tbr> ok
15:37:51 <tbr> #info if there is community interest it could pick up the lxr topic as jolla is likely busy with the community translation tool in this aspect
15:38:50 <javispedro> so for community guy the idea is to just get one of the source DVDs and dump it on a website and install a lxr webapp?
15:38:50 <tbr> #info gpl bits of recovery are again tricky because not easily rebuilt, like silica. Stskeeps to look into it.
15:39:10 <tbr> javispedro: I can host it, but would prefer someone to help me with it.
15:39:17 <Stskeeps> javispedro: better yet, i include _service files too..
15:39:18 <Stskeeps> :P
15:39:20 <tbr> javispedro: most can be done by parsing the _service files
15:39:37 <tbr> Stskeeps: oh, you dumped them? they used to be in the isos
15:39:39 <javispedro> (all I know about _service files is that they must be some OBS thing)
15:39:47 <cybette> time to wrap this up...
15:39:53 <tbr> yes, they point to git checkouts etc
15:39:59 <javispedro> ah, ok.
15:39:59 <Stskeeps> tbr: they're in the tarballs, i don't delete them
15:40:02 <Stskeeps> (AFAIK)
15:40:09 <Stskeeps> if i did, that's a mistake :)
15:40:13 <tbr> ok, so we can look into it outside the meeting
15:40:13 <Stskeeps> ok, i'm done
15:40:18 <tbr> we're done
15:40:29 <cybette> #topic Updates from Jolla after summer break & discussions - all (45 min)
15:40:42 <cybette> please wait while I describe how we go about this
15:40:50 <cybette> To avoid everyone talking about different topics all at once, I will break them up into these areas:
15:40:59 <cybette> position on paid apps, planning outcome after summer holidays, middleware merge, bugzilla situation, ambiences/icon packs in Harbour, Store/Harbour updates, HADK - for 5 min each.
15:41:02 <tbr> javispedro: I did some simple parsing of the service files once and most contained github urls. only a few would need manual attention
15:41:09 <cybette> I have colleted some short updates, Jolla Sailors please comment more if you can.
15:41:17 <cybette> Strict timebox, no in-depth discussions, please leave that to future meetings. This is mainly for a quick update and general idea of how things are going.
15:41:27 <cybette> so let's start with...
15:41:28 <SK_work> thanks for this recap, it's needed :)
15:41:55 <cybette> #topic Jolla's position on paid apps
15:41:59 <cybette> #info we are working on this and the current estimate is later in Q4
15:42:02 <cybette> 5 minutes
15:42:51 <cybette> (probably not much to add to that, but please comment or ask anything qns you might have)
15:43:20 <tbr> any visibility yet if this will be geo-locked?
15:43:21 <SK_work> cybette: anything about some other nice features hat could be in harbour
15:43:31 <M4rtinK> any plans for in store donnate support ?
15:43:39 <sledges> SK_work: that will be later topic
15:43:41 <SK_work> like geolocation of users ?
15:44:00 <SK_work> M4rtinK: +1
15:44:04 <cybette> SK_work: please bring that up in the Store/Harbour topic :)
15:44:04 <tbr> SK_work: like "you can't buy apps as you are not in finland" (as a crass example)
15:44:49 <cybette> #idea from M4rtinK, Support for in-store donation
15:44:51 <Stskeeps> (sarcasm: your language is set to english, you cannot add a finnish credit card..)
15:44:55 <Stskeeps> ;)
15:45:07 <tbr> hrw had fun with that during his .cz trip...
15:45:17 <M4rtinK> brings back memories of the webOS app store :)
15:45:43 <Stskeeps> M4rtinK: i know that thp idly played with the idea of a flattr like approach
15:45:48 <Stskeeps> nothing factual though
15:46:00 <M4rtinK> that would be nice
15:46:02 <tbr> cybette: did you see my question?
15:46:09 <AL13N_work> so paid apps are not geo-locked?
15:46:13 <locusf> what about the laws in which receiving donations requires a permit or otherwise its illegal?
15:46:14 <M4rtinK> or gittip seems to be getting popular
15:46:37 <cybette> tbr: I have no idea. we can #info or #action that
15:47:00 <tbr> cybette: that's an answer too
15:47:03 <tbr> that's fine
15:47:20 <tbr> I didn't expect it to be known yet but wanted to ask
15:47:43 <cybette> #info Question about whether paid apps will be geo-locked
15:47:49 <cybette> ok moving on
15:47:54 <cybette> #topic Planning outcome after summer holidays (5 min)
15:48:07 <bijjal> #link https://lists.sailfishos.org/pipermail/devel/2014-August/004939.html
15:48:10 <cybette> #info Shared earlier today on mailing list: https://lists.sailfishos.org/pipermail/devel/2014-August/004939.html
15:48:18 <cybette> bijjal: thanks :)
15:48:21 <bijjal> :)
15:48:41 <cybette> comments/questions
15:48:41 <SK_work> yep, seen this mail :)
15:49:02 <bijjal> we hope to finalize the release in the next couple of weeks..
15:49:31 <SK_work> question: what new stuff Qt 5.2 provides ? For example QtLocation QtPositionning ?
15:49:43 <SK_work> will these new libs be allowed in harbour ?
15:49:47 <w00t> SK_work: that will probably take some time to work out after the release happens
15:50:23 <M4rtinK> well, that would be kinda disappointing
15:50:26 <tbr> so this is more like an next release scope. are there long term plans / work areas that can be shared?
15:50:38 <tbr> are there areas where the community can possibly help?
15:50:49 <w00t> qtlocation is a bit more murky (as it's still not for-sure-released upstream, though I spent a while trying to push for that to happen) but qtpositioning should be available as it's released upstream
15:50:49 <tbr> think like it happened for the caldav plugin
15:50:51 <M4rtinK> it has been long enough with no GPS support already...
15:51:46 <Stskeeps> we might want to move to a more er, recent, compiler/glibc, so there's at least some work that'll arrive in a few months regarding that
15:51:47 <M4rtinK> well I care only about positioning, as long as that is available I am fine :)
15:51:55 <cybette> #idea Sharing of longer term plans and areas where community can help
15:52:01 <w00t> tbr: people can contribute to the upstream modules/projects they want to see becoming stable, for starters
15:52:09 <Stskeeps> there's always crazy packaging or build errors appearing with newer gccs..
15:52:09 <w00t> qtlocation has no real dedicated maintainer upstream
15:52:30 <cybette> 5 min up. next...
15:52:34 <cybette> #topic Middleware merge (5 min)
15:52:41 <cybette> #info ongoing, there will be a lot happening this week on this topic
15:52:54 <Stskeeps> there was supposed to be a lot more done this summer but unfortunately my laptop got stolen during my summer.
15:52:58 <w00t> it had some drive-by effort by us for fixing various things and removing qt3d, but it needs someone who can spend real quality time on working on the codebase before they're comfortable releasing it, and right now, there isn't anyone available to do that..
15:53:05 <SK_work> Stskeeps: :(
15:53:06 <Stskeeps> which kinda made me unable to do anything but get sunburnt.
15:53:28 <cybette> Stskeeps: sorry for the laptop and yay for sunburn :P
15:53:30 <bijjal> tbr, yes, our first step after holidays was to muster up for the next update.. for the bigger picture, it'd have to wait a bit.. we have scheduled an internal sync on that during september
15:53:46 <Stskeeps> and read a lot .. i'm back on the horse now
15:54:01 <tbr> bijjal: ok! please keep us posted after that.
15:54:23 <Stskeeps> been helping to open source some hardware adaptation related bits today under mer-hybris/
15:54:31 <bijjal> tbr, but i can say that update 10 is most likely going to be about bug fixes, with qt5.2 and other bits in, we believe we need some time to improve the stability of the OS in general
15:54:41 <bijjal> tbr, surely!
15:55:26 <tbr> sure qt5.2 is a big move and there will be corner cases that will only surface in the field
15:55:42 <bijjal> :nod:
15:56:53 <cybette> moving on..
15:57:05 <cybette> #topic Bugzilla situation (5 min)
15:57:14 <cybette> eleroux: can you help me a bit on this?
15:57:35 <eleroux> cybette: sure :)
15:57:58 <cybette> thanks eleroux :)
15:59:09 <javispedro> ?
15:59:28 <eleroux> #info no current plan to deploy a specific instance but we are working on automation between TJC and our internal tracker to follow up - a robot is planned to comment on TJC related items whenever actions are taken
15:59:46 <eleroux> However, the topic remains open :)
16:00:00 <vgrade_> #info Bugs are being tracked in nemomobile Bugzilla for HADK adaptations #link https://bugs.nemomobile.org/buglist.cgi?product=Hardware%20adaptation&component=Hybris-ing&resolution=---
16:00:16 <locusf> was just going to mention that, thanks vgrade_ :)
16:00:20 <vgrade_> #info We are at the point we need to start doing some triage and we would like to know the best time to organise them to get the best input from Jolla Sailors
16:00:20 <sledges> +1
16:00:38 <SK_work> cool, awesome :)
16:01:04 <cybette> thanks for the summaries, eleroux and vgrade_
16:01:24 <eleroux> #info The same mechanism is under work to make Bugzilla instances talk to each other… More to come when we're closer to deploying
16:01:40 <sledges> #info mer/nemo bz versions will have to be updated
16:01:58 <sledges> lbt will look into that when frees up
16:02:17 <javispedro> so the plan is for TJC to be used as public-facing bugzilla for sailfish-specific issues?
16:02:23 <sledges> yes
16:02:34 <cybette> #topic Ambiences/icon packs in Harbour (5 min)
16:02:44 <cybette> #info This is a good input to know that the community is also interested on this. We have thought about this and started on the planning but haven't started the implementation yet.
16:03:18 <eleroux> javispedro: TJC is meant to be used as public-facing tracker, forum, etc… We shape it as we need
16:05:59 <cybette> if no comments, we can go to next topic
16:06:14 <cybette> #topic Store/Harbour updates (5 min)
16:06:21 <cybette> #info Like you have noticed that we submitted update to harbour couple of weeks ago with support for metrics and other small bug fixes.
16:06:25 <cybette> #info We are planning to release soon an update that enables support for python apps to be submitted
16:06:33 <sledges> \o/
16:06:35 <locusf> YAY
16:06:41 <M4rtinK> finally! :D
16:06:54 <tbr> wow \o/
16:07:07 <lbt> sledges: I'm actually doing nemo bz cert right now
16:07:31 * sledges hi5s lbt
16:07:48 * lbt hi5s sledges
16:07:53 <SK_work> finally
16:07:54 <cybette> SK_work: did you have some feature suggestions for Harbour?
16:08:03 <SK_work> cybette: download map
16:08:10 <SK_work> statistics (download per day etc.)
16:08:23 <SK_work> it lacks fancy graphs
16:08:29 <SK_work> also a web ui for comments
16:09:08 <locusf> I have also lost some comments on my app
16:09:11 <M4rtinK> well, a web UI ? :)
16:09:18 <locusf> from store, I'd like to see them somehow again
16:09:20 <cybette> #idea Download map, statistics (downloads per day etc.), fancy graphs in Harbour
16:09:49 <cybette> #idea Web UI for comments / web UI for store in general
16:10:06 <M4rtinK> also guess a cli tool for submitting packagrs would be nice, but not critical
16:10:31 <AL13N_work> maybe for updates
16:10:36 <AL13N_work> so it can be a git hook or something
16:10:39 <M4rtinK> *packages
16:11:06 <javispedro> maybe a webapi in general =)
16:11:12 <MSameer> M4rtinK: we can script that with curl :D
16:11:20 <M4rtinK> I already have some crazy packaging scripts so the more stuff I can hook to it the better :)
16:11:38 <M4rtinK> well, one can always do that :P
16:11:40 <SK_work> definitely need a webui :)
16:11:55 <cybette> #idea CLI tool for submitting packages, perhaps a git hook
16:12:02 <M4rtinK> also an idea - suplort fot more packages
16:12:16 <M4rtinK> say theme l10n data
16:12:30 <AL13N_work> shouldn't these be rpm?
16:12:30 <M4rtinK> that might not change that often
16:12:37 <cybette> looks like this is a popular topic. we can discuss details in future meetings. let's continue with updates
16:12:59 <cybette> #topic HADK porting (5 min)
16:13:09 <cybette> vgrade_: please share the updates
16:13:13 <vgrade_> #info We have many porters engaged in HADK execution #link https://wiki.merproject.org/wiki/Adaptations/libhybris/porters on #sailfishos-porters
16:13:28 <vgrade_> #info Community builds for Nexus5, Galaxy Nexus and Galaxy Note are out with many more in various stages of port
16:13:37 <vgrade_> #info multiROM support for N5 after help from the multiROM author
16:13:57 <vgrade_> #info we have some take up by xda forum members and on the whole good constructive comments. More engaement with that community planned
16:14:06 <vgrade_> #info The main requests are around official store, OTA updates and android app support.
16:14:16 <vgrade_> #info there will be a Jolla and sailfish community presence at xda:devcon in Manchester next month, #link http://xda-devcon.com/
16:14:35 <vgrade_> #info a big thanks to everyone
16:14:46 <cybette> a big thanks to you, vgrade_ !
16:15:05 <sledges> #info requests on camera, too; and gps (gps is blocked by a non-oss sailfish geo component plugin missing for non jolla devices)
16:15:24 <lbt> vgrade_: great updates
16:15:26 <vgrade_> sledges: +1
16:16:12 <sledges> #info we need gpu experts *cough* stskeeps for https://wiki.merproject.org/wiki/Adaptations/libhybris/gpu, blocking many more amazing devices from reaching uiatm
16:17:12 <cybette> thanks again for the great updates on this
16:17:27 <lbt> #info the https://bugs.nemomobile.org/ bugzilla is being used to track issues on the opensource/HA aspects of the HADK
16:17:44 <cybette> #topic Others: community translations, documentation/autodoc situation, chum repos (5 min)
16:17:50 <cybette> I do not have any updates on these, if anyone does, please share. Or if I missed any topics, please add them here with #info
16:18:17 <sledges> bijjal: is community translation tool sailor here?
16:18:18 <tbr> #info chum needs more active testers that provide feedback about apps in "testing"
16:19:06 <javispedro> tbr: is chum already working? can I start using obs for sailfish packages?
16:19:15 <tbr> #info There is a community effort (mainly by me) to bring a push notification framework to sailfish (based on MQTT). First results very promising and we have reliable irssi notifications. We are on #sailfishos-push
16:19:50 <tbr> javispedro: I'd call it in "beta". many things are still forming, but packages can be already submitted, yes
16:20:04 <M4rtinK> javispedro: the salifish target has been in OBS for quite a whilen already
16:20:13 <cybette> tbr: great to hear :)
16:20:22 <bijjal> sledges: i think not
16:20:55 <javispedro> M4rtinK: yeah, but last time I tried it did not actually have sailfish specific pkgs (such as libsailfishapp)
16:21:29 <tbr> that stuff has been there since last christmas or such?
16:21:38 <javispedro> ok, so then I'm doing something wrong.
16:21:44 <javispedro> will ask after the meeting
16:21:48 <tbr> *nod*
16:22:46 <lbt> #info no progress on autodoc
16:23:10 <lbt> I'm working on some tasks which will result in touching boss and OBS and that will be when I touch autodoc
16:23:12 <javispedro> tbr: where I can read more about the state of chum (client-side too). Where is the queue of pending pkgs for example?
16:23:19 <javispedro> pending for review that is.
16:23:19 <bijjal> w.r.t community translation tool, we are closer to releasing. A bit more work pending to ensure that we have necessary infra to do fast changes and verify
16:23:37 <tbr> javispedro: I'll show you links after the meeting
16:23:41 <javispedro> merci!
16:23:44 <SK_work> \o/ bijjal
16:23:54 <cybette> #info <+bijjal> w.r.t community translation tool, we are closer to releasing. A bit more work pending to ensure that we have necessary infra to do fast changes and verify
16:24:09 <cybette> ok thanks everyone for all the updates. let's wrap up.
16:24:19 <cybette> #topic Wrap up and next meeting (10 min)
16:24:43 <cybette> #info Please submit topic proposals for future meetings to SailfishDevel mailing list (instead of the Pirate Pad)
16:25:21 <tbr> how about a TJC post?
16:25:22 <cybette> shall we have the next meeting in one or two weeks?
16:25:45 <cybette> tbr: that's a viable idea
16:25:55 <locusf> TJC is proper
16:26:02 <Stskeeps> #info If anybody is in Helsinki, feel free to join for informal/unofficial jolla user beer in Amsterdam Bar in Ruoholahti at 17:30 (next to metro station) on Thursday 21st
16:26:03 <javispedro> yeah, I never got why piratepad when TJC has fully working wikies :)
16:26:04 <cybette> comments? TJC post for agenda topic proposal or ML?
16:26:35 * tbr votes for tjc
16:26:40 <lbt> cybette: TJC wiki post ?
16:26:47 <javispedro> I say TJC instead of piratepad, but please keep sending the ML "summaries", they are useful
16:27:05 <cybette> #info If anybody is in Tampere, feel free to join for informal/unofficial Jolla meetup this Saturday - time and venue to be confirmed. Ping cybette
16:27:22 <cybette> lbt: that would work :)
16:28:16 <cybette> #info Meeting topic proposals on TJC wiki post instead
16:28:33 <cybette> #action cybette to create TJC post for next meeting
16:28:35 <tbr> cybette: please also ping the devaamo mailing list for that
16:28:45 <Morpog_PC> finally catched up :D
16:28:48 <cybette> tbr: will do!
16:29:03 <cybette> alright, next meeting: in 1 or 2 weeks?
16:29:18 <SK_work> cybette: maybe one week ?
16:29:24 <Stskeeps> i vote one week
16:29:25 <SK_work> hum, meeting on TJC is a good idea :)
16:29:42 <locusf> is discussing the community HADK proper for this channel or #sailfishos-porters?
16:29:47 <tbr> cybette: is there a lot going on that we need it next week already?
16:30:00 <cybette> SK_work: lol, meeting stays in IRC, topics proposed on TJC :)
16:30:01 <SK_work> tbr: middleware merge ?
16:30:06 <Stskeeps> locusf: any discussion can go on in that irc channel just fine :)
16:30:07 <tbr> roger
16:30:15 <SK_work> cybette: I meant topics indeed :)
16:30:17 <locusf> Stskeeps: okay
16:30:23 <tbr> 10:00 utc?
16:30:25 <cybette> SK_work: ok :)
16:30:58 <cybette> tbr: yes, let's see if jalyst can join at this time
16:31:07 <SK_work> yep
16:31:30 <cybette> #info Next community meeting 2014-08-26, 10:00 UTC
16:31:52 <sledges> and hope faenil gets a new HDD
16:31:54 <sledges> so joins too
16:32:04 <sledges> lol
16:32:17 <cybette> speaking of the devil ;)
16:32:25 <tbr> jalyst: meeting next week at 1000utc :)
16:32:42 <cybette> jalyst: yes, see you next week! now go back to bed ;)
16:32:47 <jalyst> u better not have been talking about me! ;-P
16:32:56 <tbr> 18:30:58<@cybette> tbr: yes, let's see if jalyst can join at this time
16:33:02 <cybette> thank you everyone, and apologies for being 5 min late
16:33:09 <jalyst> GN ;-P 240am
16:33:28 <sledges> and hence we're 5mins overtime, no worries cybette :))
16:33:37 <cybette> sledges: :)
16:33:39 <cybette> cheers all
16:33:39 <javispedro> thanks all indeed.
16:33:40 <sledges> nn jalyst
16:33:40 <kimmoli_sailing> plop ? i did notice beer in logs
16:33:47 <sledges> porters beer?
16:33:48 <cybette> #endmeeting