#mer-meeting: SailfishOS, open source, collaboration: 25-November @ 15:00 UTC

Meeting started by cybette at 15:00:18 UTC (full logs).

Meeting summary

    1. Welcome to another week of SailfishOS OSS and collaboration meeting (cybette, 15:00:32)
    2. Kimmo Lindholm, TOH-tailor, tohkbd-team. Community member. (kimmoli, 15:00:34)
    3. Meeting info and agenda: https://lists.sailfishos.org/pipermail/devel/2014-November/005276.html (cybette, 15:00:47)

  1. Brief introductions (5 min), prefix your information with #info (cybette, 15:00:59)
    1. Kimmo Lindholm, TOH-tailor, tohkbd-team. Community member. (kimmoli, 15:01:04)
    2. Simonas Leleiva, community sailor, sailfish for everyone (porting to android devices) (sledges, 15:01:10)
    3. Jonathan Frederickson, community member (ryukafalz, 15:01:14)
    4. Thomas B. Ruecker, community member (tbr, 15:01:16)
    5. Martin Kolman, community, modRana developer (M4rtinK_jolla_, 15:01:16)
    6. Lucien Xu, community member and dev (SK_work, 15:01:23)
    7. Carol Chen, Community Chief at Jolla, hatless chair today (cybette, 15:01:23)
    8. Andrea Bernabei, Nemomobile contributor, Sailfish community member (faenil, 15:01:24)
    9. Siteshwar, community (situ, 15:01:27)
    10. Thomas A., app developer (Armadillo, 15:01:28)
    11. Carsten Munk, Chief Research Engineer @ Jolla (Stskeeps, 15:01:32)
    12. Steph Gosling, community (stephg, 15:01:38)
    13. François, community member, dev-wannabe (daitheflu, 15:01:51)
    14. Bernd Wachter, Release Guy and other stuff @ Jolla (Aard, 15:01:58)
    15. Christophe Chapuis, community member, qml dev (Tofe, 15:01:59)
    16. Basil Semuonov, community member (BasilSemuonov_, 15:02:01)
    17. Julius-Paul Jann, community (Nokius, 15:02:03)
    18. Stephan Hagen, community member (shfit, 15:02:15)
    19. Reto Zingg, Sailor @ Jolla (kontio, 15:02:45)
    20. Jonni Nakari, community member, app developer (Wnt, 15:02:46)
    21. Giulio Camuffo, developer at Jolla (giucam, 15:02:53)
    22. Raine M�kel�inen, developer @ Jolla (rainemak, 15:03:01)
    23. Alejandro Exojo, Qt and Jolla user (suy, 15:03:04)
    24. Jürg Billeter, community member (juergbi, 15:03:07)
    25. Jarkko Lehtoranta, developer @ Jolla (Jare, 15:03:12)
    26. Mohammed Hassan. Hacker and Sailor (Mostly listening) (MSameer, 15:03:36)
    27. Tim Klocke, community member (Taaeem, 15:03:38)
    28. Pami Ketolainen, developer @ Jolla (pketolai, 15:03:40)
    29. Soumya Bijjal program manager at Jolla (bijjal, 15:04:05)
    30. Iekku Pylkk�, develoeper-care + harbour qa @ jolla (iekku, 15:04:11)
    31. Islam Amer, developer @ jolla (phaeron, 15:04:13)
    32. Kaj-Michael Lang, community member, app developer (oniongarlic, 15:04:14)
    33. Val�rio, sailor @ Jolla (VDVsx, 15:04:49)

  2. Hot news: store API update - bijjal and kontio (15 min) (cybette, 15:05:40)
    1. https://github.com/sailfish-sdk/sdk-harbour-rpmvalidator/commits/master (sledges, 15:09:29)
    2. Starting with Update 10, a few new APIs will be allowed in Harbour. For details see log and above link (cybette, 15:10:31)
    3. kimmoli summarized the git commits: shortly list of new allowed: libssl, libcrypto, liblzma, libxml2, libogg, libvorbis, QtGraphicalEffects (tbr, 15:16:49)
    4. Demand for Positioning API noted and will be sorted/clarified inhouse (cybette, 15:17:16)
    5. https://github.com/sailfish-sdk/sdk-harbour-rpmvalidator/pull/20 ? (kimmoli, 15:17:29)

  3. Generic info about Jolla Tablet - SK_work or Armadillo (20 min) (cybette, 15:20:25)
    1. Idea is for Jolla to share a bit more info about the Jolla tablet followed by Q&A (cybette, 15:20:33)
    2. Will the bootloader be open? - <+Stskeeps> we built sailfishos on open devices. it doesn't make sense to deny that ability to others. (tbr, 15:25:14)
    3. We built SailfishOS on open devices, and do not plan to deny this ability to others. Together we'll find a solution balancing privacy and security with the aim to install alternative OS'es (cybette, 15:25:44)
    4. ACTION: cybette to get jolla.com/tablet updated with USB OTG info (cybette, 15:31:46)
    5. Regarding Sailfish OS progress for phone and tablet, please see https://together.jolla.com/question/63989/jolla-tablet-sailfishos-2-what-about-update-9/#post-id-64196 (cybette, 15:36:19)
    6. http://commonsware.com/blog/2013/11/21/libhoudini-what-it-means-for-developers.html is what intel devices normally use; but how that works without android runtime is a bit unknown. also, a lot of processes are more GPU bound. (Stskeeps, 15:38:02)

  4. Is SailfishOS Open Source - SK_work or tbr (20 min) (cybette, 15:40:30)
    1. So, recently there were a few obvious mistakes in the usage of the term "open source" by Jolla marketing. This is causing unnecessary tension and discussion and poisons the atmosphere between Jolla and the open source community. We'd like to remind Jolla about its roots and to respect the community on which its success is built. (tbr, 15:40:51)
    2. TL;DR - Stskeeps providing a look at how things are inside Jolla the company and Jolla Sailors/engineers as part of the open source community. For more details, please read log. (cybette, 15:52:36)

  5. How to test for different devices with SDK - Armadillo (15 min) (cybette, 16:05:46)
    1. Sailfish OS SDK uses targets, so there'll be a target per device. Multi-arch is already supported with the target design. (cybette, 16:09:25)

  6. Generic info on how's going inside Jolla about topic discussed before - SK_work (10 min) (cybette, 16:21:16)
    1. After the testruns with opt-in we had for hotfix + u9 we decided now to make updates available as opt-in when we're qa-wise ready to release from our side, and will push it to the general public about 1 week later (having fixed critical issues, if found during that time) (cybette, 16:24:06)
    2. you opt in once, and that's valid until you opt out. you won't be able to opt out when there's an opt-in update pushed out to avoid downgrading issues. (cybette, 16:25:30)
    3. Mer-Nemo merging status: currently, xulrunner compilation issue is blocking. Next: git repos moving and bugzilla stuff (SK_work, 16:26:38)

  7. Wrap up and next meeting (5 min) (cybette, 16:31:49)
    1. "Special" meeting next week Tues Dec-2 @ 15:00 UTC, Chairperson tbr (tentative) (cybette, 16:37:55)
    2. Next regular meeting Tues Dec-16 @ 15:00 UTC, Chairperson cybette (cybette, 16:38:00)
    3. ACTION: tbr to create specific TJC item for next week's special meeting (cybette, 16:38:27)
    4. ACTION: cybette to change channel topic for next meetings (cybette, 16:38:40)


Meeting ended at 16:40:53 UTC (full logs).

Action items

  1. cybette to get jolla.com/tablet updated with USB OTG info
  2. tbr to create specific TJC item for next week's special meeting
  3. cybette to change channel topic for next meetings


Action items, by person

  1. cybette
    1. cybette to get jolla.com/tablet updated with USB OTG info
    2. cybette to change channel topic for next meetings
  2. tbr
    1. tbr to create specific TJC item for next week's special meeting


People present (lines said)

  1. SK_work (129)
  2. Stskeeps (79)
  3. cybette (66)
  4. tbr (56)
  5. M4rtinK_jolla_ (42)
  6. lbt (42)
  7. faenil (37)
  8. kontio (26)
  9. Armadillo (25)
  10. kimmoli (20)
  11. ryukafalz (20)
  12. stephg (15)
  13. Aard (11)
  14. daitheflu (10)
  15. Wnt (9)
  16. VDVsx (9)
  17. Tofe (9)
  18. shfit (8)
  19. sledges (8)
  20. iekku (8)
  21. Nokius (8)
  22. javispedro (7)
  23. MSameer (5)
  24. deztructor (5)
  25. phaeron (5)
  26. jmlich (5)
  27. Merbot (3)
  28. locusf (3)
  29. juergbi (3)
  30. oniongarlic (3)
  31. Jare (2)
  32. suy (2)
  33. BasilSemuonov_ (2)
  34. bijjal (2)
  35. reviewjolla (1)
  36. pketolai (1)
  37. situ (1)
  38. leinir (1)
  39. rainemak (1)
  40. giucam (1)
  41. Sail0r (1)
  42. tadzik (1)
  43. Taaeem (1)


Generated by MeetBot 0.1.4.