15:00:22 <iekku> #startmeeting SailfishOS, open source, collaboration: 10-March 2015
15:00:22 <merbot> Meeting started Tue Mar 10 15:00:22 2015 UTC.  The chair is iekku. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
15:00:22 <merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:30 <iekku> welcome :)
15:00:36 <iekku> # topic Intro (5 min)
15:00:37 <iekku> #info intoduce yourself, use #info in the beginning
15:00:43 <lainwir3d_> \o
15:00:45 <kimmoli> #info Kimmo Lindholm,  TOHs et.al.
15:00:47 <locusf> #info Aleksi Suomalainen, Nemo Mobile community
15:00:58 <vgrade_mm> #info Martin Brook , community member, HADK eater
15:01:05 <cybette> iekku: space between # and topic
15:01:14 <Nokius|jolla_> #info Nokius, community
15:01:14 <iekku> graah
15:01:15 <SfietKontantinW> #info Lucien Xu, community
15:01:17 <vmaatta> #info Ville Määttä, random dev, Ruriat
15:01:20 <lainwir3d_> #info Richard Rondu, app developer (RPNCalc, Parrot Zik 2.0 Manager)
15:01:24 <iekku> #topic Intro (5 min)
15:01:42 <iekku> noo
15:01:55 <otsaloma> #info Osmo Salomaa, app developer
15:02:01 <kimmoli> not worky?
15:02:03 <iekku> #topic Intro (5 min)
15:02:07 <iekku> no, not worky
15:02:10 <iekku> hold on
15:02:23 <M4rtinK_jolla_> #info Martin Kolman, community member & modRana navigation system developer
15:02:41 <iekku> #topic Intro (5 min)
15:02:43 <iekku> now
15:02:46 <kimmoli> #info Kimmo Lindholm,  TOHs et.al.
15:02:51 <iekku> #info intoduce yourself, use #info in the beginning
15:02:54 <vgrade_mm> #info Martin Brook , community member, HADK eater
15:02:57 <lainwir3d_> #info Richard Rondu, app developer (RPNCalc, Parrot Zik 2.0 Manager)
15:02:58 <iekku> please, again
15:03:07 <sledges> #info Simonas Leleiva, Jolla sailor, #sailfishos-porters, community pootle
15:03:08 <SfietKontantinW> #info Lucien Xu, community, dev
15:03:15 <cybette> #info Carol Chen, community chef @ Jolla, tired but happy sailor from mwc
15:03:15 <SfietKontantinW> community pootle
15:03:18 <Nokius|jolla_> #info Nokius , community
15:03:29 <vmaatta> #info Ville Määttä, random dev, Ruriat
15:03:37 <spiiroin> #info Simo Piiroinen, Jolla sailor, mostly nemo mw
15:03:47 <iekku> #info Iekku Pylkk�, Developer community sailor, hatles chair today
15:04:17 <thp> #info Thomas Perl, sailor
15:04:22 <otsaloma> #info Osmo Salomaa, app developer
15:04:54 <Munnu> #info Timo Munnukka, developer
15:05:08 <iekku> locusf, vmaatta: could you please repeat your info?
15:05:13 <vmaatta> #info Ville Määttä, random dev, Ruriat
15:05:22 <vgrade_mm> nh1402_:info yourself
15:05:26 <locusf> #info Aleksi Suomalainen, Nemo Mobile community
15:05:50 <vmaatta> iekku: maybe 3rd time was the charm :)
15:05:58 <iekku> :)
15:05:59 <nh1402_> #info community member, currently attempting to get android compatibility working via cyanogenmod
15:07:05 <iekku> moving on
15:07:13 <iekku> #topic SailfishOS and SailfishOS Secure - Nokius (10-20 min)
15:07:22 <iekku> #info Nokius can't join, "Please tell more about the plans will be the consumer SFOS Version be an other branche or will it have the same Core."
15:08:06 <Nokius|jolla_> Last Monday Jolla announced the partnership  with SSH Communication Security and SailfishOS Secure. After that announcement there ware a discussion in social-media about it and the question if it's  a new branch or does  the consumer Version will get the security  features as well. So can we get today some more information about this. Thanks
15:08:26 <iekku> #link https://cdn.jolla.com/wp-content/uploads/bsk-pdf-manager/49_PRESS_RELEASE_MWC_SAILFISHSECURE_FINAL.PDF
15:08:48 * Nokius|jolla_ back to work thanks for the answer
15:09:11 <iekku> Nokius|jolla_, thank you
15:11:32 <locusf> I remember Marc Dillon stating that the Sailfish Secure is coming to consumers as well in the JollaUsers question session in youtube
15:11:38 <cybette> we made the announcement for Sailfish Secure at MWC, however the project has just started and things are still being defined
15:11:54 <cybette> there is plan to make it available for consumers
15:12:25 <iekku> #info we made the announcement for Sailfish Secure at MWC, however the project has just started and things are still being defined
15:12:36 <M4rtinK_jolla_> will it be open source ?
15:12:37 <iekku> #info there is plan to make it available for consumers
15:13:22 <cybette> for other customers (governments, enterprises etc.) there will be discussions on case-by-case basis to determine their specific needs and work with them on that
15:14:02 <SfietKontantinW> so Sailfish secure is more for gouvernments and companies
15:14:11 <SfietKontantinW> not really for average user
15:14:17 <vmaatta> #info will it be open source, and if so, what type of licence? i.e. permissive or not etc.
15:14:54 <NSA-Rep> I believe features that will be required for the enterprises will make their way to consumers (ie VPN stuff)
15:15:30 <cybette> SfietKontantinW: some security features will be made available to everyone, others require customized solutions
15:16:07 <M4rtinK_jolla_> also is it actually software or more of a certification/audit thing ?
15:16:09 <cybette> vmaatta: those are still being discussed and planned
15:16:16 <vmaatta> #info "others require customized solutions" i.e. proprietary?
15:16:55 <vmaatta> cybette: :) yeah I'm sure they are… voicing the concerns / interest
15:16:56 <cybette> vmaatta: please do not #info your questions
15:17:26 <iekku> thank you cybette.
15:17:29 <vmaatta> cybette: I'll be conservative
15:17:43 <cybette> M4rtinK_jolla_: I would say more software, as the solution is based on a security-hardened version of Sailfish OS and SSH's communication encryption and key management platform
15:18:01 <iekku> please use #info to information, not to questions.
15:18:05 <vmaatta> cybette: note though: " People should liberally use this for important things they say, so that they can be logged in the minutes."
15:19:23 <inte> what about gpg support? (if I may ask here)
15:19:38 <iekku> vmaatta, point taken. this conversation however doesn't belong to this topic, but to general
15:20:01 <vmaatta> iekku: very much true so I didn't and won't comment about it further
15:20:11 <cybette> inte: I don't have info on that at the moment
15:20:21 <inte> thx
15:20:33 <thp> inte: gpg 2.0.4 is on the device, but do you mean support in the e-mail client?
15:20:42 <inte> exactely
15:20:56 <iekku> #action iekku will collect unaswered questions
15:20:57 <thp> inte: refer to together.jolla.com if there's a thread for this already, if not, create one.
15:21:00 <inte> im using mutt with the built in jolla-gpg which works but....
15:21:14 <inte> i put mutt on openrepos already :-)
15:21:23 <vmaatta> yeah integration of gpg at system level would be quite beneficial and fit the Secure OS theme
15:21:40 <vmaatta> but I support this deal is only about SSH corp products
15:21:43 <iekku> #info integration of gpg at system level would be quite beneficial and fit the Secure OS theme
15:22:05 <thp> again, gpg integration into system/apps best discussed/brainstormed at a together.jolla.com topic
15:22:09 <M4rtinK_jolla_> also maybe OTR in IM a user data encryption ?
15:22:15 <vmaatta> s/I support/I suppose/
15:22:27 <thp> https://together.jolla.com/question/887/gpg-for-email-and-other-stuff/
15:22:35 <iekku> #info gpg integration into system/apps best discussed/brainstormed at a together.jolla.com topic
15:22:54 <iekku> #link https://together.jolla.com/question/887/gpg-for-email-and-other-stuff/
15:23:42 <iekku> anything else on this topic, or should we move on?
15:24:20 <cybette> basically we do not have too much to share on this topic at this point, the project is just starting and we'll share more info with you as we progress
15:24:58 <iekku> #info more info will be shared as project progress
15:24:59 <vmaatta> good development and idea.. and something to return to when things develop
15:25:11 <cybette> vmaatta: certainly, thanks :)
15:25:26 <iekku> #topic Clarification about GPS & QtPositioning usage in Jolla store applications - M4rtinK (20 min)
15:25:35 <iekku> M4rtinK_jolla_, could you please?
15:25:45 <M4rtinK_jolla_> sure
15:27:29 <M4rtinK_jolla_> I see it as a simple question - why cant application developers use QtPositioning for Harbour apps and are more or less forced to use a low lewel DBUS api instead?
15:28:02 <M4rtinK_jolla_> The APIs are functionally equivalent so it feels very weird.
15:28:46 <thp> technically, starting with qt 5.2, we can now allow qtpositioning. just waiting on legal team to approve some details.
15:29:00 <M4rtinK_jolla_> also the geoclue DBUS api is pretty hard to use for Python or pure QML apps in a Harbour compatible way
15:29:07 <SfietKontantinW> M4rtinK_jolla_: how easy would it be to wrap QtPositioning API just around geoclue DBus API ?
15:29:45 <M4rtinK_jolla_> it would be doable, sure
15:29:46 <SfietKontantinW> thp: do you know if the legal issue is about the QtPositioning API or geoclue API too ?
15:29:54 <thp> agree that using geoclue D-Bus API is not ideal. also agree that QtPositioning can do the same thing as GeoClue (and the same thing as android apps, for that matter)
15:29:57 <SfietKontantinW> as it might be because of the HERE positioning API
15:30:31 <iekku> #info technically, starting with qt 5.2, we can now allow qtpositioning. just waiting on legal team to approve some details.
15:31:14 <thp> SfietKontantinW: harbour faq at the moment recommends geoclue as stopgap solution.
15:31:20 <M4rtinK_jolla_> so how come Geoclue  is fine and QtPositioning is not ?
15:32:22 <thp> M4rtinK_jolla_: "historic reasons". qtpositioning wasn't ABI- (API?-) stable in qt 5.1 and before. with D-Bus APIs, API stability is a bit different (your calls would fail, but your apps don't crash.. usually)
15:32:54 <M4rtinK_jolla_> or what if I submitted an Android app that uses QtPositioning to Harbour, woukd it be accepted ?
15:33:07 <SfietKontantinW> thp: what if community provides a geoclue wrapper that provides QtPoisitionning API ?
15:33:16 <SfietKontantinW> would it be accepted and packaged etc ? as a workaround ?
15:33:32 <M4rtinK_jolla_> thp: sure, but that should be no longer the case with Qt 5.2
15:33:43 <thp> SfietKontantinW: idea is to get the legal checks done and then allow QtPositioning as-is.
15:34:09 <SfietKontantinW> thp: :)
15:34:17 <SfietKontantinW> but maybe the legal stuff would take a long time
15:34:23 <thp> i'd say we hopefully can get this done within a week. allowing qtpositioning then should just be a matter of updating rpmvalidator.
15:34:23 <M4rtinK_jolla_> and 'undisclosed legal stuff' is getting rather tiring after all the waiting...
15:34:55 <M4rtinK_jolla_> thp: a week from now ? ;-)
15:35:04 <SfietKontantinW> M4rtinK_jolla_: +1
15:35:13 <SfietKontantinW> but now we have a deadline :)
15:35:20 <thp> i'll try to push this forward internally. won't happen today, though. and no promises, but i'll see what i can do.
15:35:27 <NSA-Rep> a week after they start which can be months away :P
15:35:48 <thp> but you guys have to submit apps to harbour then using qtpositioning :p
15:35:54 <thp> anyway, i think we can wrap up this topic and continue?
15:36:02 <iekku> +1
15:36:12 <M4rtinK_jolla_> thp: thanks - it is nice to finally see feedback like this! :-)
15:36:20 <SfietKontantinW> yeah
15:36:28 <M4rtinK_jolla_> info it ?
15:36:33 <SfietKontantinW> good news
15:36:38 <otsaloma> thanks thp, we do have apps waiting
15:36:47 <iekku> #info thp tries to push it internally
15:36:56 <iekku> #info you guys have to submit apps to harbour then using qtpositioning :p
15:36:58 <iekku> ;)
15:37:00 <thp> #action thp to push forward qtpositioning internally. eta 1 week, no promises.
15:37:13 <iekku> thp, thanks
15:37:19 <iekku> moving on
15:37:20 <SfietKontantinW> thp: can you keep us posted ? like via twitter or on irc ?
15:37:20 <M4rtinK_jolla_> modRana has been reaady for half a year at least :)
15:37:21 <NSA-Rep> this last info "thp tries to push it internally" sounds weird :P
15:37:31 <SfietKontantinW> M4rtinK_jolla_: /me using modrana for half a year :)
15:37:39 <iekku> NSA-Rep, ;)
15:37:57 <thp> SfietKontantinW: yup, feel free to poll status from me via irc daily ;)
15:38:04 <iekku> #topic General discussions - everyone (10 min)
15:38:35 <NSA-Rep> two questions: 1) status of offline HERE maps (stefano said that it would start this year)
15:39:04 <iekku> #action iekku to find out status of offline HERE maps (stefano said that it would start this year)
15:39:05 <SfietKontantinW> NSA-Rep: really ? :)
15:39:26 <M4rtinK_jolla_> FYI I'm close to offline routin on Sailfish Os
15:39:33 <M4rtinK_jolla_> *routing
15:39:43 <NSA-Rep> 2) Ways to accelerate DIT. Ie. a guy solved the voisemail problem but jolla hasn't said much (or i didn't notice it) how to make the process of taking in things faster
15:39:44 <iekku> NSA-Rep, so nothing to share, but i will try to get info for next meeting
15:39:44 <SfietKontantinW> M4rtinK_jolla_: cool, but do you have offline map rendering ?
15:39:50 <SfietKontantinW> this will help a lot
15:40:05 <SfietKontantinW> NSA-Rep: +1 for the topic of DIT
15:40:19 <iekku> 2) sound more like own topic
15:40:21 <SfietKontantinW> + there are plenty of community patching going around
15:40:32 <M4rtinK_jolla_> SfietKonstantinW: just offline routing for now
15:40:33 <NSA-Rep> DIT also inscludes translations and kb layouts and stuff which are needed yesterdays and don't get much traction.
15:41:07 <iekku> NSA-Rep, we are working on getting translations part open for community.
15:41:25 <iekku> oops, i forgot that i don't have hat
15:41:28 <cybette> NSA-Rep: source of stefano's comment?
15:41:32 <NSA-Rep> i know the translation tool is comming but thats just half the problem. Kbrds are missing
15:41:47 <M4rtinK_jolla_> but I basically forked Monav (check for monav-light on GitHub) so it might be possible to reuse the ofkine map rendering code too
15:42:00 <SfietKontantinW> NSA-Rep: problem about this is the same as with privileged API: security issues
15:42:02 <vmaatta> any upates on the topic of in-app payment / paid apps etc topics?
15:42:19 <SfietKontantinW> M4rtinK_jolla_: did you ever thought about using osmand ? they have Qt code !
15:42:21 <NSA-Rep> https://together.jolla.com/question/339/downloadable-map-data-and-offline-turn-by-turn-navigation-in-maps/?answer=54921#post-id-54921 next january
15:42:26 <vmaatta> s/upates/updates/
15:42:43 <NSA-Rep> and the comment was made on sep 14
15:42:51 <iekku> vmaatta, unfortunately no
15:43:23 <vmaatta> ok
15:43:34 <NSA-Rep> cybette: except if he meant jan 2016 :P
15:43:44 <thp> NSA-Rep: re: 2.) -- which voicemail problem and how was it solved? is there a patch / fix somewhere that we should see to get merged?
15:44:16 <SfietKontantinW> thp: basically the jolla do not display any voicemail notification
15:44:21 <SfietKontantinW> even if the middleware seems to handle it
15:44:29 <NSA-Rep> thp: wait i have to find the tjc comments
15:44:36 <SfietKontantinW> thp: basically it is a ui issue
15:44:47 <SfietKontantinW> https://together.jolla.com/question/8779/no-notification-when-new-voicemail/?answer=76513#post-id-76513
15:45:04 <SfietKontantinW> patch is included
15:45:39 <NSA-Rep> SfietKontantinW: you are faster :D
15:45:40 <cybette> NSA-Rep: ok thanks. as iekku noted, we'll look into it
15:45:49 <vmaatta> iekku: comment re: payment, it might be obvious but I hope the Qt Purchasing API is being taken into consideration and usable where possible
15:45:55 <SfietKontantinW> NSA-Rep: firefox's awesomebar is awesome
15:46:02 <lbt> damn - reminder was off by an hour :(
15:46:38 <vmaatta> lbt: welcome to DST :)
15:46:54 <thp> NSA-Rep, SfietKontantinW: i'll try to link this patch up internally to the right people and forward it. maybe it's done in a different way, but proof of concept code always helps.
15:46:59 <iekku> #info vmaatta hopes the Qt Purchasing API is being taken into consideration and usable where possible
15:47:04 <vmaatta> :)
15:47:07 <iekku> 1 minute left
15:47:16 <SfietKontantinW> thp: yep, you will need to ask design etc.
15:47:29 <cybette> for those in/near Florence: http://www.qtday.it/
15:47:39 <cybette> this fri/sat
15:47:52 <iekku> #info http://www.qtday.it/
15:47:58 <NSA-Rep> ETA on the translation tool?
15:48:22 <iekku> NSA-Rep, as soon as possible
15:48:36 <cybette> #info get 30% discount on qtday: https://ti.to/develer/qtday2015?discount_code=GNR30
15:48:50 <NSA-Rep> iekku: push them internally :P
15:49:04 <iekku> NSA-Rep, we are doing it already :)
15:49:29 <iekku> and time out for this topic
15:49:33 <iekku> #topic Wrap up and next meeting (5 min)
15:49:34 <NSA-Rep> use force if nessesary.
15:49:34 <cybette> NSA-Rep: constantly
15:49:52 <NSA-Rep> thats the way
15:50:10 * iekku proposes 2 weeks from now: March 24, same time
15:50:24 <cybette> I'll chair, it's my turn :)
15:50:32 <cybette> should have recovered from MWC by then
15:50:45 <iekku> :)
15:52:33 <cybette> i think the proposed time is ok
15:52:36 <iekku> no +1 ? no -1 ?
15:52:39 <cybette> +1
15:52:41 <iekku> :D
15:52:42 <vmaatta> +1
15:52:52 <lbt> +1
15:53:01 <cybette> lbt: do you need a separate alarm? :)
15:53:05 <lbt> yes please
15:53:09 * lbt runs
15:53:10 <cybette> :D
15:53:15 <iekku> #info next meeting 24-March 2015, 15:00 UTC
15:53:31 <iekku> thank you all and everyone
15:53:38 <cybette> thanks iekku
15:53:45 <iekku> #endmeeting