#mer-meeting: SailfishOS, open source, collaboration: 21-May @ 14:30 UTC

Meeting started by iekku at 14:30:52 UTC (full logs).

Meeting summary

    1. Welcome to another week of SailfishOS OSS and collaboration meeting (iekku, 14:31:05)
    2. Meeting info and agenda: https://lists.sailfishos.org/pipermail/devel/2015-May/006099.html (iekku, 14:31:07)

  1. Brief introductions (5 min), prefix your information with #info (iekku, 14:31:47)
    1. Kimmo Lindhol, tohs et al. Community. (kimmoli, 14:31:54)
    2. Carsten Munk, Chief Research Engineer @ Jolla (Stskeeps, 14:31:58)
    3. Iekku Pylkk�, Developer community sailor @ Jolla (iekku, 14:32:17)
    4. Andrey Kozhevnikov, indie opensource developer (coderus, 14:32:40)
    5. Simonas Leleiva, sailor porter and pootler @ Jolla (sledges, 14:32:53)
    6. Pami Ketolainen, developer @ Jolla (pketolai, 14:33:00)
    7. François Kubler, community (daitheflu, 14:33:22)
    8. Christophe Chapuis, community (Tofe, 14:33:26)
    9. Jussi Pakkanen, SDK lead developer @ Jolla (jpakkane, 14:33:27)
    10. Steph Gosling, community (stephg, 14:33:31)

  2. Opensourcing and allowing to use jolla qml components - coderus (15 min) (iekku, 14:36:15)
    1. some details about the topic: there are many cool proprietary qml components made by jolla: CameraExtensions, TextLinking, Email ComposerPage, Gallery ThumbnailImage/Video, Sailfish.Pickers (including allowing to use QtDocGallery), TransferEngine. It's always pain to develop applications using camera/email/gallery(filesystem)/thumbnailing, because every developer should implement own hacks for application and can't use native components. If i (iekku, 14:36:32)
    2. details continue: If it's not possible (please tell us why) then it will be great to have these components opensources so developer can compile and bundle it to application. (iekku, 14:38:57)
    3. there's two sides of this, one is that they're currently closed source, and second, that they're not considered API stable and possibly uses unstable APIs underneath (iekku, 14:40:02)
    4. there's a few of those i'd say makes sense to take a deeper look at, but i don't carry any news about open source today (Stskeeps) (iekku, 14:40:34)
    5. we're currrently doing quite a lot of work on sailfish 2.0 ui which has deep impact on many of the shared components as well (iekku, 14:40:54)
    6. 1) stskeeps: i don't have any details on open sourcing these components currently 2) to be supported in harbour they need to be reasonably api stable (iekku, 14:44:42)
    7. 1) stskeeps: 3) quite a lot of work going on that impacts every UI-level component, due to sailfishos 2.0 ui, so api stability is first expected after that and 4) we have a new SDK lead, jpakkane, who will be a great entry point for topics like this in the future :) (iekku, 14:44:58)
    8. ACTION: iekku to get jpakkane to next collaboration meeting (iekku, 14:45:13)
    9. ACTION: evaluate how jolla could open TransferEngine, EmailComposer, SailfishPickers (including allowing to use QtDocGallery), GalleryThumbnails and other components (iekku, 14:52:59)
    10. ACTION: evaluate also Sailfish.Media and account (iekku, 14:54:03)
    11. ACTION: evaluate how nemomobile components could be allowed to Harbour (iekku, 14:55:48)

  3. General discussions - everyone (10 min) (iekku, 14:56:45)
    1. Harbour QA team asks to wait until official SDK release note has been sent with new accepted APIs before submitting app to Harbour. If app is submitted too early it will be rejected because of not allowed API. (iekku, 14:57:31)

  4. Wrap up and next meeting (10 min) (iekku, 15:06:29)
    1. next meeting 11th of June, 14:30 UTC, chair: cybette? (iekku, 15:12:34)


Meeting ended at 15:13:33 UTC (full logs).

Action items

  1. iekku to get jpakkane to next collaboration meeting
  2. evaluate how jolla could open TransferEngine, EmailComposer, SailfishPickers (including allowing to use QtDocGallery), GalleryThumbnails and other components
  3. evaluate also Sailfish.Media and account
  4. evaluate how nemomobile components could be allowed to Harbour


Action items, by person

  1. iekku
    1. iekku to get jpakkane to next collaboration meeting
  2. jpakkane
    1. iekku to get jpakkane to next collaboration meeting
  3. UNASSIGNED
    1. evaluate how jolla could open TransferEngine, EmailComposer, SailfishPickers (including allowing to use QtDocGallery), GalleryThumbnails and other components
    2. evaluate also Sailfish.Media and account
    3. evaluate how nemomobile components could be allowed to Harbour


People present (lines said)

  1. iekku (48)
  2. coderus (32)
  3. Stskeeps (29)
  4. jpakkane (7)
  5. Yaniel (4)
  6. daitheflu (3)
  7. locusf (3)
  8. Tofe (3)
  9. merbot (2)
  10. kimmoli (2)
  11. sledges (2)
  12. KeeperoftheKeys (1)
  13. pketolai (1)
  14. stephg (1)


Generated by MeetBot 0.1.4.