#mer-meeting: SailfishOS, open source, collaboration: 6-Oct @ 14:30 UTC

Meeting started by cybette at 14:31:45 UTC (full logs).

Meeting summary

    1. Welcome to a new season of SailfishOS OSS and collaboration meetings! (cybette, 14:32:44)
    2. Meeting info and agenda: http://lists.sailfishos.org/pipermail/devel/2015-October/006578.html (cybette, 14:33:08)
    3. Simonas Leleiva, sailor, porters and pootles (sledges, 14:33:09)

  1. Brief introductions (10 min), prefix your information with #info (cybette, 14:33:31)
    1. Jonathan Frederickson, community member (jfred, 14:33:40)
    2. Kimmo Lindholm, TOHs et.al. , community (kimmoli, 14:33:43)
    3. Christophe Chapuis, community member (Tofe, 14:33:46)
    4. David Greaves: sailor and Mer guy (lbt, 14:33:49)
    5. Richard Rondu, community member & app developer (lainwir3d, 14:34:04)
    6. Steph Gosling, community (stephg, 14:34:05)
    7. Simonas Leleiva, sailor, porters and pootles, limited presence today due to vkb and afk (sledges, 14:34:07)
    8. Carol Chen, Community chief at Jolla, hatless meeting chair today (cybette, 14:34:10)
    9. Urja Rannikko, sometimes helps out with TOHKBD (urjaman, 14:34:12)
    10. iekku Pylkk�, developer-community sailor at Jolla (iekku, 14:34:23)
    11. Eugenio Paolantonio, community member, patch developer, professional lurker (eugenio, 14:34:25)
    12. Martin Kolman, community member, modRana developer (M4rtinK, 14:34:26)
    13. Bob Summerwill, community member, CEO http://doublethink.co (bobsummerwill_, 14:34:59)
    14. Andrew Penkrat, community member and app developer (Aldrog, 14:35:06)
    15. Lukas Vogel, community member, app dev (lukedirwalker, 14:35:11)
    16. Pami Ketolainen, backend developer @ Jolla (pketolai, 14:35:19)
    17. François, community member, app dev (daitheflu, 14:35:22)
    18. Julius-Paul Jann, community member (Nokius_work, 14:35:22)
    19. Lucien Xu, community member and dev (SfietKonstantinW, 14:36:29)
    20. Aleksi Suomalainen, community member (locusf, 14:37:18)
    21. Olavi Haapala, community member and dev (olpe, 14:38:31)
    22. Martin Brook, community porter (vgrade_w, 14:39:44)
    23. Igor Korolyuk, community member (IgorSK, 14:40:48)
    24. Moritz Thiele, community member, tester of all openrepos (MoritzJT, 14:41:26)

  2. How to ease 3rd party contribution to SailfishOS/Mer Middleware OSS components - locusf (30 min) (cybette, 14:43:26)
    1. Fabio Isgrò , community member, StuntMan (dr_gogeta86, 14:43:31)
    2. It is apparently not very well known how to contribute to the components in the topic. See for example: https://github.com/sailfishos/sailfish-utilities/pull/33 (cybette, 14:43:34)
    3. Namely the commit message must conform to a specific form only. This is not well known information to other contributors who might have changes to the OSS components, wether Mer Middleware or SailfishOS. (cybette, 14:43:40)
    4. would be good to have contribution guidelines written up and put in the open. question: where? mer wiki, TJC, sailfishos.org? (cybette, 14:53:37)
    5. ACTION: iekku and lbt to organize the required info and find best location for it (cybette, 14:54:45)
    6. also need more detailed info on packaging process in addition to guidelines (cybette, 14:59:22)

  3. Situation update about the Mer Middleware merger from Nemo Middleware - locusf (20 min) (cybette, 15:02:32)
    1. http://www.mail-archive.com/mer-general@lists.merproject.org/msg01557.html (cybette, 15:02:41)
    2. Message to Mer mailing list suggested that this is started but ongoing. A small status update would help Nemo community decide on its roadmap. (cybette, 15:02:47)
    3. http://www.merproject.org/dash2/ (cybette, 15:04:05)
    4. main issue is being in mid-migration, maintainers have been asked to move stuff but it's not happening (cybette, 15:07:13)
    5. lbt is in the process of updating Maintainer file and will probably take over maintainer role for neglected projects (cybette, 15:10:23)
    6. volunteer to be a maintainer - which basically means submit patches, get stuff working, show you're responsible and eventually get told it's yours. simply say "I'd like to maintain <blah>" (cybette, 15:16:08)
    7. ACTION: lbt and iekku to add the above to guidelines (cybette, 15:16:50)
    8. moving mer-core git packages from 'dumb' to tar_git is a chore. Help would be appreciated here. Talk to lbt in #mer about it. First step is actually help writing the HOWTO (lbt, 15:21:46)

  4. Request more information on Roadmap for open-sourcing more of Sailfish - bobsummerwill (20 min) (cybette, 15:23:08)
    1. It has been mentioned on several occasions that there is a plan with regard to further open-sourcing of components within Sailfish. It would be great to have some more public information on that. (cybette, 15:23:19)
    2. In particular, the status of Silica is a constant 'sore point'. With the company split and the move towards licensing of Sailfish 2.0, perhaps there is an opportunity to restore some lost faith in Jolla with regard to licensing. (cybette, 15:23:25)
    3. we will revisit this topic in next meeting, and get answers to questions brought up here (cybette, 15:30:34)

  5. Update on localization status (keyboards and translation tool) - ApBBB (5 min) (cybette, 15:32:43)
    1. For translation tool, work is progressing nicely and we are already testing it in-house. We will be able to deploy it in the open once any remaining rough edges have been polished and all infra is in place (cybette, 15:35:12)
    2. Jolla is working on a community translation tool (based on Pootle localization server) to enable community to contribute to Sailfish OS translations (cybette, 15:38:40)

  6. General discussions - everyone (15 min) (cybette, 15:41:03)
    1. Check #sailfishos-porters if you're interested in finding the progress of SFOS ports to Nexus and other devices (cybette, 15:45:08)

  7. Wrap up and next meeting (10 min) (cybette, 15:56:11)
    1. Next meeting Thurs Oct-22 @ 14:30 UTC, Chairperson iekku (cybette, 16:04:21)


Meeting ended at 16:06:11 UTC (full logs).

Action items

  1. iekku and lbt to organize the required info and find best location for it
  2. lbt and iekku to add the above to guidelines


Action items, by person

  1. iekku
    1. iekku and lbt to organize the required info and find best location for it
    2. lbt and iekku to add the above to guidelines
  2. lbt
    1. iekku and lbt to organize the required info and find best location for it
    2. lbt and iekku to add the above to guidelines


People present (lines said)

  1. cybette (82)
  2. lbt (61)
  3. locusf (34)
  4. stephg (31)
  5. bobsummerwill_ (28)
  6. iekku (27)
  7. urjaman (14)
  8. sledges (13)
  9. M4rtinK (12)
  10. nh1402 (11)
  11. kimmoli (10)
  12. dr_gogeta86 (9)
  13. SfietKonstantinW (7)
  14. jfred (5)
  15. Mikaela (4)
  16. MoritzJT (3)
  17. ericcc (3)
  18. pvuorela (3)
  19. Aard (2)
  20. merbot (2)
  21. pketolai (2)
  22. daitheflu (2)
  23. vgrade_w (2)
  24. Aldrog (2)
  25. lukedirwalker (1)
  26. olpe (1)
  27. Nokius_work (1)
  28. eugenio (1)
  29. lainwir3d (1)
  30. IgorSK (1)
  31. Tofe (1)


Generated by MeetBot 0.1.4.