14:30:24 <stephg> #startmeeting SailfishOS, open source, collaboration 31st of March 2016
14:30:24 <merbot> Meeting started Thu Mar 31 14:30:24 2016 UTC.  The chair is stephg. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
14:30:24 <merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:25 <Aliasbody> Ready
14:30:35 <stephg> #info Happy World Backup Day and welcome to another SailfishOS OSS and collaboration meeting
14:30:41 <stephg> ^^ tru dat
14:30:47 <stephg> #info Meeting information and agenda can be found here: http://lists.sailfishos.org/pipermail/devel/2016-March/007022.html
14:30:55 <stephg> I'm the meeting chair today and will be doing my best to keep time and order. Please behave, be gentle and show due respect.
14:31:01 <stephg> We have a few things to get through today so please lets not stray from the topics too much.
14:31:08 <stephg> #topic Brief introduction (5 minutes), please prefix your name/handle with #info
14:31:13 <stephg> off we go!
14:31:45 <eugenio> #info Eugenio Paolantonio, community, professional lurker
14:31:47 <r0kk3rz> #info Lewis Rockliffe, community
14:31:50 <stephg> #info Steph Gosling community, porter
14:31:54 <ljo_> #info Leif-Jöran Olsson, community
14:32:02 <M-jon> #info Jonathan Frederickson, community
14:32:10 <kimmoli> #info kimmo lindholm. adhoc.
14:32:15 <veskuh> #info Vesa-Matti Hartikainen, Program Manager, Jolla
14:32:46 <piggz> #info Adam Pigg, community
14:32:51 <M4rtinK> #info Martin Kolman, community member & modRana developer
14:32:57 <sledges> #info Simonas Leleiva, pootle and portle, Jolla
14:32:57 <cybette> #info Carol Chen, community, in between meetings so might drop off anytime
14:33:15 <Aliasbody> #info Luis Da Costa, community and LibreTrend CEO
14:33:37 <dcaliste> #info Damien Caliste, community, contributor when possible
14:33:40 <ballock> #info Bolesław Tokarski, community
14:34:05 <tadzik> #info Tadeusz Sośnierz, community, developer
14:34:19 <pketo> #info Pami Ketolainen, backend developer @ Jolla
14:34:31 <linphilrie> #info Philip Ries, community
14:34:39 <stephg> another minute or so folks
14:34:40 <Smar> #info Samu Voutilainen, lurker
14:34:53 <PhixGre_> #info Philippe Bollard, community member, software engineer and ex-entrepreneur
14:35:05 <the_mgt> #info Stefan, user and lurker
14:35:38 <andybranson> #info Andrew Branson, community and occasional developer
14:36:11 <stephg> okiedoke
14:36:12 <NeKit> #info Nikita, community
14:36:21 <stephg> #topic Paid app situation (ApB, 5 minutes)
14:36:29 <stephg> ApBBB I suppose, the floor is all yours
14:37:07 <ApBBB> OK. As the topic suggested. What keeps them back and if there is an ETA.
14:37:25 <stephg> #info (from tjc: some details about the topic: Someone to answer: 1) what holds them back 2) is there a ETA on when they will be allowed)
14:38:36 <veskuh> #info There is no ETA at the moment.
14:38:48 <Jaymzz_> #info James, Community Manager
14:39:18 <veskuh> #info Unfortunatly, we lost many people involved in this activity
14:39:37 <cybette> Jaymzz_: welcome :)
14:39:38 <r0kk3rz> veskuh: so this is (was) still progressing internally?
14:39:43 <M4rtinK> what about better Flatter integration ?
14:40:08 <Jaymzz_> Thanks cybette !
14:40:09 <sledges> I was to ask community: what's wrong with Flattr, and would actual paid apps bring you the revenue you're anticipating?
14:40:10 <M4rtinK> at the moment it just opens a web browser once you click on the flatter button in store
14:40:12 <veskuh> r0kk3rz: At the moment its not being worked on, so no ETA, and I’m not sure what are the biggest issues
14:40:12 <ApBBB> veskuh: apart from manpower is there something particular that holds them back? We need people developing apps and there is only so much that can be done with open and people who cant make money out of it.
14:40:27 <daitheflu> what about subcontracting it ?
14:40:34 <M4rtinK> I'm sure more people will use it if it was integrated with the account framework
14:40:40 <sledges> also (I'm not aware), but Finland laws of receiving money also cross the path
14:40:47 <M4rtinK> most probably don't bother with the current state
14:41:14 <r0kk3rz> sledges: agreed, I dont think anyone is getting rich of paid sailfish apps
14:41:15 <veskuh> I think the business side of the thing is most unclear. Taxes, returns, payment methods, etc.
14:41:29 <M4rtinK> also re:paid apps -> anything community can help with ?
14:41:42 <stephg> cryptocurrencies :D
14:41:42 <veskuh> And then the implementation side is just having enough bandwidth from backend team
14:41:47 <M4rtinK> (not likely but still asking ...)
14:42:01 <r0kk3rz> M4rtinK: Nemomobile payments library?
14:42:06 <stephg> another couple of minutes folks...
14:42:12 <Aliasbody> M4rtink: The problem is that the value is based on the monthly value, so in a month 1 Flattr can make you win 1$ and the other month 10 Flattr can make you win 0.50$ (and this not forgetting that a lot of people just don't want to create an account just to donate)
14:42:36 <M4rtinK> I don't want to be rough but I kinda feel the backend team bandwidth has been always limited to 56k...
14:42:42 <ApBBB> i am covered since there isn't much to talk about.
14:42:49 <schmittlauch> #info schmittlauch, community member, currently on a train with bad internet connection
14:42:50 <M4rtinK> r0kk3rz: nice idea!
14:42:59 <Smar> also donations are poor way to sell anything
14:43:01 <sledges> M4rtinK: see your open job positions ;)
14:43:06 <veskuh> r0kk3rz: yeah, something like that
14:43:07 <stephg> welcome schmittlauch hope your connectivity survives
14:43:22 <stephg> ok 1 more minute and we're moving on
14:43:38 <M4rtinK> Aliasbody: sure, it is not perfect - but with the current implementation no one will probably bother either way
14:43:46 <Aliasbody> Qt has already the Purchasing (for the inapp purchases on Android and iOS) and some other things that should be implemented in order to monetize Apps, but nowadays we have nothing, we don't even have a good Qt Ads library compactible with SailfishOS (this is why paid apps was and still is the best solution so far)
14:44:17 <Aliasbody> M4rtink: You are absolutely right
14:44:22 <M4rtinK> Aliasbody: that's actually a really nice idea - maybe the Qt purchasing API could be re/used ?
14:44:40 <r0kk3rz> Aliasbody: there is no problem with rolling your own, i think QuasarMX does this themselves
14:44:41 <M4rtinK> might need to be backported, but still...
14:44:48 <stephg> ok 1 more minute and we're moving onshould be implemented in order to monetize Apps, but nowadays we have nothing, we don't even have a good  Qt Ads library compactible with SailfishOS (this is why paid apps was and still is the best solution so far)
14:44:57 <stephg> damnit
14:45:25 <stephg> #info Qt has already the Purchasing (for the inapp purchases on Android and iOS) and some other things that should be implemented in order to monetize Apps, but nowadays we have nothing, we don't even have a good Qt Ads library compactible with SailfishOS (this is why paid apps was and still is the best solution so far)
14:45:25 <Aliasbody> r0kk3rz: We are actually working to create two libraries, one for Chromecast support and one for Mobfox support (but that doesn't solve the paid apps problem)
14:45:36 <stephg> ok, moving on
14:45:44 <stephg> #topic Platform Development documentation (ArmsOfSorrow, 5 minutes)
14:45:47 * M4rtinK doesn't really miss "a good adds library" :)
14:46:06 <r0kk3rz> M4rtinK: the best ads library is no ads library
14:46:18 <M4rtinK> r0kk3rz: absolutely! :)
14:46:26 <stephg> ... ArmsOfSorrow is apparently not here
14:46:41 <stephg> #info (from tjc): some details about the topic: this https://sailfishos.org/wiki/Platform_Development and various other sites about platform development are still just placeholders. I'd really like to help advance the platform (e.g. update some old packages), but the documentation on the whole process is scattered around various sites. When is it going to be (more) complete?
14:47:01 <Aliasbody> stephg: What do we do in those cases? Do we talk anyway about the subject or do we simply continue?
14:47:10 <r0kk3rz> is lbt around? perhaps he (or someone) could give an update on the documentation project
14:47:15 <M4rtinK> I think lbt has been leading a documentation refresh effort ?
14:47:28 <stephg> Aliasbody in this case as there have been a load of changes to the wiki in last month I think there is stuff to talk about
14:47:31 <lbt> oops, forgot about this
14:47:32 <stephg> if only points
14:48:04 <M4rtinK> Aliasbody: I think it kinda depends on the topic - sometimes it is IMHO quite self-explanatory
14:48:36 <Aliasbody> M4rtink: Sorry, this is my first meeting so I'm still trying to understand how it works :)
14:48:38 <cybette> it'll be good if he appointed (and informed) a substitute, but in this case he wrote "if I'm not available just answer the question"
14:48:59 <veskuh> yeah, lbt knows that side best, but in general we do now work more on docs, and have tried to improve the structure and appearance of wiki too
14:49:25 <lbt> At the moment I'm looking at automatically generated documentation
14:49:25 <M4rtinK> any approximate ETA when community members can start helping ?
14:49:42 <Aliasbody> lbt: Like javadoc?
14:49:44 <lbt> eg we have Qt 5.2 and need to include a sane copy of those docs
14:49:48 <lbt> Aliasbody: haha
14:49:53 <stephg> heh
14:49:55 * sledges just got a flashback of http://autodoc.merproject.org/
14:50:01 <M4rtinK> there is a fair share of errors and omissions in the current docs, many reported long ago
14:50:06 <lbt> sledges: it's essentially using that approach
14:50:26 <lbt> M4rtinK: indeed
14:50:50 <lbt> there will be 2 kinds of doc
14:50:51 <lbt> s
14:50:52 <sledges> a flashback from Thu May 29 2014 :))
14:50:53 <M4rtinK> so being able to send "pull request" with a fix would be handy
14:51:16 <lbt> blurb is going to go in the wiki - things like howtos and guides and overviews
14:51:30 <lbt> API docs are usually tied to code comments
14:51:56 <stephg> a couple more minutes
14:52:49 <lbt> so M4rtinK API docs will be ammended by pull requests
14:52:49 <M4rtinK> lbt: that can be an issue
14:52:51 <schmittlauch> I hope it's not too offtopic: Some developers have complained that there's no documentaion about basic building blocks e.g. filepicker which are there at other plattforms
14:53:06 <M4rtinK> lbt: for the proprietary parts
14:53:13 <lbt> oops - phone call, sorry
14:53:17 <schmittlauch> I think community has created some solutions for this but these aren't documented at a central place
14:53:41 <Aliasbody> (If those proprietary parts weren't proprietary as they were promised a long ago not to be, then we wouldn't have that problem)
14:53:47 <sledges> schmittlauch: i'll pass your remark to our UI team
14:53:50 <M4rtinK> Aliasbody: +1
14:54:09 <sledges> #action inquire UI team about docs to components like filepicker etc
14:54:21 <stephg> one more minute
14:54:22 <M4rtinK> sledges: I think there is some very basic file picker, but it is not documented & not allowed for Harbour apps
14:54:49 <M4rtinK> sledges: and I remember acquiring about it on a community meeting being allowed - about a year ago IIRC...
14:54:57 <M4rtinK> just for context
14:54:57 <sledges> spoiler alert: there are improvement in file manager component in 2.0.2
14:55:15 <M4rtinK> sledges: finally!
14:55:16 <r0kk3rz> sledges: :o
14:55:51 <sledges> now i hope it won't get reverted, or the joke is on me :D
14:55:59 <stephg> ok seems to me that this one can run and there are subsequent unanswered questions, however the OP isn't here so I'm going to move on if that's ok with every one
14:56:02 <r0kk3rz> sledges: you've jinxed it now....
14:56:06 <cybette> sledges: :D
14:56:10 <sledges> :)))
14:56:10 <cybette> stephg: +1
14:56:13 <stephg> answers on a postcard for the next meeting please :)
14:56:19 <stephg> ok moving on
14:56:27 <stephg> #topic Future of Jolla in the professional environment (Aliasbody, 30 minutes)
14:56:37 <stephg> Aliasbody you're here, the floor is all yours!
14:56:47 <Aliasbody> Hello once again everyone, I'll try to be as quick as possible
14:56:51 <Aliasbody> thanks stephg
14:56:57 <stephg> #info (from tjc): I've been promoting Jolla as a platform for my clients and their feedback might be good to be heard. More in details, every time we gain a client/project for a mobile app (mostly Android and iOS) we always propose a version for Jolla or Ubuntu Touch for free (in order to promote those platforms and to help them understand the benefits of a convergent code), but usually everyone chooses Ubuntu.
14:57:09 <stephg> #info (from tjc): At start I thought that it was because they knew the name (so there were more attracted to it) but after long discussions with our clients we found out that this wasn't the case. If you allow me I would be interested in explaining what are their concerns (and why, if this doesn't change, we might at libretrend change also everything to Ubuntu Touch).
14:57:13 <Aliasbody> So quick introduction, my name is Luis Da Costa and I'm the CEO of a Free Software company called LibreTrend located in portugal.
14:57:34 <Aliasbody> We started developing mobile apps for our clients a few months ago, and we started proposing something we called "Open-Offer"
14:58:11 <Aliasbody> this "Open-Offer" literally says that for each iOS/Android or Windows Phone version of an app we offer a version for an OpenSource OS (like SailfishOS, Ubuntu Touch or FirefoxOS)
14:58:18 <Aliasbody> and today I'm here to talk about the feedback
14:58:38 <schmittlauch> what I was suggesting: If there are common components missing that community has created replacements/solutions for, those should be socumented in the wiki
14:58:55 <schmittlauch> but I'm (currently) not a sfos developer
14:59:10 <Aliasbody> What happens, is that everyone of our clients, some of them with their apps already on the respective Stores and others still in development, simply don't want to have their application on the Jolla Store, they prefer to have it on the Ubuntu Store
14:59:43 <PhixGre_> Aliasbody: why ?
14:59:52 <Aliasbody> the reason is clear, first there is no InApp Purchases (but that can always be solved via a lot of meetings and exchange of ideas), there is no Paid Apps
15:00:04 <Aliasbody> And the most important part... the store is full of Android Apps
15:00:32 <schmittlauch> Aliasbody: to be honest, calling SFOS an open source os is at least arguable :\ but good idea
15:00:46 <Smar> one solution would be to isolate the android apps to separate category, maybe? so native and android apps would have separate ”views” so they don’t smudge together
15:00:49 <Aliasbody> my clients always answer me, why would I ask you to take time (even if the SailfishOS version is Free if the client asked for an Android version because we always make our code in Qt), if you (LibreTrend) can simply upload the Apk?
15:01:18 <Aliasbody> So everyone of my clients always concentrate on Ubuntu Touch. And I see this as a real problem.
15:01:42 <PhixGre_> Isn't related to popularity of Ubuntu?
15:02:01 <schmittlauch> Personally I can say that I just ignore the android apps in Jolla store and I guess many people do so. But this isn't obvious to other companies
15:02:02 <ApBBB> its a known name it "sells" more
15:02:35 <Aliasbody> A few months ago I wrote somewhere on the together.jolla.com site that we were in the making to port at least 2 apps (one for Finance and one Social Network) to Jolla. Since they are new apps and this Social Network is also new, it would be great for the SailfishOS ecosystem, but they've changed their idea
15:02:35 <PhixGre_> schmittlauch: +1
15:02:42 <Smar> I can see that from company’s perspective it’s wasted time to do something for SF if the android application would work perfectly well
15:02:51 <M4rtinK> what about dependencies on the Ubuntu Store ? do they allow more libraries or perhaps make bundling easier ?
15:03:01 <r0kk3rz> Aliasbody: to be honest, your customers are right. You (as a developer) have a lot more freedom with what you can do in an android Qt app than a native sailfish Qt app
15:03:05 <ballock> The android apps are not available on ported devices - no alien dalvik there. Perhaps that's a good reason to have an app as native?
15:03:21 <Aliasbody> At start yes I asked if it was because they knew the Ubuntu name, but the answer were already the same : "If it was by the name, we would choose FirefoxOS and this even knowning we never tested none of the 3"
15:03:26 <stephg> remember there are an icreasing number of people who have SFOS but don't have an android runtime (yet)
15:03:33 <M4rtinK> r0kk3rz: yeah - you can use up-to-date Qt for once...
15:03:42 <schmittlauch> Smar: So it's an advantage of Ubuntu that it doesn't support Android apps? Quite strange
15:03:45 <Wnt> ballock: +1
15:04:18 <Aliasbody> So yes, they love the SailfishOS experience (since it's my main phone I always love to show them what others can do), but when we talk about numbers, about API's, about possibilities... they all say no to SFOS and yes to Ubuntu.
15:04:21 <Smar> schmittlauch: depends, if you count android application as ”new SF application”, then I don’t see why the company wouldn’t just provide it to SF too
15:04:43 <Smar> talking about purely native apps, it sounds like that to me
15:05:05 <r0kk3rz> Aliasbody: have you attempted a cross platform ubuntu touch / sailfishos Qt app?
15:05:11 <Aliasbody> So what's happening? Ubuntu Touch is simply gaining more power, for no real reason
15:05:28 <schmittlauch> Which Qt version does Ubuntu touch use?
15:05:31 <Aliasbody> r0kk3rz: We develop all our apps, if our client doesn't ask us otherwise, with Qt technologies
15:05:38 <Aliasbody> schmittlauch: Qt 5.5
15:05:53 <sledges> one way of looking at it is healthy competition, pulling each other up when times get rough:)
15:06:03 <schmittlauch> Aliasbody: Ok, that's clearly an advantage
15:06:10 <sledges> kde and gnome all over again?:))
15:06:41 <Aliasbody> So to summarize (sorry for my bad english, is not my native language)
15:06:42 <sledges> r0kk3rz: Aliasbody: yes, something like phonegap for sfos+ut
15:07:03 <r0kk3rz> sledges: well, universal components anyway
15:07:10 <schmittlauch> The new KDE Kirigami (or so) UI components which are going to be released next month may be interesting for cross plattform development. And from what I've seen they implement some ideas from Silica
15:07:39 <schmittlauch> nevetheless, cross plat apps never feel really native
15:07:46 <M-jon> Hmm, Kirigami huh?
15:08:37 <schmittlauch> yes, KDE kirigami components https://dot.kde.org/2016/03/30/kde-proudly-presents-kirigami-ui
15:08:49 <M-jon> That does look pretty nice actually
15:08:54 <Aliasbody> I think that a lot of things should be treated first. I mean, I don't work at Jolla and I don't want to tell the Jolla team what they have to do, they achieved a business where place where a lot of entrepreneurs (me included) want to be, but I think that in order to make SFOS attractive as it was when it was launched, a lot of things must change, and by this I'm talking on: Paid apps problem, Android apps with more rights than the
15:08:54 <Aliasbody> SFOS apps, lack of support for native components and mostly lack of support for developers in Harbour.
15:09:20 <schmittlauch> yeah, but not native at SFOS and doesn't work with Qt 5.2 (at least I assume)
15:09:25 <r0kk3rz> Aliasbody: One of your points was about paid apps, is that really a big deal? do your customers expect significant revenues from SFOS or Ubuntu? or is it a culture thing where they dont want to give anything away for free
15:09:31 <r0kk3rz> even if nobody pays
15:10:00 <Smar> r0kk3rz: and without no-one releasing any good (paid) apps, no new good paid apps will be getting in... :P
15:10:28 <M4rtinK> I'll just note I'll have a Ubuntu Touch device soon
15:10:33 <Smar> I mean, releasing something that costs 10 € elsewhere free for SF makes little sense from pov of a company
15:10:40 <Aliasbody> (About harbour) the Ubuntu Store model is not perfect, I mean you upload an app and in less than a second after that the app in the store (perfect for  malwares and others), but as an example, we are creating a library to support Chromecast and we are having problem because some of the Components we need aren't supported by the Harbour team to be included in the store, so at this point we could already have an app launched but we
15:10:40 <Aliasbody> don't have for those reasons
15:10:43 <M4rtinK> so I'll be able to actually test the Universal Components backend
15:10:45 <r0kk3rz> Smar: i expect very few people would actually buy any sfos paid app
15:10:58 <schmittlauch> Aliasbody: What do you think of improving interoperability between SFOS, Ubuntu and other Qt platforms like BB10 and Plasma Mobile?
15:10:58 <M4rtinK> for UT
15:11:00 <Smar> r0kk3rz: then SF is dead :P
15:11:09 <Aliasbody> As I've said before, the paid apps is the less important thing in my list of "ongoing problems" that my clients talk to me when proposing SFOS, but it is still one
15:11:29 <r0kk3rz> Smar: 'growing' not dead
15:11:40 <Smar> r0kk3rz: it won’t grow if no-one will buy any apps
15:11:45 <stephg> #info (About harbour) as an example, we are creating a library to support Chromecast and we are having problem because some of the Components we need aren't supported by the Harbour team to be included in the store, so at this point we could already have an app launched but we don't have for those reasons
15:12:13 <r0kk3rz> Smar: there is nobody to buy apps, not compared to any other platform
15:12:27 <Aliasbody> schmittlauch: Well of course if someone could make 1 code in Qt and it worked everywhere without changing nothing it would be perfect, that without those SFOS components, UT components and so on, the platform wouldn't be the plaform it is right now. So yes for interoperability but not in any way.
15:12:36 <Smar> r0kk3rz: I think Aliasbody just came here to tell some points what could change it...
15:12:40 <M4rtinK> it's chicken and egg problem I think
15:12:49 <stephg> 5 more minutes folks
15:12:51 <M4rtinK> IIRC there have been some developers stating
15:13:17 <M4rtinK> they have apps (mostly ports from the N9) but are waiting for paid apps support
15:13:30 <M4rtinK> as their apps have been commercial on the N9 via the Ovi store
15:13:43 <schmittlauch> So an important point would be updating Qt to a recent level and providing a broad but stable API of what's allowed in store?
15:13:55 <Aliasbody> Again, we can solve this issue without Paid Apps, but Flattr isn't the perfect way to do it either (even if it helped)
15:14:04 <veskuh> Aliasbody: thanks for covering these topics. Good to hear from real profressional development viewpoint the issues we are having.
15:14:22 <Aliasbody> schmittlaunch: That would be a good start yes
15:14:23 <PhixGre_> Aliasbody: so, what is the first problem on your list of "ongoing problems"?
15:14:32 <Aliasbody> veskuh: thanks
15:14:50 <schmittlauch> I'd love to pay for open source apps (: But I'm quite sure there are many people who also pay for proprietary ones
15:14:53 <ApBBB> Aliasbody: maybe it is better to talk to someone more "official" at Jolla since this is a proffesional matter
15:15:26 <urjaman> ApBBB: and thats what makes jolla more closed rather than more open...
15:15:28 <sledges> Aliasbody: how critical is allowing "daemon" apps within Harbour?
15:15:29 <M4rtinK> but is there even someone like that ?
15:15:31 <sledges> from your PoV
15:15:33 <Aliasbody> PhixGre_: The first, and most commong problem I've heard from my clients, is the support that the Jolla Phone has for Android. The apps are mixed and they are better supported then the native ones.. so why bother?
15:15:34 <ApBBB> a guy on the bussiness side
15:16:02 <stephg> Aliasbody: well I'm not sure any android apps are actually 'supported' :P
15:16:20 <urjaman> what, your problem is that jolla has an awkward android support? ... -.-
15:16:22 <ApBBB> urjaman: business is business and benefits both the moneymaking people and the community IMO
15:16:24 <Aliasbody> I'll be honest with you all, when the Jolla phone started shipping I wanted one so bad but couldn't have one because I didn't had a work, here in Portugal the economy is not easy, and I was going to be a father.
15:16:27 <MSameer> getting android apps into harbour is easier than native apps IMHO
15:16:30 <stephg> but I can see that that perception may exist (thinking about apps that require Play Services for example)
15:16:42 <PhixGre_> In my point of view, mixing android and natives apps in the store is a big mistake
15:16:52 <urjaman> (i.e. it'd be better if it didnt have android support...)
15:17:08 <Aliasbody> Then my (back then girlfriend and now wife, sent a message to Jolla in order to ask for help, and they did, they send me a special card with a discount.
15:17:25 <stephg> couple more minutes
15:17:29 <Aliasbody> I got my Jolla (my first smartphone in years), and started doing everything in order to help them and the Free Software movement
15:17:44 <Aliasbody> and after a few months/years I created LibreTrend and now I'm here talking in this meeting
15:17:53 <Aliasbody> I'll do anything to help the SFOS and Jolla family
15:18:15 <Aliasbody> But they need to be receptive to those discussions, and right now it doesn't seem to be the case unfortunately
15:19:08 <stephg> ok going to move on
15:19:09 <M4rtinK> MSameer: indeed - it's more or less a big blob, even more than normal binary RPMs - QA can hardly check anything on that
15:19:14 <cybette> Aliasbody: good points and great to hear :)
15:19:23 <stephg> #topic Handling critical security fixes (schmittlauch, 10 minutes)
15:19:30 <Aliasbody> stephg: For my POV, it was a marketing thing, and Jolla lost a lot of money, to attract users, but that only did that nothing else.
15:19:34 <Aliasbody> cybette: thanks
15:19:39 <stephg> schmittlauch: hope you're still here
15:20:18 <stephg> #info (from tjc): As CVE-2015-7547 still isn't fixed we need to talk about how to handle security fixes. Jolla has already released very small hotfix updates for critical problems, so why don't they do it for this very critical issue? I understand that the testing effort for Q&A may be a reason to ship it as part of Taalojärvi, but as this hasn't been released for over a month now just releasing a patched glibc is quite necessary.
15:20:19 <schmittlauch> OK, I guess everyone of you heard of the critical glibc CVE
15:20:22 <schmittlauch> I hope, too
15:20:33 <stephg> #info (from tjc): What are the criteria for Jolla on releasing a hotfix? How to cope with similar issues in future?
15:21:00 <schmittlauch> This critical security issue is still unfixed for most people as Taalojärvi still isn't released (another interesting topic)
15:21:15 <Aliasbody> schmittlauch: indeed
15:21:18 <schmittlauch> So we need to talk about hotfixes
15:21:29 <linphilrie> one package updates
15:21:39 <linphilrie> in this case
15:22:42 <linphilrie> all other distros were able to do it...
15:22:59 <linphilrie> the patch is upstream in mer
15:23:12 <veskuh> #info So 2.0.1 releasing is pending on the incoming call silence issue.
15:23:14 <schmittlauch> So does Jolla have some guidelines on how to cope with critical security issues?
15:23:21 <schmittlauch> The glibc issue is already fixed in mer and SFOS has a great package manager, so it shouldn't be too much work, maybe some for Q&A
15:23:26 <schmittlauch> Jolla has already released hotfixes for I think 2 critical issues before, one of them a security one
15:24:23 <veskuh> #info the plan has been to release the hotfixes along with 2.0.1, but if that is still too far we should reconsider doing it as a separate hotfix as is now the proposal
15:24:27 <urjaman> yeah i was about to say that the commandline package manager parts could do it easily, but i guess its just an UI thing so the system could notify you of updates and update, without the whole new release everything changes and forced reboot ...
15:25:11 <urjaman> (obviously you can do it like that too, i just dont like it at all :P)
15:25:17 <linphilrie> i think we could live with a forced reboot
15:25:40 <Smar> glibc thing also kind of would benefit from reboot...
15:25:44 <veskuh> schmittlauch: Yes, we have branch for old releases and can do upgrades to it without disturbing 2.0.1 releasing or 2.0.2 development.
15:26:14 <veskuh> schmittlauch: The 2.0.1 releasing has just taken too much time
15:26:18 <M4rtinK> I'll reiterate - it was done before
15:26:19 <linphilrie> so why waiting?
15:26:57 <M4rtinK> veskuh: also - critical security updates should *never* be blocked by feature updates
15:27:05 <M4rtinK> seriously
15:27:10 <schmittlauch> veskuh: Call issues are bad and good luck on debugging them, but we can't whait for a major release to become ripe when there are critical vulnerabillities to fix
15:27:11 <schmittlauch> I've even read that SFOS can still be vulnerable to some type of the stagefright vuln
15:27:44 <linphilrie> yes, but you can close aliendalvik
15:27:58 <linphilrie> but not glibc
15:27:59 <schmittlauch> M4rtinK +1
15:28:14 <M4rtinK> regular (security) updates has been one of the main SFOS selling points, so it is sad seeing the current situation...
15:29:21 <r0kk3rz> M4rtinK: when your leg gets cut off its hard to keep the same lap times
15:29:24 <Aliasbody> Maybe a "every-x-months-update" could be a good solution
15:29:33 <schmittlauch> As all desktop linux distros have managed to release a patched version (not a new major version, just a patched version which needn't to be tested that hard) it shouldn't be too difficult
15:29:48 <veskuh> M4rtinK: I do agree with that and we are trying
15:30:03 <schmittlauch> veskuh: Does Jolla have internal guidelines on how to cope with critical sec issues?
15:30:33 <stephg> couple more minutes
15:30:42 <M4rtinK> veskuh: thanks! good to know :)
15:30:58 <veskuh> schmittlauch: We don’t have definition of what makes issue critical, but we do have process for hotfix releases
15:31:38 <stephg> #info Jolla don't have definition of what makes issue critical, but we do have process for hotfix  releases
15:31:55 <linphilrie> i think this process should be startet on glibc
15:32:10 <schmittlauch> veskuh: Maybe you could develop one? Because than it may be a clear decision on whether to fix immediately or whait till the next update
15:32:22 <M4rtinK> um, you don't have to decide if it is critical
15:32:42 <M4rtinK> IIRC the CVEs are usually have a severity level
15:33:03 <schmittlauch> maybe something like "shall be patched in x days" and when seeing that the release date for a mayor is too far away -> hotfix
15:33:17 <stephg> ok going to move on..
15:33:25 <stephg> #topic All other business  (everyone, 10 minutes)
15:33:43 <schmittlauch> M4rtinK: well, you have some space for decisions: Shellshock and Heartbleed where critical, but worse for servers than for clients
15:33:46 <r0kk3rz> schmittlauch: when you have an imminent release, i think their idea of rolling it into 2.0.1 is perfectly fine
15:33:48 <linphilrie> android driver updates for jolla1?
15:34:00 <ballock> M4rtinK: what's critical in a CVE from a server perspective may not be so for a mobile
15:34:03 <ApBBB> i'am going to be THAT guy. How close we are to the call bug?
15:34:13 <ApBBB> and to the release of 2.0.1
15:34:17 <stephg> ApBBB +1 :D
15:34:37 <M4rtinK> ballock, schmittlauch: sure, but I think its still a good guideline
15:34:54 <veskuh> ApBBB: We did two fix attempts neither were fully effective and now we evaluate if by changing design we could go around the issue
15:35:19 <sledges> r0kk3rz: and then you think a silenced calls blocker will be an easy fix, ok c'mon one more week :D
15:35:27 <sledges> (soz OT already)
15:35:33 <schmittlauch> M4rtinK: indeed. You should have a good excuse for not fixing a critical CVE
15:35:33 <veskuh> ApBBB: and as such I don’t think its next week and thus the security discussion we should have internally for the hotfix process
15:35:54 <stephg> #info (regarding release of 2.0.1) Jolla did two fix attempts neither were fully effective and now we evaluate if by changing design we could go around the issue
15:35:54 <r0kk3rz> sledges: yes that one seems to be taking a long time, im sure its a tricky one
15:36:13 <ApBBB> veskuh: thanks.
15:36:38 <stephg> sledges: how are things in porter-land?
15:36:54 <stephg> and pootle land
15:37:14 <schmittlauch> just found the security-hotfix you did https://together.jolla.com/question/57874/release-notes-security-hotfix-for-tahkalampi-10821/
15:37:30 <Raymaen> is there a plan to improve Jolla apps like the Calenadr or the Galery? those and other apps need some improvement...
15:37:57 <r0kk3rz> schmittlauch: it was clear at that time that uitukka was going to take a long time to release
15:38:01 <ApBBB> probably at this state the only way to improve an app is to write a new one
15:38:13 <cybette> sorry i'm jumping in and out but there was a question from andybranson about the plans to move to Qt 5.6? if someone can comment on that. he'll probably bring up the topic at a subsequent meeting as well
15:38:27 <stephg> Raymaen: have you raised suggestions/feature requests/etc. on TJC?
15:38:46 <sledges> stephg: ghosalmartin is at the edge from having aarch64 mer, kimmoli is polishing sfos on OnePlus X which looks like N9 reincarnation:) and supports mindblowing touchscreen gestures while suspended, piggz Moto G got camera and i think is complete port, fairphone got jolla store..
15:38:48 <Raymaen> there are a fev in tjc regarding the galry
15:39:02 <stephg> sledges: wow
15:39:07 <ApBBB> cybette: this was answered some time ago and with all the trouble they were not looking into it at the moment
15:39:17 <Raymaen> such as the picture locations and sorting bay date etc.
15:39:25 <linphilrie> what about >> upgrade Qualcomm android drivers to KitKat(4.4)-level << tjc
15:39:35 <schmittlauch> Is the process of open-sourcing still ongoing? To be honest, my next smartphone won't be one with SFOS if there won't be mayor improvements in terms of open sourcing
15:39:35 <cybette> ApBBB: ok thanks. i should read backlog at some point...
15:39:51 <PhixGre_> Raymaen: for the email cleint too! https://together.jolla.com/question/319/enhancements-of-the-email-client/?sort=latest
15:39:51 <stephg> #info ghosalmartin is at the edge from having aarch64 mer, kimmoli is polishing sfos on OnePlus X which looks like N9 reincarnation:) and supports mindblowing touchscreen gestures while suspended, piggz Moto G got camera and i think is complete port, fairphone got jolla store.
15:39:55 <r0kk3rz> cybette: it wasnt mentioned in this meeting
15:39:56 <M4rtinK> schmittlauch: +1
15:40:25 <cybette> r0kk3rz: ah :)
15:40:31 <sledges> stephg: negalaxy tab has porting activity for all those didn't receive jolla tablet:)
15:40:35 <M4rtinK> I actually wanted to add that as a topic originally for todays meeting, but enough others showed up in the end
15:40:45 <sledges> s/negalaxy/new sony xperia tablet and galaxy/
15:41:16 <M4rtinK> even a "we will never open source X" would be an improvement at this stage IMHO
15:41:23 <veskuh> schmittlauch: Yes, it is still in plans quite similarly as stskeeps presented in community meeting couple times ago
15:41:24 <sledges> Xiaomi Redmi 1S also shaping up
15:41:36 <M4rtinK> as you might know you should not bother waiting/should start on a full replacement
15:41:37 <stephg> #info new sony xperia tablet and galaxy have porting activity
15:41:54 <sledges> and raspberry pi3 work started by locusf (lots of re-used from rpi2)
15:42:08 <ApBBB> The least of the problems SFOS has at the moment is open sourcing
15:42:16 <sledges> stephg: community translations (pootle) have started among beta testers, because translation round came too quick :)
15:42:25 <stephg> #info QT 5.6 migration is still in plans quite similarly as stskeeps presented in community meeting couple times ago
15:42:26 <M4rtinK> sledges: what about the new Ubuntu Tablet ? :) the hardware looks decent & would be nice to have a real OS on it :)
15:42:29 <sledges> will be rolled out to everyone after that
15:42:44 <stephg> #info community translations (pootle) have started among beta testers, because translation round came too quick
15:42:49 <r0kk3rz> stephg: open sourcing, not qt5.6
15:43:01 <stephg> r0kk3rz oops
15:43:05 <stephg> thanks
15:43:05 <veskuh> stephg: My comment was about Open sourcing, but yes at some point we will need to update Qt too.
15:43:10 <sledges> stephg: you can #undo ;)
15:43:14 <schmittlauch> veskuh: Just "plans" lying around in some closet or is there ongoing activity? I know it's a tough situation right now, but IMHO the only way to regain community trust
15:43:35 <M4rtinK> schmittlauch: 100% agreed
15:43:41 <veskuh> schmittlauch: we did small changes, our CTO harri hakulinen is one preparing it for board now.
15:43:55 <dcaliste> ApBBB: not really, open sourcing is indeed part of the evolution. I'm thinking of the calculator bug that could be easily fixed if source code would be free.
15:43:57 <r0kk3rz> veskuh: is there any more idea than "some point" on qt upgrade? it seems with qt5.6 being an LTS release it is a good candidate
15:44:32 <stephg> #undo
15:44:32 <merbot> Removing item from minutes: <MeetBot.items.Info object at 0xa606f10>
15:44:34 <M4rtinK> dcaliste: or the missing character counter when tweeting an image from gallery...
15:44:39 <sledges> stephg: one more;)
15:44:40 <stephg> #undo
15:44:40 <merbot> Removing item from minutes: <MeetBot.items.Info object at 0xa606c90>
15:44:40 <sledges> M4rtinK: not enough adopters :D
15:44:50 <sledges> ok, now #info again:)
15:44:54 <stephg> #info community translations (pootle) have started among beta testers, because translation round came too quick
15:45:08 <schmittlauch> veskuh: Thanks for the update on that (:
15:45:15 <stephg> #info Open-sourcing is still in plans quite similarly as stskeeps presented in community meeting couple times ago
15:45:32 * sledges pats stephg
15:45:53 <r0kk3rz> stephg: \o/
15:45:55 <stephg> ok a couple more minutes
15:45:57 <ApBBB> dcaliste: as i said i don't expect much in terms of apps from jolla at this moment. the best way it the community to develop new ones
15:45:59 <veskuh> r0kk3rz: No timing yet, but there is definitely need to plan it well.
15:46:07 <otsaloma> Is there any reason not to allow QtLocation in the store, considering it's stable in 5.6 with no major API changes compared to the version in SFOS?
15:46:30 <r0kk3rz> veskuh: for sure, can the community help in this regard? getting Qt5.6 packaged into mer of any use?
15:46:37 <Raymaen> is there a roadmap for 2016? the one from 2015 was not completed...
15:46:53 <Wnt> otsaloma: even minor API changes might break apps when qt SFOS version is upgraded?
15:47:12 <urjaman> it'd need to be ABI compatible ...
15:47:20 <urjaman> (i dont know if it is)
15:47:21 <veskuh> otsaloma: Wnt Yep, that would need to be checked
15:48:03 <otsaloma> Wnt: A Qt bump will break apps anyway (did so the last time)
15:48:19 <stephg> one more minute
15:48:19 <sledges> M4rtinK: if you give me .ts or .po files in (a near-to) Pootle format, I can import czech/slovak translations into community translations instance:)
15:48:52 <sledges> (we can take this offline)
15:48:54 <ApBBB> sledges: could you make a call about it in TJC. have people sent you files
15:49:09 <veskuh> Raymaen: There is no public roadmap. Its a delicate subject now that we want to have customer projects and resourcing situation has been changing.
15:49:28 <Raymaen> oh ok...
15:49:37 <stephg> okies then
15:49:38 <r0kk3rz> sledges: i will have to write Australian translation for you too :)
15:49:41 <dcaliste> ApBBB: well existing apps are quite good IMHO, just would like to correct some annoying minor issues. I don't want to restart writing from scratch, it's a waste of time.
15:49:43 <sledges> ApBBB: cz/sk is a near-complete set, and M4rtinK asked on here many times. for others, it will be either manual work, or similar process of bulk import that we'll polish with M4rtinK first
15:49:49 <stephg> r0kk3rz: lol
15:50:06 <M4rtinK> sledges: cool! I know the maintainer of the Czech/Slovak translation project so I'll let him know :)
15:50:10 <sledges> r0kk3rz: no worries mi' :D
15:50:10 <stephg> #topic Wrap up, and next meeting (5 minutes)
15:50:32 <stephg> cybette: if you're still here and want still to chair do you want to move the day?
15:50:45 <stephg> how are people finding the timing at the moment
15:50:57 <sledges> got interest from other side of the world (.au) and we should start thinking of .in too :) to alternate timings
15:51:00 <r0kk3rz> stephg: cybette shouldnt we let our new community manager Jaymzz_ step up to the plate?
15:51:56 <r0kk3rz> as much as cybette always does a fantastic job
15:52:06 <stephg> Jaymzz_: welcome! are you interested in chairing (it'll involve a careful juggling of hats for you :P )
15:52:14 <cybette> stephg, r0kk3rz: I'll be happy to chair, unfortunately now I have a weekly meeting at this time :-/
15:52:20 <cybette> stephg: thanks for helping out!!
15:52:32 <cybette> r0kk3rz: thanks for the compliment :)
15:52:42 <Jaymzz_> I was watching the whole time and there is a LOT to learn for a newbie in IRC like me. I got the most of it, but still have a lot to learn in commands and so on!
15:52:50 <Jaymzz_> I could give it a try I guess! :)
15:53:04 <stephg> leaving the chair aside for the time being, what do people think about the time?
15:53:06 <Jaymzz_> stephg: Thanks!! :)
15:53:07 <stephg> and the day
15:53:14 <Raymaen> *thubs up*
15:53:39 <Aliasbody> Need to go. Nice meeting and a rest of a good day (or night depending on the place of the Globe you are) for you all.
15:53:41 <r0kk3rz> sledges: better to focus on .in rather than .au, the timezone is too hard
15:54:02 <cybette> wednesdays would work better for me, but it depends on what works for the majority
15:54:23 <Raymaen> thank you for a nice meeting, cu all!
15:54:25 <stephg> ok seeing as no opinions from anyone going to tentatively suggest Thursday April the 14th at the same time, 14:30 UTC
15:54:48 <r0kk3rz> welp, i'll be in .au at that time
15:54:51 <stephg> I can chair again (Jaymzz_ if you don't want to just yet)
15:55:07 <Jaymzz_> Wednesdays work for me too, as long as  the timing is an hour earlier.
15:55:26 <Jaymzz_> stephg: It'd be nice to watch one more time :)
15:55:47 <stephg> Jaymzz_: no problem
15:56:02 <sledges> ok, let's not jump too far, make it hour earlier, and see if .in can happily fit in:)
15:56:08 <schmittlauch> taking .in into consideration is a good idea, at least after the AquaFish has been released
15:56:23 <Jaymzz_> Yeah I agree :)
15:56:30 <stephg> ... and day?
15:56:33 <sledges> if you know friends in india, don't forget to appoint them to our community channels, including this one:)
15:56:45 <stephg> (this is all pending there being topics on TJC of course)
15:56:53 <cybette> gotta go, big thanks to stephg once again and hope to make it to next meeting
15:57:35 <stephg> ok going to do Thursday 14th April, 13:30 UTC dependent on topics
15:57:48 <schmittlauch> k
15:57:49 <r0kk3rz> stephg: make it so!
15:57:50 <sledges> is everyone ok with that?
15:57:52 <Jaymzz_> Sounds good
15:58:01 <stephg> #info Next meeting Thursday the 14th of April, 13:30 UTC, stephg to chair
15:58:04 <sledges> \o/
15:58:12 <stephg> aand there we go
15:58:13 <stephg> thanks all
15:58:14 <sledges> step up to stephg!
15:58:19 <stephg> and we got in with 90s to spare :P
15:58:31 <locusf> oh its already over ..
15:58:41 <veskuh> thanks all
15:58:44 <stephg> locusf: not yet :P
15:58:48 <stephg> #endmeeting