#mer-meeting: CalDAV/CardDAV Community Contributions Kick-off Meeting

Meeting started by chriadam at 09:04:04 UTC (full logs).

Meeting summary

    1. https://sailfishos.org/wiki/CalDAV_and_CardDAV_Community_Contributions (chriadam, 09:05:04)

  1. Agenda (chriadam, 09:05:16)
  2. Introductions (chriadam, 09:07:20)
    1. Lucien Xu, Sfiet_Konstantin, I would like to take a look at unit-tests and code-related tasks (SfietKonstantinW, 09:08:03)
    2. Chris Adams / chriadam - Sailor with Jolla, have contributed to CardDAV/CalDAV and other sync plugins. (chriadam, 09:08:07)
    3. Lewis Rockliffe - just observing (r0kk3rz, 09:08:28)
    4. Nadir Hanid, nh1402, just observing. (nh1402_work, 09:08:57)
    5. William, I am complete newby at Mer, but I would like to get into CPP stuff, so probably simple bugfixing first (William__, 09:09:03)
    6. David Greaves / lbt - Sailor and Mer guy. Can setup test infra if needed (lbt, 09:09:11)
    7. Damien Caliste, I would like to help contributing to unit tests and related bugs. (dcaliste, 09:09:53)

  3. Overview (chriadam, 09:13:01)
    1. First target is to improve stability and quality through improved testing (and related bug-fixing) (chriadam, 09:22:26)

  4. Test Servers - The Plan (chriadam, 09:25:45)
    1. Discussion between lbt/chriadam/occirol/dr_gogeta86 around 20th Sept to discuss setting up test server instances in Mer infra (chriadam, 09:36:46)
    2. Goal to have first test server instance up and running (and usable for testing) by 30th Sept. (chriadam, 09:37:06)

  5. Simple System Test Scripts - Any Volunteers? (chriadam, 09:40:38)
  6. Any Volunteers For MER#1623 ? (chriadam, 09:46:07)
    1. https://bugs.merproject.org/show_bug.cgi?id=1623 (SfietKonstantinW, 09:46:38)
    2. https://github.com/owncloud/vm (r0kk3rz, 09:49:03)
    3. AGREED: dcaliste to investigate MER#1623 (chriadam, 09:51:48)

  7. Any Volunteers For MER#1647 ? (chriadam, 09:52:32)
    1. https://bugs.merproject.org/show_bug.cgi?id=1647 (SfietKonstantinW, 09:54:31)
    2. AGREED: elfio will contribute a simple system-testing script (chriadam, 09:55:27)
    3. AGREED: William__ will look into MER#1647 (chriadam, 09:57:46)

  8. SDK Issues - Roadmap For Better Platform SDK (October) (chriadam, 09:58:16)
  9. Unit Tests - How? (chriadam, 10:07:21)
  10. Any Other Business ? (chriadam, 10:10:29)
    1. vam52 mentioned that the interchange format used for Bluetooth transfers / Sharing of Calendar Events is vCalendar not iCalendar - should update (chriadam, 10:13:06)

  11. Summary (chriadam, 10:14:17)


Meeting ended at 10:18:05 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. chriadam (154)
  2. SfietKonstantinW (22)
  3. lbt (21)
  4. dcaliste (20)
  5. William__ (11)
  6. r0kk3rz (9)
  7. merbot (4)
  8. dr_gogeta86 (4)
  9. elfio_mvl (3)
  10. vam52 (2)
  11. nh1402_work (2)


Generated by MeetBot 0.1.4.