#mer-meeting: Sailfish OS, Open Source, Collaboration 22nd of March 2017

Meeting started by Jaymzz_ at 09:00:39 UTC (full logs).

Meeting summary

    1. meeting information and agenda can be found here: https://lists.sailfishos.org/pipermail/devel/2017-March/007764.html (Jaymzz_, 09:00:54)
    2. Since this meeting was going to be a longer-than-usual session, I was forced to reduce the duration of some of the topics by requests from sailors who have to do their work! In case the time was not enough, we can continue the topic during the next meeting (whenever we agree the time and date). I also have moved the two related topics to the end of the meeting by request. (Jaymzz_, 09:01:12)

  1. Brief introduction (5 minutes). Please prefix your name/handle with # info (Jaymzz_, 09:01:44)
    1. James Noori, Community Manager, Jolla (Jaymzz_, 09:01:51)
    2. Lewis Rockliffe, community member (r0kk3rz, 09:02:11)
    3. Vesa-Matti Hartikainen, Program Manager, Jolla (veskuh, 09:02:13)
    4. Martin Ebnoether, Community Member and SailfishOS Fanboy (Venty, 09:02:31)
    5. occirol, Community member (occirol, 09:02:46)
    6. nh1402, community member and a sfdroid guy (nh1402, 09:02:57)
    7. Tomoshokas, Community member (tomoshokas, 09:03:07)
    8. Aleksi Suomalainen, Nemo and Sailfish Community member (locusf, 09:03:39)
    9. Chris Adams, developer at Jolla (chriadam_, 09:03:40)
    10. irc://chat.freenode.net:6667/#info Juhani Lassila, Head of Communications, Jolla (jlassila, 09:03:41)
    11. Simonas Leleiva, l10n'n'hw @ jolla (sledges, 09:03:50)
    12. Raju , Community Member (libregeekingkid[, 09:04:04)
    13. Pami Ketolainen, backend developer @�Jolla (pketo, 09:04:06)
    14. Martin Kolman, community member and modRana developer (M4rtinK, 09:04:11)
    15. irc://chat.freenode.net:6667/#info Juhani Lassila, Head of Communications, Jolla (jlassila, 09:04:17)
    16. eekkelund, Maemo Community council + community member (eekkelund, 09:04:50)
    17. Leif-Jöran Olsson, community (ljo, 09:06:06)

  2. MWC Announcements Q&A (20 mins) Asked by c_la , backup: r0kk3rz (Jaymzz_, 09:07:27)
    1. This topic is shortened in duration as explained before. The Q&A is going to be divided into 2 sections. The first section is to answer the top questions from TJC Q&A page ( https://together.jolla.com/question/157639/jolla-sony-xperia-qa/?sort=votes&page=1 ) and second, whatever time we have left in 20 minutes, will be dedicated to community members asking their questions live. In case there were unanswered questions left, we (Jaymzz_, 09:07:41)
    2. https://together.jolla.com/question/157639/jolla-sony-xperia-qa/?sort=votes&page=1 (Jaymzz_, 09:07:49)
    3. First question: How do we get Xperias running Sailfish OS? (Jaymzz_, 09:12:56)
    4. Answer: So basically: the practical side of things, i.e. how a user gets the Xperia Sailfish device are not agreed fully yet. So unfortunately we will need to come back to this at a later stage. (Jaymzz_, 09:13:12)
    5. second question: Alien Dalvik support? (Jaymzz_, 09:13:32)
    6. Answer: Simply yes. (Jaymzz_, 09:13:56)
    7. Third question: Will sony give jolla access to the SW that powers its really good cameras so SFOS can fully exploit them? (Jaymzz_, 09:14:27)
    8. Answer: For the camera, we cannot yet promise that all the features of the camera are supported, but we are working on it and we think that we are going to get great quality pictures out of the camera. (Jaymzz_, 09:14:44)
    9. Jonatan Walck, Community member (jwalck, 09:16:02)
    10. Fourth question: How will the warranty be handled? (Jaymzz_, 09:17:22)
    11. Fifth question: To what extent are Sony involved? Are they simply allowing their hardware to be ported onto, or are they looking at becoming an official partner? In essence, in the future, could we buy a Sony device running SFOS? (Jaymzz_, 09:18:32)
    12. Answer to the previous question: Not agreed yet. (Jaymzz_, 09:18:55)
    13. Answer: This is a collaboration between Jolla and Sony Open Devices Program. The future regarding "buying a Sony device with Sailfish OS" is under discussion, and will be announced when we know. (Jaymzz_, 09:19:37)
    14. Sixth question: When can we expect the first Xperias with SFOS? I imagine it will be an official port of SFOS onto an Xperia already running Android. If this is the case, will there be a clear, step-by-step process to help those Jolla fans who don't have great tech knowledge (Jaymzz_, 09:20:29)
    15. Answer: We target to have something to offer at the end of Q2. (Jaymzz_, 09:21:46)
    16. Seventh question: Will the Dual Sim models be supported if the single sim devices are going to receive SFOS? (Jaymzz_, 09:22:06)
    17. Answer: Our first project is with the Xpreria X device, further devices are still to be agreed and announced. Aim is to support several Xpreria series devices.  (Jaymzz_, 09:23:07)
    18. Eighth question: End of June? (Jaymzz_, 09:23:42)
    19. Answer: Yes (Jaymzz_, 09:23:50)
    20. Ninth question: Does the cooperation include Xperia tablets? (Jaymzz_, 09:24:17)
    21. Answer: Our first project is with the Xpreria X device, further devices are still to be agreed and announced. (Jaymzz_, 09:25:14)
    22. Tenth question: Will the devices be pure SFOS, or will they be dual boot? (Jaymzz_, 09:25:34)
    23. Answer: Practicalities are undecided, but we are considering both options single and dual boot. (Jaymzz_, 09:27:08)
    24. Does this mean we should run out and buy ourselves an xperia x with android today, getting sailfish and alien dalvik on it after Q2 2017? (Jaymzz_, 09:27:59)
    25. Answer: We should have answers relatively soon, so I'd not run to a store today. Of course up to you. (Jaymzz_, 09:30:03)

  3. Update PyOtherSide in Sailfish OS (10 min) Asked by M4tinK (Jaymzz_, 09:31:44)
    1. The PyOtherSide library, which makes it possible to write powerful Python + QtQuick applications, is stuck on version 1.4 on Sailfish OS. This version has some serious bugs that have since been fixed in newer versions & is missing many useful features provided by newer releases.The latest PyOtherSide stable release is 1.5.1 and I've prepared a merge request for updating to this version for the Mer core pyotherside package ( (Jaymzz_, 09:32:00)
    2. https://git.merproject.org/mer-core/pyotherside/merge_requests/2 ) As the PyOtherSide library keeps as stable API, has good test coverage & my testing has not uncovered any issues I think there should not be anything preventing the merge request from being merged by the Mer pyotherside package maintainer.So I'd like to formally ask for the merge request to be merged. I would also like to know how long will it approximately take for (Jaymzz_, 09:32:00)
    3. https://git.merproject.org/mer-core/pyotherside/merge_requests/2 (Jaymzz_, 09:32:08)
    4. We don’t at the moment have an active mainteiner for the PyOtherSide (Jaymzz_, 09:35:34)
    5. ACTION: pketo to check for pyotherside apps on harbour (Jaymzz_, 09:41:27)
    6. Since this is 3rd party API would be good to have someone familiar with the matter to check the things discussed (Jaymzz_, 09:44:57)
    7. This is good contribution and I think we should be able to get this in 2.1.2 (Jaymzz_, 09:45:24)

  4. Clarify and cleanup of Wiki's (20 min) Asked by pavi[m] (Jaymzz_, 09:46:50)
    1. We have currently 2 Wikis, one is at https://wiki.merproject.org/ and the other is at https://sailfishos.org/wiki/ . This issue concerns the visiblity of three projects SailfishOS, Mer and Nemo. The three are related to Mer but the information in the wiki is 1. Too confusing. 2. Repeated, 3. Ambiguous, 4. Written in wrong place, 5. Outdated. I hope some time is spent to discuss these issues. (Jaymzz_, 09:46:58)
    2. https://wiki.merproject.org/ (Jaymzz_, 09:47:09)
    3. https://sailfishos.org/wiki/ (Jaymzz_, 09:47:19)
    4. Target is to open it up for community, but we haven’t had time to proceed with that, and schedule is still looking like it will not change during short term. (Jaymzz_, 09:52:40)

  5. Nemo Mobile as community distribution for SailfishOS (60 min) Asked by locusf (Jaymzz_, 10:03:35)
    1. After giving this some thought, about what was discussed at the previous Jolla community meeting at FOSDEM, I've come up with an idea on how Nemo Mobile can make use of the open source efforts of Jolla. It would be quite useful to have mer feeding off of Fedora packages with the newest versions of stuff and co-maintaining the middleware update effort with Fedora community.But about how Fedora and Red Hat are related, I'd like (Jaymzz_, 10:03:44)
    2. Problem with using large part of desktop distro is that they are optimized for different use cases, newer kernel, different toolchain, desktop and server usecases etc. (Jaymzz_, 10:21:11)
    3. If pyotherside update goes fine, we will know the process for how the updates will be handled. M4tinK would be a good maintainer. the process should be easier and documented better. (Jaymzz_, 10:43:56)
    4. https://build.merproject.org/package/show/mer:core:gcc53/gcc5 (sledges, 10:56:59)
    5. ACTION: locusf to create proposal for further discussion leading to nemo being as staging for sailfish (locusf_, 11:01:25)
    6. ACTION: locusf_ to pull together a proposal to cover mer:nemo (tbc), feature projects/bugs and the goal of nemo in supporting sfos. Eventually to be reviewed and responded to by Jolla management. (lbt, 11:01:26)

  6. General discussion (15 min) (Jaymzz_, 11:03:06)
    1. ACTION: Jaymzz to discuss some collaboration possibilities with Alin Jerplea (Jaymzz_, 11:18:21)
    2. There is couple of things going on 1) OMP is promoting Sailfish development in russia 2) New devices will help - Jala, inoi, Xperia 3) New china partner will hopefully promote similarly in china (Jaymzz_, 11:23:43)
    3. The question to the above answer was: Is there a plan to improve the app gap situation. Can jolla afford to organise app devel workshops? (sledges, 11:25:24)
    4. Question about NFC situation for Xperia devices and Sailfish OS in general (Jaymzz_, 11:26:16)
    5. Answer: Proper NFC support with useful set of usecases is still a roadmap item and I can’t promise a schedule for it at this point. (Jaymzz_, 11:26:26)
    6. Having simple HW enabler is smaller item, but things like audio routing, payment, support in Dalvik are bigger items. (Jaymzz_, 11:26:47)

  7. Next meeting time and date (5min) (Jaymzz_, 11:30:39)
    1. Next meeting will be held on 5th of April 2017 at 09:00 UTC (Jaymzz_, 11:33:57)


Meeting ended at 11:35:32 UTC (full logs).

Action items

  1. pketo to check for pyotherside apps on harbour
  2. locusf to create proposal for further discussion leading to nemo being as staging for sailfish
  3. locusf_ to pull together a proposal to cover mer:nemo (tbc), feature projects/bugs and the goal of nemo in supporting sfos. Eventually to be reviewed and responded to by Jolla management.
  4. Jaymzz to discuss some collaboration possibilities with Alin Jerplea


Action items, by person

  1. locusf
    1. locusf to create proposal for further discussion leading to nemo being as staging for sailfish
    2. locusf_ to pull together a proposal to cover mer:nemo (tbc), feature projects/bugs and the goal of nemo in supporting sfos. Eventually to be reviewed and responded to by Jolla management.
  2. locusf_
    1. locusf_ to pull together a proposal to cover mer:nemo (tbc), feature projects/bugs and the goal of nemo in supporting sfos. Eventually to be reviewed and responded to by Jolla management.
  3. pketo
    1. pketo to check for pyotherside apps on harbour


People present (lines said)

  1. Jaymzz_ (130)
  2. lbt (59)
  3. M4rtinK (47)
  4. sledges (41)
  5. pavi[m] (37)
  6. locusf (37)
  7. veskuh (30)
  8. ApBBB (19)
  9. nh1402 (18)
  10. r0kk3rz (17)
  11. jlassila (16)
  12. M4rtinK_phone_ (7)
  13. c-la_ (7)
  14. locusf_ (7)
  15. c_la_phone (6)
  16. jwalck (5)
  17. occirol (4)
  18. chriadam_ (4)
  19. Coolgeek (3)
  20. merbot (3)
  21. pketo (3)
  22. kimmoli (2)
  23. eekkelund (2)
  24. Venty (2)
  25. abranson (1)
  26. libregeekingkid[ (1)
  27. tomoshokas (1)
  28. stephg (1)
  29. ljo (1)
  30. Drummer12_ (1)


Generated by MeetBot 0.1.4.