#mer-meeting: Sailfish OS, open source, collaboration – August 23rd 2017

Meeting started by sledges at 08:03:36 UTC (full logs).

Meeting summary

    1. Meeting information and agenda can be found here: https://lists.sailfishos.org/pipermail/devel/2017-August/007978.html (sledges, 08:04:26)

  1. Brief introduction (5 min). Please prefix your name/handle with # info (sledges, 08:04:52)
    1. Leif-Jöran Olsson, community member (ljo_, 08:05:13)
    2. tbr, mer community (tbr, 08:05:14)
    3. juiceme, general hacker (juiceme, 08:05:18)
    4. Jens Müller, Sailor / SFOS User (jenix, 08:05:21)
    5. Chris Adams, developer at Jolla (chriadam__, 08:05:21)
    6. nh1402, community member (nh1402, 08:05:26)
    7. LSRB, newbie (LSRB, 08:05:29)
    8. Drummer12, SFOS User and Community member (Drummer12, 08:05:43)
    9. Rodolphe Sequeira, community member (RodSeq, 08:05:45)
    10. Nekron, golang developer (nekron, 08:05:45)
    11. jolladiho, user (jolladiho, 08:05:46)
    12. Leszek Lesner, developer and community member (leszek, 08:05:47)
    13. eekkelund (eekkelund, 08:05:49)
    14. bshah, Halium, Plasma Mobile (bshah, 08:05:50)
    15. piggz, community porter (mido/falcon/ace) (piggz, 08:05:51)
    16. Mister_Magister, mad porter (Mister_Magister, 08:05:52)
    17. James Noori, won't be available the whole time, community manager (Jaymzz, 08:05:53)
    18. Damien Caliste, community (dcaliste, 08:05:56)
    19. Lewis Rockliffe, shenannigans bringer (r0kk3rz, 08:05:56)
    20. Kostadin Damyanov, community (Max-Might, 08:06:02)
    21. Pami Ketolainen, sailor @ Jolla (pketo, 08:06:08)
    22. Wouter van Heijst, infra at Jolla (LarstiQ, 08:06:10)
    23. ExPLIT, community member (ExPLIT, 08:06:13)
    24. Steph Gosling community, lapsed porter (stephg, 08:06:13)
    25. schmittlauch,community member (M-schmittlauch, 08:06:15)
    26. Jonatan Walck, community member (jwalck, 08:06:22)
    27. raj/user (Sailor5811_, 08:06:25)
    28. remote1, user (remote1, 08:06:29)
    29. Martin Ebnoether, Humble SailfishOS User and Community Member (Venty, 08:06:29)
    30. marmistrz, currently porting SFOS (marmistrz, 08:06:39)
    31. Carmen Fdez, community member (cfb014, 08:06:40)
    32. herdem, prospective SailfishOS user (herdem, 08:07:05)
    33. Simonas Leleiva, hw & l10n at Jolla (sledges, 08:07:41)
    34. Vesa-Matti Hartikainen, Program Manager at Jolla (veskuh, 08:08:25)
    35. Timur Kristof, community member (Venemo, 08:09:08)
    36. Simo Piiroinen, developer at Jolla (spiiroin, 08:09:12)
    37. vk, future SFOS user and tinkerer (vk, 08:09:39)

  2. Energy Aware Scheduling (EAS) support in Sailfish (10 mins, asked by nh1402) (sledges, 08:09:41)
    1. some details about the topic: EAS is designed with SoC's with the big.Little design in mind, so that the more energy efficient CPU's are used more effectively. This should in theory increase battery life by quite a bit, and with the Xperia X coming, it would be a suitable device to use it with. (sledges, 08:11:29)
    2. Now EAS isn't just a kernel tweak, it requires numerous patches on the kernel, but some things also need changing at the OS level also. (sledges, 08:11:34)
    3. https://developer.arm.com/open-source/energy-aware-scheduling/eas-mainline-development (nh1402, 08:12:42)
    4. https://developer.arm.com/open-source/energy-aware-scheduling (nh1402, 08:20:34)
    5. https://developer.arm.com/open-source/energy-aware-scheduling (sledges, 08:20:56)
    6. https://developer.arm.com/open-source/energy-aware-scheduling/eas-mainline-development (sledges, 08:21:01)
    7. https://www.linuxplumbersconf.org/2016/ocw//system/presentations/3693/original/LPC-%20EAS%20for%20Android.pdf (sledges, 08:21:14)
    8. Jolla'll have that technology in mind in case battery life performance becomes a priority, in the meantimg nothing prevents community from experimenting while doing ports to sfos (sledges, 08:21:55)

  3. UnitTesting QML apps (20 min - asked by M-schmittlauch) (sledges, 08:22:10)
    1. What are the recommended setups (tools, project structure, frameworks) for testing QML apps? What's still missing? (sledges, 08:22:23)
    2. https://gist.github.com/schmittlauch/172c39a9e669ece1e5a080a0869e7a87 (sledges, 08:24:46)
    3. http://doc.qt.io/qt-5/qttest-qmlmodule.html (chriadam__, 08:25:55)
    4. these are used internally e.g. in jolla-gallery etc to test that our interaction flows work as expected (sledges, 08:27:25)
    5. ACTION: chriadam__+Jolla to document best UI testing practices about project structure and QtCreator integration (sledges, 08:40:17)

  4. Update for Xperia X port (10 min - asked by jenix) (sledges, 08:42:05)
    1. A lot of Sailors (me included) are getting excited about the planned release of SFOS for Sony's Xperia X. I'd like to ask a few questions regarding the status of the project (current status, model variety, release schedule and prices). (sledges, 08:42:18)
    2. https://github.com/ExAnimoso/counter-application (coderus1, 08:50:51)
    3. (links for previous topic about QML UI testing): (sledges, 08:51:59)
    4. https://habrahabr.ru/post/320808/ (sledges, 08:52:03)
    5. https://github.com/ExAnimoso/counter-application (sledges, 08:52:08)
    6. we are getting closer to announcing the details, getting good progress with the issues we’ve had and I(veskuh)’m using the device happily as my daily device already :) (sledges, 08:53:00)
    7. Still only supported model is F5121 (sledges, 08:53:13)
    8. My advice is still wait to hear the [announcement] details first before going to shop (sledges, 08:53:33)
    9. Alien Dalvik [on Xperia X] will be based on the 4.4.4 (sledges, 08:54:10)

  5. General discussion (15 min) (sledges, 08:55:36)
    1. ideas for next meeting (those who didn't get their answers, please suggest meeting questions in the next fortnight): (sledges, 09:05:04)
    2. gcc upgrade (sledges, 09:05:09)
    3. feasibility of adding firefox improvement to sfos browser (sledges, 09:05:27)
    4. harbour in russia ; paid apps support (tortoisedoc, 09:05:40)
    5. (insert your unanswered question here:) (sledges, 09:05:40)
    6. unanswered question: Is Jolla working together with YouYota on the tablet? Would Jolla help YouYota increase awareness on the YouYota tablet project? See https://www.indiegogo.com/projects/youyota-sailfish-os-2-in-1-tablet/#/ (Venemo, 09:06:34)

  6. Next meeting time and date (5min) (sledges, 09:07:47)
    1. Next meeting will be held on Wednesday, 6th of September 2017 at 08:00 UTC (sledges, 09:11:25)


Meeting ended at 09:11:31 UTC (full logs).

Action items

  1. chriadam__+Jolla to document best UI testing practices about project structure and QtCreator integration


Action items, by person

  1. chriadam__
    1. chriadam__+Jolla to document best UI testing practices about project structure and QtCreator integration


People present (lines said)

  1. sledges (71)
  2. nh1402 (32)
  3. Mister_Magister (32)
  4. M-schmittlauch (25)
  5. r0kk3rz (20)
  6. piggz (18)
  7. veskuh (17)
  8. chriadam__ (17)
  9. jenix (15)
  10. Venemo (13)
  11. tortoisedoc (12)
  12. Sailor5811_ (12)
  13. ApBBB (11)
  14. remote1 (10)
  15. leszek (8)
  16. LarstiQ (7)
  17. marmistrz (7)
  18. c_la (6)
  19. RodSeq (4)
  20. stephg (4)
  21. nekron (4)
  22. Coolgeek (4)
  23. merbot (3)
  24. ljo_ (2)
  25. vk (2)
  26. eekkelund (2)
  27. tbr (2)
  28. coderus1 (2)
  29. cfb014 (1)
  30. bshah (1)
  31. ExPLIT (1)
  32. spiiroin (1)
  33. jwalck (1)
  34. dcaliste (1)
  35. Venty (1)
  36. jolladiho (1)
  37. occirol (1)
  38. LSRB (1)
  39. herdem (1)
  40. Drummer12 (1)
  41. pketo (1)
  42. rainemak (1)
  43. Max-Might (1)
  44. juiceme (1)
  45. Jaymzz (1)


Generated by MeetBot 0.1.4.