08:03:36 <sledges> #startmeeting Sailfish OS, open source, collaboration – August 23rd 2017
08:03:36 <merbot> Meeting started Wed Aug 23 08:03:36 2017 UTC.  The chair is sledges. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
08:03:36 <merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:04:26 <sledges> #info Meeting information and agenda can be found here: https://lists.sailfishos.org/pipermail/devel/2017-August/007978.html
08:04:45 <sledges> I am the meeting’s chairperson today and will be doing my best to keep time and order. Please behave, respect the timings and be-have.
08:04:52 <sledges> #topic Brief introduction (5 min). Please prefix your name/handle with # info
08:05:13 <ljo_> #info Leif-Jöran Olsson, community member
08:05:14 <tbr> #info tbr, mer community
08:05:18 <juiceme> #info juiceme, general hacker
08:05:21 <jenix> #info Jens Müller, Sailor / SFOS User
08:05:21 <chriadam__> #info Chris Adams, developer at Jolla
08:05:26 <nh1402> #info nh1402, community member
08:05:29 <LSRB> #info LSRB, newbie
08:05:43 <Drummer12> #info Drummer12, SFOS User and Community member
08:05:45 <RodSeq> #info Rodolphe Sequeira, community member
08:05:45 <nekron> #info Nekron, golang developer
08:05:46 <jolladiho> #info jolladiho, user
08:05:47 <leszek> #info Leszek Lesner, developer and community member
08:05:49 <eekkelund> #info eekkelund
08:05:50 <bshah> #info bshah, Halium, Plasma Mobile
08:05:51 <piggz> #info piggz, community porter (mido/falcon/ace)
08:05:52 <Mister_Magister> #info Mister_Magister, mad porter
08:05:53 <Jaymzz> #info James Noori, won't be available the whole time, community manager
08:05:56 <dcaliste> #info Damien Caliste, community
08:05:56 <r0kk3rz> #info Lewis Rockliffe, shenannigans bringer
08:06:02 <Max-Might> #info Kostadin Damyanov, community
08:06:08 <pketo> #info Pami Ketolainen, sailor @ Jolla
08:06:10 <LarstiQ> #info Wouter van Heijst, infra at Jolla
08:06:13 <ExPLIT> #info ExPLIT, community member
08:06:13 <stephg> #info Steph Gosling community, lapsed porter
08:06:15 <M-schmittlauch> #info schmittlauch,community member
08:06:22 <jwalck> #info Jonatan Walck, community member
08:06:25 <Sailor5811_> #info raj/user
08:06:29 <remote1> #info remote1, user
08:06:29 <Venty> #info Martin Ebnoether, Humble SailfishOS User and Community Member
08:06:36 <stephg> getting the impression lots of folks are back from holiday :)
08:06:39 <marmistrz> #info marmistrz, currently porting SFOS
08:06:40 <cfb014> #info Carmen Fdez, community member
08:06:59 <Mister_Magister> whoa we have many people today
08:07:05 <herdem> #info herdem, prospective SailfishOS user
08:07:41 <sledges> #info Simonas Leleiva, hw & l10n at Jolla
08:07:58 <piggz> Mister_Magister: maybe as its holiday seaason (thats why I can make it!)
08:08:16 <Mister_Magister> piggz: i'm at work though haha :D
08:08:25 <veskuh> #info Vesa-Matti Hartikainen, Program Manager at Jolla
08:09:08 <Venemo> #info Timur Kristof, community member
08:09:12 <spiiroin> #info Simo Piiroinen, developer at Jolla
08:09:29 <stephg> piggz: you no longer biking?
08:09:39 <vk> #info vk, future SFOS user and tinkerer
08:09:41 <sledges> #topic Energy Aware Scheduling (EAS) support in Sailfish (10 mins, asked by nh1402)
08:10:01 <piggz> stephg: no, back in uk, brother and his family visiting this week
08:10:12 <nh1402> a bit more info about EAS https://developer.arm.com/open-source/energy-aware-scheduling
08:10:23 <sledges> merbot: wake up:)
08:10:23 <merbot> sledges: Error: "wake" is not a valid command.
08:10:39 <stephg> pfft, silly merbot
08:10:51 <LarstiQ> sledges: it can't set topic without ops
08:11:06 <sledges> ok, it doesn't spit more info when topic changes, so moving on
08:11:29 <nh1402> so EAS is designed for SoC's with different CPU's (performance and power efficient)
08:11:29 <sledges> #info some details about the topic: EAS is designed with SoC's with the big.Little design in mind, so that the more energy efficient CPU's are used more effectively. This should in theory increase battery life by quite a bit, and with the Xperia X coming, it would be a suitable device to use it with.
08:11:34 <sledges> #info Now EAS isn't just a kernel tweak, it requires numerous patches on the kernel, but some things also need changing at the OS level also.
08:11:55 <Mister_Magister> Well in my new port there is big.LITTLE architecture so it would be useful
08:12:00 <r0kk3rz> is there any EAS support in mainline kernel?
08:12:16 <nh1402> there is in AOSP common kernel apparently
08:12:42 <nh1402> https://developer.arm.com/open-source/energy-aware-scheduling/eas-mainline-development
08:12:53 <nh1402> and mainline development
08:13:30 <r0kk3rz> dont porters just disable the BIG cores instead?
08:13:43 <tbr> yes, there won't be reaction to topic commands, but the bot registers them just fine
08:13:50 <Mister_Magister> r0kk3rz: i disabled little ones because animations was super laggy
08:13:59 <nh1402> some say EAS can improve battery life substantially
08:14:04 <r0kk3rz> oh, other way around ok
08:14:36 <Mister_Magister> basically big ones are used all the time and little ones are just for heavy multitasking
08:14:55 <piggz> Mister_Magister: what are your cores?
08:15:14 <Mister_Magister> piggz: snapdragon 810 i don't remember details
08:15:21 <Mister_Magister> 4x1.5 4x2 GHz
08:15:22 <nh1402> I can't imagine the cores would be too different from the ones on the SoC
08:15:30 <nh1402> Xperia X*
08:15:42 <nh1402> a53?
08:15:47 <nh1402> a72?
08:16:01 <Sailor5811_> little ones are also  used for small applications like dialer Mister_Magister
08:16:23 <Mister_Magister> Sailor5811_: nah it isn't that simple to just use little ones for that
08:16:44 <Mister_Magister> 4x ARM Cortex A57 4x ARM Cortex A53
08:16:47 <piggz> ah, you have 4xa53 and 4xa57 .... I have 8xa57
08:16:55 <sledges> nh1402: so your question is, is it coming to Xperia X?
08:17:06 <nh1402> to Sailfish in general
08:17:11 <Mister_Magister> i have another port with big.LITTLE too moto x play
08:17:12 <nh1402> and the Xperia X
08:17:22 <sledges> nh1402: can you enlist what changes are in order at the OS level?
08:18:02 <Mister_Magister> If somebody need some testing with that in futurejust write to me :)
08:18:23 <sledges> (two minutes left)
08:18:34 <Sailor5811_> Mister_Magister: to reduce battery usage & cpu power . When heavy load comes they act together with big ones
08:19:23 <nh1402> sledges: I'm afraid I can't find that information, maybe the OS changes were only for Android specifically
08:19:24 <Mister_Magister> Sailor5811_: nope it's working in other way. The big ones are used all the time and when need for multitasking comes (heavy usage) the little ones are used
08:19:54 <M-schmittlauch> Does the kernel decide which types of cores to use or do userlevel applications have a say too?
08:19:56 <RodSeq> good slides on Power + Performance improvement with EAS applied on Android: https://www.linuxplumbersconf.org/2016/ocw//system/presentations/3693/original/LPC-%20EAS%20for%20Android.pdf
08:20:34 <nh1402> https://developer.arm.com/open-source/energy-aware-scheduling
08:20:40 <sledges> nh1402: thanks for making us aware, we'll have that technology in mind in case battery life performance becomes a priority, nothing prevents you from experimenting while doing ports to sfos
08:20:45 <Mister_Magister> M-schmittlauch: i just explained how kernel is using/should use them
08:20:56 <sledges> #link https://developer.arm.com/open-source/energy-aware-scheduling
08:21:01 <sledges> #link https://developer.arm.com/open-source/energy-aware-scheduling/eas-mainline-development
08:21:04 <r0kk3rz> it would make sense for the OS to have some say, if your app is going to be long running but doesnt need big juice then maybe thats what its for
08:21:14 <sledges> #link https://www.linuxplumbersconf.org/2016/ocw//system/presentations/3693/original/LPC-%20EAS%20for%20Android.pdf
08:21:22 <Mister_Magister> on my phone without modifications all the little ones were working all the time with one big
08:21:55 <sledges> #info Jolla'll have that technology in mind in case battery life performance becomes a priority, in the meantimg nothing prevents community from experimenting while doing ports to sfos
08:21:59 <Mister_Magister> that big.LITTLE architecture is pure nonesense and pita
08:22:06 <sledges> moving on:)
08:22:10 <sledges> #topic UnitTesting QML apps (20 min - asked by M-schmittlauch)
08:22:23 <sledges> #info What are the recommended setups (tools, project structure, frameworks) for testing QML apps? What's still missing?
08:22:44 <M-schmittlauch> Hi. Im on mobile so please be patient
08:23:33 <marmistrz> M-schmittlauch, thanks for bringing up this topic! :)
08:23:55 <M-schmittlauch> So the main question is: How do people (both Jolla themselves and 3rd party devs) are testing QtQuick apps?
08:24:14 <sledges> the best person amongst us now to answer that would be chriadam__ :)
08:24:26 <M-schmittlauch> sledges: can you please post the link I prepared?
08:24:44 <sledges> M-schmittlauch: sure
08:24:46 <sledges> #link https://gist.github.com/schmittlauch/172c39a9e669ece1e5a080a0869e7a87
08:25:05 <M-schmittlauch> I found 2 tutorials (see link) but both have issues:
08:25:11 <Sailor5811_> Mister_Magister: https://www.google.co.in/url?sa=t&source=web&rct=j&url=https://www.arm.com/files/pdf/big_LITTLE_Technology_the_Futue_of_Mobile.pdf&ved=0ahUKEwir0aG29uzVAhWBqI8KHaH6D9EQFggvMAE&usg=AFQjCNFbmKPyEuKFiPj4r61ftG3a9aKHpA
08:25:16 <r0kk3rz> M-schmittlauch: iirc a while back sfietkonstantin was investigating unit testing with qt, might be worth hunting him down and seeing what he came up with
08:25:23 <chriadam__> the QtTest import provides a variety of types which allow building autotests for QtQuick (TestCase etc)
08:25:49 <sledges> SfietKonstantinW: ^^
08:25:55 <chriadam__> #link http://doc.qt.io/qt-5/qttest-qmlmodule.html
08:26:45 <M-schmittlauch> 1 issue is the project structure: I dont want the release packages to have the test data and cases - so use sub packages?
08:26:46 <chriadam__> these are used internally e.g. in jolla-gallery etc to test that our interaction flows work as expected.  you have to do some hacks (like setting objectName property to "known value" which the test driver can then test against)
08:26:47 <Venemo> GUI unit testing is always a challenge, so it'd be interesting to hear how Qt solves that
08:27:24 <chriadam__> we don't use it internally, but there are frameworks like squish from froglogic which expand upon the basic support.
08:27:25 <sledges> #info these are used internally e.g. in jolla-gallery etc to test that our interaction flows work as expected
08:27:37 <M-schmittlauch> But those have the problem that QtCreator may be confused by the import paths
08:27:40 <chriadam__> M-schmittlauch: yes, sub-packages is the way it's done
08:28:15 <M-schmittlauch> Documenting best practices in SFOS wiki would be great
08:28:25 <chriadam__> I agree
08:28:29 <chriadam__> we should do that
08:29:11 <sledges> a volunteer for the #action? :)
08:29:25 <piggz> seems like chriadam__did ;)
08:29:29 <M-schmittlauch> chriadam__: The example structure I used needed me to change imports between coding and building for autosuggest to work
08:29:39 <M-schmittlauch> (see link)
08:29:53 <chriadam__> M-schmittlauch: when it comes to QtCreator integration and the .qmltypes data, that's an interesting issue which I don't know much about
08:30:50 <M-schmittlauch> I only want to test a db migration, but for UI testing some convenience functions for Silica might be useful
08:31:10 <chriadam__> sorry, I don't understand what you mean there?
08:31:29 <M-schmittlauch> chriadam__: use the C++ test harnish or qmltestrunner?
08:31:53 <chriadam__> qmltestrunner
08:32:47 <chriadam__> with a modified environment (to prevent e.g. dbus interaction from causing issues, so separate session)
08:33:20 <M-schmittlauch> chriadam__: one tutorial I linked included code how to control Silica UI components (eg pulley menus), but mentioned other QML components shipping them
08:33:49 <M-schmittlauch> I have no experience with UI testing, though
08:34:38 <chriadam__> M-schmittlauch: forgive me if I'm misunderstanding: are you suggesting that we provide some testing convenience methods in Silica.Test import namespace or similar, to make creating unit tests easier?
08:35:04 <chriadam__> e.g. to interact with pulley menu / other Silica-specific elements?
08:35:22 <nekron> M-schmittlauch: if the GUI is not too complex I usually test the GUI logic manually as test cases are much overhead to implement
08:35:33 <M-schmittlauch> yes, if that isnt easy done yet
08:36:12 <ApBBB> nekron: if you have a complex gui on a mobile device you are most definately doing something wrong
08:36:40 <nekron> ApBBB: I try to KISS ;-)
08:37:05 <chriadam__> M-schmittlauch: I'm not sure what level of convenience API we have currently.  we can look into improving it, but currently I'm not sure how much resources we have available for such effort.  documentation can certainly be improved, though, and if we see a clear lack, perhaps some convenience methods can be added as part of sdk effort.  but would need management to agree on that I guess.
08:37:46 <M-schmittlauch> (I have no practical experience, just mentioning this for completeness reasons. I just think there might be something wrong when other QML components have convenience methods but Silica doesnt)
08:39:03 <M-schmittlauch> chriadam__: For me, documenting best practices about project structure and QtCreator integration would be more important
08:39:55 <chriadam__> ok, well that's a simple first step :-)  I'll raise it with chiefs internally and try to get it roadmapped.
08:39:56 <M-schmittlauch> eg sub packages need modifications to the Spectacle yaml file which is hidden in QtCreator
08:40:17 <sledges> #action chriadam__+Jolla to document best UI testing practices about project structure and QtCreator integration
08:40:23 <M-schmittlauch> also: import paths, autosuggest and running tests
08:40:39 <r0kk3rz> sledges: chriadam__ maybe another webinar topic!
08:41:07 <sledges> may be :)
08:41:25 <sledges> wrapping up, thanks M-schmittlauch and chriadam__!
08:41:28 <chriadam__> sledges: I will raise it with Joona and see when we can roadmap that one for.  Can't promise to have it done by the next meeting, for example, it depends on priorities and scheduling.
08:41:33 <piggz> where do webinars get announced? i cant recall seeing any!
08:41:57 <r0kk3rz> piggz: its been a while since they did some webinars, it was around the Jolla C release time
08:42:02 <sledges> chriadam__: certainly:)
08:42:05 <sledges> #topic Update for Xperia X port (10 min - asked by jenix)
08:42:18 <sledges> #info A lot of Sailors (me included) are getting excited about the planned release of SFOS for Sony's Xperia X. I'd like to ask a few questions regarding the status of the project (current status, model variety, release schedule and prices).
08:42:26 <piggz> r0kk3rz: ah, in that case, i saw some live :)
08:42:35 * nekron pulls a bag of popcorn
08:42:36 <Venemo> Yes, I'd like to hear more about it too
08:42:37 <jenix> So, first of all, thank you for keeping us up-to-date with the blog post / updates, veskuh. I think many members of the community are interested in an update, but I'm also aware that a lot of my question(s) are more or less boiling down to 'anything new?', so please tell me if they annoy you, then I'll stop :)
08:42:45 <sledges> veskuh: are you nearby?:)
08:42:46 <Sailor5811_> sledges:  :)
08:43:06 <veskuh> Thanks :) So we are getting closer to announcing the details
08:43:10 <jenix> I'll try to make my part as short as possible to catch up some time
08:43:36 <veskuh> I think we are getting good progress with the issues we’ve had and I’m using the device happily as my daily device already :)
08:43:47 <jenix> veskuh: thats nice to hear
08:44:03 <remote1> is Jolla going to IFA2017 in Berlin?
08:44:12 <jenix> can you already estimate a release date or month?
08:44:19 <r0kk3rz> remote1: save it for general discussion
08:44:50 <jenix> like are we talking 01.09.2017 or Christmas 2020? :)
08:45:04 <sledges> or somewhere in between ;)
08:45:08 <LarstiQ> or outside?
08:45:08 <veskuh> jenix: I can’t announce it here. We should be ready to announce the details quite soon.
08:45:22 <r0kk3rz> jenix: SoonTM obviously
08:45:30 <Coolgeek> the price too is disclose for now ?
08:45:43 <jenix> veskuh: any news regarding dedvice models? You're still on F5121 or did you expand to other models as well?
08:45:58 <jenix> *device
08:45:59 <veskuh> jenix: Still only supported model is F5121
08:46:11 <remote1> hopefully F5122 soon after
08:46:26 <LarstiQ> r0kk3rz: non sarcastically, next announcement really is soon now
08:46:29 <Coolgeek> do you have a plan for how long you will support this device ?
08:46:36 <r0kk3rz> LarstiQ: :)
08:46:39 <sledges> RSN:)
08:46:41 <jenix> veskuh: thanks, so it's feasible to buy a F5121 (like many already did) by now?
08:46:57 <veskuh> remote1: It would be nice, but no plans to attend at the moment. Yes, dual SIM variant support would be nice, but let’s see when single sim is ready how big effort it is and if community can help us.
08:47:05 <ApBBB> veskuh: have you had any talks woth the sony guys about using a mainline kernel?? or helping them in a way. because that is what they were targeting at some point
08:47:20 <r0kk3rz> veskuh: of course we can help :)
08:47:43 <r0kk3rz> ApBBB: mainline kernel stuff is still far off being useable
08:47:55 * vk wonders if SFOS on XperiaX depends/needs "TA partition"/DRM keys, for those who have lost it
08:47:58 <Mister_Magister> dualsim is like add 2 lines to /etc/ofono/ril_subscriptions, no?
08:48:13 <veskuh> jenix: My advice is still wait to hear the details first before going to shop.
08:48:46 <jenix> veskuh: like wait for the announcement soon to come or wait till the relase?
08:48:54 <remote1> Mister_Magister: yeah, I thought the same, since we have Jolla C already, but seems like it takes more
08:49:02 * ApBBB will wait for a smaller device (hopefully the rumored new compact xperia since the xcompact is getting old)
08:49:30 <Mister_Magister> yeah my friend have x compact and is interested in sfos so i hope it will be available too
08:49:44 <nh1402> speaking of the rumoured new XZ1 compact, the UK pricing has allegedly been leaked
08:49:49 <r0kk3rz> remote1: the porting side will be easy as, the business side? is always complicated :)
08:50:23 <ApBBB> by the time jolla finishes with the x the x compact will have been replaced
08:50:43 <coderus1> about qml unit testing: https://habrahabr.ru/post/320808/
08:50:44 <ApBBB> hoe vesku will give us xz1 compact support
08:50:47 <jenix> veskuh: And I'll just have two minor questions to end with: Can you already say which Android Version the Alien Dalvik on the Xperia X will run on? And what about the propritary DRM-protected hardware-features of the Xperia X, like camera-improvements? I'd suspect they will be lost like in the AOSP builds, right?
08:50:51 <coderus1> https://github.com/ExAnimoso/counter-application
08:51:42 <ApBBB> eeeek hope not hoe
08:51:50 <Sailor5811_> is sfos without android support ready for X ?
08:51:51 <veskuh> jenix: Alien Dalvik will be based on the 4.4.4.
08:51:59 <sledges> #info (links for previous topic about QML UI testing):
08:52:00 <nh1402> jenix: I think the DRM stuff has already been answered, Sailfish and Alien Dalvik won't use it.
08:52:03 <sledges> #link https://habrahabr.ru/post/320808/
08:52:07 <M-schmittlauch> coderus1: Yeah, I linked that. But it doesnt use subpackages for test files
08:52:08 <sledges> #link https://github.com/ExAnimoso/counter-application
08:52:28 <Coolgeek> 4.4 for android support ? why can't it be more recent ?
08:52:37 <M-schmittlauch> sledges: I linked to that in my gist
08:52:52 <veskuh> Sailor5811_:  There are still some missing features and few bugs, but most stuff is working quite nicely.
08:53:00 <sledges> #info we are getting closer to announcing the details, getting good progress with the issues we’ve had and I(veskuh)’m using the device happily as my daily device already :)
08:53:13 <sledges> #info Still only supported model is F5121
08:53:30 <veskuh> Coolgeek: Porting newer Android version is a major effort
08:53:33 <sledges> #info My advice is still wait to hear the [announcement] details first before going to shop
08:53:58 <nh1402> if you want newer version of Android, I say help with the Anbox effort
08:54:06 <leszek> no one actually managed to create an android runtime / acl beyond 4.4.4
08:54:10 <sledges> #info Alien Dalvik [on Xperia X] will be based on the 4.4.4
08:54:10 <piggz> nh1402: +1
08:54:18 <jenix> veskuh: great, thank you very much for the ansers. I (We) wish you good progress :)
08:54:42 <marmistrz> Anbox has one advantage over Alien dalvik btw.: it's FLOSS and doesn't require custom kernel module
08:54:49 <sledges> veskuh: yes, DRM keys are lost as soon as you unlock the bootloader (all is written in EULAs)
08:54:55 <sledges> jenix: yes, DRM keys are lost as soon as you unlock the bootloader (all is written in EULAs)
08:55:01 <leszek> marmistrz: but it has the downside of using a lot more ressources atm
08:55:05 <nh1402> marmistrz: actually numerous kernel patches are needed
08:55:07 <leszek> and it needs a recent kernel
08:55:13 <Venemo> so does that mean that the Xperia's camera doesn't work or does it mean it works, but not as well?
08:55:19 <Sailor5811_> veskuh:  Any improvements in App Cache?
08:55:26 <Venemo> or what are the DRM-protected features you speak of?
08:55:30 <sledges> ok, we've overshot the schedule, moving on:)
08:55:36 <sledges> #topic General discussion (15 min)
08:55:41 <r0kk3rz> Venemo: the most noticable one is the noise suppression
08:55:57 <jenix> Venemo: It means you don0t get a 23MP camera (which is achieved by software improvements), but only the native 8 MP one.
08:56:07 <veskuh> Venemo: Camera works, and works quite well
08:56:12 <remote1> jenix: sony's latest AOSP allow 23MP
08:56:15 <sledges> jenix: we're already at 16MP, maybe will reach 23MP
08:56:16 <piggz> i have 2 topics for general ... 1) could veskuh comment on QtLocation 5.6 either here or to the ML for rinigus? 2) plans for fingerprint support?
08:56:25 <jenix> oh, cool. I didn't know that
08:56:28 <Venemo> so basically it's just a software and not a hardware limitation? how does a 23MP camera become 8MP?
08:56:29 <ApBBB> veskuh: is it fast? (the camera) and will USB otg work?
08:56:43 <Mister_Magister> I'll be starting next crowdfunding campaign but first i need to ask community which phone they want to crowdfund :)
08:56:45 <sledges> Venemo: think about bandwidth needed to pipe all these pixels ;)
08:56:57 <marmistrz> sledges, what about this hybris-boot CI integration? Did you think about it?
08:57:00 <piggz> Mister_Magister: u need to get the last one working first ;)
08:57:02 <veskuh> Venemo: 16MP like commented above. Sony propietary bits on camera pipeline.
08:57:09 <jenix> Venemo: so, apperently the 8MP was on older version :)
08:57:11 <Venemo> sledges: PureView did it in 2012 so I don't see why Sony couldn't do it now
08:57:13 <sledges> Mister_Magister: try https://together.jolla.com/question/128326/community-port-requests/
08:57:19 <nh1402> also an update on quicksilver, tried reviving it, but too much has changed in the chromium codebase, and with my limited knowledge in that area, it won't be revived. Even the original developer suggested of using qtwebengine instead
08:57:21 <c_la> veskuh: is dual boot (sfos/android) feasible on xperia x?
08:57:26 <Mister_Magister> piggz: it is working just video/camera and bluetooth are not working and campaign takes some time
08:57:27 <sledges> Venemo: different hw+sw design
08:57:43 <Mister_Magister> sledges: but there is many ports and people need to choose one they want
08:57:50 <Mister_Magister> i would go with honor 5x though
08:57:52 <sledges> Mister_Magister: it's vote based
08:58:01 <Mister_Magister> ah thanks!
08:58:04 <M-schmittlauch> Any news on open-sourcing, veskuh?
08:58:07 <Sailor5811_> Nokia 6 !
08:58:19 <nh1402> Sailor5811_: locked bootloader
08:58:20 <Venemo> lol
08:58:23 <sledges> (suggestion for everyone to vote/add devices on that TJC:)
08:58:49 <veskuh> c_la: Dual boot is perhaps technically possible, but we are not supporting it. There is challenges related to handling updates.
08:59:06 <tortoisedoc> +1nokia 6!
08:59:09 <Mister_Magister> sledges: i'll ask James Noori to help me with reaching more people
08:59:09 <remote1> is Jolla going to IFA2017 in Berlin?
08:59:16 <veskuh> M-schmittlauch: Sorry, nothing I can announce here.
08:59:16 <Coolgeek> any news on fully opensourcing SFOS ?
08:59:30 <ApBBB> rainemak: a question about the browser. mozilla are landing stuff that make firefox faster. will these come to the sfos browser?
08:59:30 <nh1402> tortoisedoc: since the last minute, the bootloader situation still hasn't changed, it's still locked
08:59:50 <tortoisedoc> whats the status of harbour in say russia?
08:59:50 <sledges> marmistrz (& all): which 3rd party CI service for github would you recommend? (having shellcheck in mind)
08:59:53 <RodSeq> @leszek about the Anbox ressouce downside: requires more more ROM or more RAM vs Dalvik ?
09:00:07 <tortoisedoc> there were rumors that a separate one would be opened, targetibg that market
09:00:12 <leszek> RodSeq: more RAM atm
09:00:13 <tortoisedoc> *targeting
09:00:14 <Sailor5811_> veskuh:  App Cache for FASTER opening?
09:00:15 <M-schmittlauch> and is there now a position of Jolla on GPLv3? Is not being able to lock the phone down a real issue?
09:00:21 <nh1402> ApBBB: I would have tried building Firefox for Sailfish but requires newer version of gcc
09:00:25 <ApBBB> veskuh: at least if you could open a few apps. the mail is dreary and could use some love from the community
09:00:37 <c_la> veskuh: thanks, so community could build a dual boot version? or dual boot would require actions from Jolla?
09:00:44 <r0kk3rz> RodSeq: both, its not as stripped down as alien-dalvik is, or as integrated with sailfish
09:00:47 <Mister_Magister> Everybody wants xperias but imo xperia is no good
09:00:50 <tortoisedoc> will jolla support existing apps to be included? and if it will have paymenz support, what could be jollas support for that like?
09:00:55 <nh1402> once Anbox supports Android Oreo the ram usage should go down a bit, I think
09:01:00 <ApBBB> nh1402: having firefox for sailfish would be the awesomest thing ever
09:01:02 <veskuh> Sailor5811_: I haven’t taken a look at that.
09:01:06 <Venemo> is Jolla working together with YouYota on the tablet? would Jolla help YouYota increase awareness on their tablet project?
09:01:15 <nh1402> ApBBB: needs GCC 4.9, Sailfish is GCC 4.8
09:01:22 <M-schmittlauch> veskuh :-(
09:01:24 <marmistrz> sledges, I used CircleCI with success, two Rust projects used Travis CI
09:01:39 <veskuh> ApBBB: Yeah, I can see how that would make sense.
09:01:42 <r0kk3rz> wow lots of questions, FYI if you add them to the meeting you get dedicated time for your answer!
09:01:43 <sledges> marmistrz: libhybris upstream is using travis CI, so i'd go with that
09:01:58 <tortoisedoc> nh1402: does jolla phone have open boitloader?
09:02:03 <tortoisedoc> *bootloader
09:02:09 <ApBBB> veskuh: help us help you then :D
09:02:12 <marmistrz> Remember that the option to enable Travis only for public repos is well hidden :)
09:02:33 <sledges> c_la: handling android/sailfish os updates would require actions from jolla
09:02:35 <rainemak> ApBBB, let's see... could happen eventually. No promises.
09:02:46 <Mister_Magister> sledges: the most voted phones are whe worst ones
09:02:47 <leszek> Not a question just a notice. Someone poke the qtwebkit maintainer to take a look at the commits to qtwebkit 5.6 branch upstream since the 2016-09-27 to add those patches (CSS and crash fixes) to qtwebkit in mer/sailfishos. That would greatly improve stability for webcat on sailfishos
09:02:59 <tortoisedoc> gcc upgrade +10
09:03:02 <piggz> veskuh: what are the plans/status of qtlocation 5.6?
09:03:12 <Mister_Magister> gcc upgrade +999999999999999999999999
09:03:14 <c_la> ApBBB: I second the request of open sourcing mail app // veskuh
09:03:22 <RodSeq> @leszek @rokk3rz think it's not a blocking point: ROM capacity on today smartphone is clearly not an issue, RAM capacity neither now with >=2GB memories
09:03:25 <nh1402> tortoisedoc: it might be, but that's not the point, if it is locked, Jolla locked it after having installed it with Sailfish, Nokia are running Android, kernel requires modifications in order to get Sailfish working, and with a locked bootloader that's not possible
09:03:43 <marmistrz> gcc upgrade +2.71e100 :P
09:03:56 <tortoisedoc> nh1402 : so ask mdh to open it for jolla :p
09:03:59 <veskuh> piggz: It’s one of the areas we’d like to go forward with, but we haven’t been able to put resources to properly investigate what needs to be done.
09:04:04 <tortoisedoc> *mhd
09:04:10 <piggz> veskuh: k
09:04:20 <leszek> gcc upgrade breaks abi after 4.9 so I doubt thats feasible too soon. It means recompiling everything against the newer gcc
09:04:21 <remote1> how soon Jolla usually releases kernel source? When to expect it after Xperia X SFOS release?
09:04:38 <Venemo> leszek: you can ask the newer version to use the old ABI
09:04:51 <Venemo> leszek: so that argument is invalid
09:04:53 <nh1402> leszek: you can use a flag to use older abi with newer version of gcc
09:04:53 <piggz> Next. does the Xperia have a fingerprint sensor, and is it used in the port yet? if so, is there anything tht can be used by other porters?
09:04:58 <LarstiQ> remote1: ideally, at the same time
09:05:00 <leszek> oh interesting did not know about that
09:05:03 <nh1402> -fabi-version or something
09:05:04 <sledges> #info ideas for next meeting (those who didn't get their answers, please suggest meeting questions in the next fortnight):
09:05:09 <sledges> #info gcc upgrade
09:05:27 <sledges> #info feasibility of adding firefox improvement to sfos browser
09:05:36 <remote1> LarstiQ: ok, thanks
09:05:40 <tortoisedoc> #info harbour in russia ; paid apps support
09:05:40 <r0kk3rz> gcc update we talked about a few meetings ago
09:05:40 <sledges> #info (insert your unanswered question here:)
09:05:43 <nh1402> piggz: yes, it has a fingerprint sensor, it's on the power button
09:05:43 <Venemo> leszek: see https://gcc.gnu.org/onlinedocs/gcc/C_002b_002b-Dialect-Options.html#C_002b_002b-Dialect-Options -fabi-version
09:05:45 <r0kk3rz> same with paid apps
09:05:47 <Mister_Magister> gcc upgrade was on the meeting before
09:06:01 <sledges> Mister_Magister: means we need an update on its progress
09:06:05 <Mister_Magister> and jolla don't care about it and throw everything on community -_-
09:06:07 <tortoisedoc> r0kk3rz this is related to russia only now
09:06:09 <piggz> nh1402: so, parts 2 and 3 of the Q? ;)
09:06:09 <nh1402> Mister_Magister: new information came to light about using older abi version with new gcc
09:06:21 <Mister_Magister> nh1402: nice
09:06:21 <LarstiQ> Mister_Magister: that's not true
09:06:22 <sledges> we're outresourced with projects
09:06:34 <Venemo> #info unanswered question: Is Jolla working together with YouYota on the tablet? Would Jolla help YouYota increase awareness on the YouYota tablet project? See https://www.indiegogo.com/projects/youyota-sailfish-os-2-in-1-tablet/#/
09:06:38 <nh1402> piggz: parts 2 and 3 the answer is beats me  :p
09:06:41 <remote1> since IFA is on 1st of Sep, is Jolla going to be present at IFA2017 in Berlin?
09:07:02 <LarstiQ> remote1: that question has already been answered by veskuh?
09:07:06 <Sailor5811_> IFA ?
09:07:06 <nh1402> remote1: that was already answered
09:07:11 <remote1> sorry, missed it
09:07:41 <sledges> time to wrap up, this was the most chatty meeting that i could remember! :)
09:07:47 <sledges> #topic Next meeting time and date (5min)
09:08:04 <c_la> sledges: agree, lot of contributions
09:08:17 * piggz still wondering about fingerprint support
09:08:19 <sledges> so another meeting in two weeks, same time
09:08:25 <sledges> piggz: add it as a topic;)
09:08:27 <ljo_> +1
09:08:32 <c_la> sledges: I agree
09:08:38 <piggz> sledges: yeah, but i struggle to make meetings usually ;)
09:08:52 <piggz> will do, and maybe it could be discussed, and i'll read the minutes
09:08:53 <sledges> Wednesday 6th September 2017 at 08:00 UTC
09:09:05 <eekkelund> re dualboot on xperia: https://translate.google.com/translate?hl=en&sl=ru&tl=en&u=https%3A%2F%2Fhi-tech.mail.ru%2Fnews%2Fsailfish-i-android
09:09:10 <Mister_Magister> piggz: put someone as alternative to you
09:09:14 <Sailor5811_> Default App Improvements needed for daily usage ! Will patches be a part of jolla in future ?
09:09:14 <sledges> piggz: alternatively ping spiiroin on porters channel;)
09:09:28 <c_la> eekkelund: thanks, will read it
09:10:09 <sledges> couple of more +1s for the next meeting date and we'll conclude:)
09:10:34 <Sailor5811_> sledges: +1
09:10:43 <r0kk3rz> sledges: make it so
09:11:06 <Mister_Magister> +1
09:11:09 <occirol> +1
09:11:25 <sledges> #info Next meeting will be held on Wednesday, 6th of September 2017 at 08:00 UTC
09:11:31 <sledges> #endmeeting