08:02:20 <sledges> #startmeeting Sailfish OS, open source, collaboration – 23rd August 2018
08:02:20 <merbot> Meeting started Thu Aug 23 08:02:20 2018 UTC.  The chair is sledges. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
08:02:20 <merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:02:45 <sledges> #info meeting information and agenda can be found here: https://lists.sailfishos.org/pipermail/devel/2018-August/008451.html
08:02:52 <sledges> #topic Brief introduction (5 min)
08:03:22 <sledges> I am the meeting’s chairperson today and will be doing my best to keep time and order. Please behave, respect the timings and be-have ;)
08:03:42 <Raymaen> :-)
08:04:19 <sledges> Please prefix your name/handle with # info
08:04:47 <sledges> #info Simonas Leleiva – /dev @ Jolla
08:05:16 <Raymaen> #info Rajmond Wildemann - comunity
08:05:37 <Venty> 'llo.
08:06:04 <vknecht> #info Vincent Knecht - community
08:06:08 <r0kk3rz> #info Lewis Rockliffe - community
08:06:09 <flypig> #info David Llewellyn-Jones - dev in the community
08:06:39 <vknecht> hello :-)
08:06:40 <Venty> #info Martin Ebnoether - Fanboy
08:09:13 <sledges> #topic Community contributions to non open-source components (15 min – asked by flypig)
08:09:32 <sledges> #info There are a number of oustanding features and bug-fixes that community members have requested in some of the closed-source SFOS components. The message from Jolla is that they are often too busy to focus on them as revenue-generating work must take priority.
08:09:40 <sledges> #info However, Jolla apparently have an NDA that would allow community contributors to access internal repositories to help submit code and fixes. The topic is a request for Jolla representatives to give some more info about how this works, and for the community to suggest areas for contributions and how the scheme could be made more visible to others.
08:10:28 <flypig> Can I give a little more context?
08:10:44 <sledges> thanks for this topic flypig, as some of you might know, we already have a thing with dcaliste ongoing, syncing up on #sailfishos
08:10:48 <sledges> flypig: sure!
08:11:31 <flypig> I'd like to know more about the thing with dcaliste, as I'm not aware of it, but just to give a bit more context, this was a topic that came out of the discussion in the meeting a fortnight ago.
08:11:56 <sledges> #info Jolla has already put this in practice (testing waters), and to take things further we will propose hot items from TJC or our own backlogs to a willing and experienced community developer to work on under an NDA, have minimal (but relevant) input from us
08:12:00 <sledges> #info We would focus on the tasks where required the UX design is relatively clear
08:13:31 <flypig> Could you explain how the process works? This is the part that's missing from my understanding (e.g. how does a developer get connected with a task, is there a preview NDA)?
08:14:01 <flypig> It's great that this is possible, BTW.
08:15:16 <sledges> I'd imagine we would publish a list of tasks in a TJC ticket, and developers would propose their candidacy, also time available
08:15:45 <sledges> I need to doublecheck if we can publish an NDA for people to preview (cc jpetrell)
08:16:16 <flypig> I think it would be helpful if you could publish the NDA in advance, to give an idea about what people are letting themselves in for (so to speak).
08:16:51 <leszek> Is there no alternative to NDA?
08:17:01 <r0kk3rz> the first rule about an NDA is that you dont talk about NDAs
08:17:05 <flypig> Or just give a summary of the important points (e.g. if there's a no-compete clause, the length of the non-disclosure period)
08:17:27 <sledges> NDA is about not disclosing closed-sourced components, because well, they're closed source :)
08:17:44 <leszek> It should be clear that the dev community around SailfishOS is mostly totally against any kind of NDA
08:18:21 <leszek> sledges: so the plans for open sourcing were a lie?
08:18:25 <flypig> Yeah, but I think there's some need for pragmatism. If we want stuff fixed in the closed-source part, there's no other reasonable way.
08:18:38 <leszek> flypig: open sourcing
08:19:01 <leszek> there is absolutely no reason left why silica is closed
08:19:02 <flypig> Sure, but Jolla have been clear about the extent of their open sourcing, I think.
08:19:14 <sledges> leszek: we have Damien who's willingness to address in-depth sfos issues has overcome the wait for them to get opensourced (it's better to do this while waiting for opensourcing instead of doing nothing)
08:19:23 <leszek> flypig: promised to open source is what I have still ringing in my ears
08:19:40 <flypig> Nevertheless, I'd like us to avoid going down this rabbit hole in this discussion ;)
08:20:20 <sledges> 4more mins
08:20:30 <leszek> it should be clear to jolla it will be a pr desaster especially in the Open Source / Free Software world if it is known that people can work on their closed components with NDAs. Or if they even try to have OpenSource developers work on it
08:21:02 <r0kk3rz> we've had the open sourcing discussion plenty of times, but its good jolla has an alternative mechanism for accepting contributions
08:21:13 <leszek> Sometimes I have the feeling there is no one at Jolla understanding the OpenSource / FreeSoftware movement as one of the biggest parts of their community
08:21:22 <flypig> Is there a way to take this forward, in the short term, without causing a PR disaster but still getting things done?
08:21:28 <sledges> we're doing what we can here given not stalling completely in terms of contributions and bringing the OS forward
08:22:18 <sledges> leszek: there are different managerial/board levels who don't understand, in this way we're doing our best from those teams that do
08:22:20 <flypig> So, e.g. don't publish the NDA, but publish an initial short list of tasks, with contact info for who to talk to about them?
08:22:30 <leszek> I won't code a single line of code with an NDA thats for sure and I will also recommend other peoples not to sign any NDA with Jolla
08:22:48 <flypig> leszek, that's fine and good. But it's also a personal choice, surely?
08:23:02 <flypig> Personally, I would like to fix some stuff if I can.
08:23:13 <leszek> last sentence from me is a personal choice and frustration
08:23:33 <r0kk3rz> leszek: you do you, other people can choose for themselves
08:24:00 <sledges> we have been having NDAs for community beta testing programme (pre-Early-Access) that has plenty of members
08:24:05 <sledges> i'm sure this could work too
08:24:17 <flypig> sledges, could you give an action, timeline, or place to take this forwards?
08:24:20 <sledges> also, we're expanding it
08:24:27 <Raymaen> when there is a way to fix something with NDA why live with bugs?
08:24:34 <leszek> sledges: Now I know why I am not a cbeta member
08:25:10 <leszek> Raymaen: because it is the wrong way of developing and the opposite direction in which way the ship should go
08:25:36 <sledges> flypig: we'll have an update during next meeting, i'll raise this during our iteration planning that will happen to happen in between these meetings ;)
08:25:49 <Raymaen> so it is better to have a buggy system? dousnt make sense to me
08:25:51 <sledges> time's up for this topic
08:26:22 <flypig> sledges, that's great, thank you. I'd love there to be a page on TJC, or something lite, just to point interested people in the right direction.
08:26:27 <sledges> #topic general problems with roaming on Sailfish OS (20mins – asked by Raymaen)
08:26:48 <sledges> #info There are a lot of questions about this topic on TJC.
08:26:53 <sledges> #link https://together.jolla.com/question/177397/xperia-x-roaming-does-not-show-local-operator-and-does-not-show-connection/
08:27:02 <sledges> #info this question is tracked by Jolla, but since the tracking there have been 2 updates without patching this issue. In my opinion it is a huge problem that needs to be fixed as fast as possible, as it is something that makes Sailfish phones unusable as daily driver.
08:27:08 <sledges> #info What is the problem and why is it stil present? What can we as comunity do to help solve it? Shouldn't such critical bugs being patched as fast as there is a solution, no matter if it fits the update schedule?
08:27:23 <sledges> everybody loves Raymaen :) the stage is yours :)
08:27:32 <Raymaen> lol
08:28:03 <Raymaen> do i have to say something more?
08:28:35 <Raymaen> would like to know how is this "tracked by Jolla" thing working
08:29:04 <leszek> To add something to that topic. I traveled to Vienna for Akademy a few weeks ago and after landing and turning on my Xperia X it would connect just fine until it starts to popup the message that I removed my SIM and have to restart to use it. I fixed it by rebooting. After landing back in Cologne I fixed it by opening the Sim tray and moving the tray out and in again. Still unpleasant as it ate 10%
08:29:07 <leszek> battery in 5 minutes spamming me with the message
08:29:07 <sledges> Raymaen: it's tracked by Jolla, but prioritised by paying customers :)
08:29:59 <Raymaen> so what you say is...?
08:30:00 <sledges> leszek: sounds like another roaming-related problem (SIM removed)
08:30:11 <leszek> Also I think it is an issue that can be experienced in different ways on different devices. For example I met with many Jolla 1 owners that were unable to use data connection when roaming
08:30:17 <sledges> Raymaen: that some tracked tasks might not get addressed in timely fashion
08:30:22 <vknecht> didn't we pay for SailfishX ? ;-)
08:30:50 <sledges> vknecht: point taken :) i can't speak much as the developer is not here at the moment (monich)
08:30:51 <Raymaen> i think that is a huge general problem that affects every sailfish user
08:31:10 <sledges> he's been working hard this week on few burning things in 2.2.1 and 2.2.2
08:31:27 <sledges> i suspect roaming issue being an involved/complex one
08:31:31 <leszek> It would be nice if we as community when experiencing such issues could help with logs. So maybe a small little tool or script to generate logs when we experience such problems might help Jolla fixing the issue. It just needs someone at Jolla to write this script/tool and to take a look at the logs
08:31:50 <r0kk3rz> leszek: theres ofono logger on openrepos
08:31:51 <flypig> +1
08:32:25 <leszek> r0kk3rz: good then someone needs to update the TJC thread and asks for logs from ofono logger
08:32:36 <leszek> -s
08:32:40 <Raymaen> I often loggt with it but traveled seldom in past months
08:33:29 <r0kk3rz> i travel often with my jolla c, and its been fine roaming
08:33:39 <Raymaen> I thing Jolla schould be more aware of this bug and prioritiye that functionality higher than some nice new features
08:33:45 <r0kk3rz> EU/ME/AUS no worries
08:34:06 <r0kk3rz> both sims, different carriers
08:34:48 <Raymaen> sorry for my writing skills... No I'm not drunk... :-)
08:35:27 <leszek> r0kk3rz: Jolla C works better than Jolla 1 and Xperia X in that regard.
08:35:52 <leszek> At least I also got that impression from Akademy Jolla C users that were roaming and had no issues
08:36:00 <Raymaen> would be interesting to know why?
08:36:03 <leszek> so thats why I say it might be device specific
08:36:36 <Raymaen> is it depending on different modems?
08:37:15 <leszek> I assume you need to use different delays or timeouts to check for networks and react and such
08:37:31 <leszek> so yeah different modems, different drivers, different behavior
08:37:34 <flypig> There are lots of variables here: country, carrier, configuration. I experienced this in Ireland, but not every time I travel there.
08:37:34 <r0kk3rz> modem stuff is dark and full of terrors
08:38:26 <Raymaen> This Roaming thing is something that holds me back to promote Sailfish X even in my family...
08:38:40 <sledges> a part of the problem might lie in the AOSP version we're using, sadly to bump that version has become too inert. but let's hear what monich has to say for the next meeting update on this
08:39:23 <sledges> if someone has lots of spare time on their hands, they could bake an (older) AOSP image and try to roam around with that to ease life for monich, but i guess that's a tad too much to ask
08:39:29 <leszek> Yeah for the Xperia X I can only guess that raising AOSP and especially the kernel to a newer version (which will bring in more up to date drivers) might really help
08:39:59 <flypig> Is it worth us performing a SIM-swap? I can provide someone with a UK sim to collect logs from another country?
08:40:00 <r0kk3rz> that probably wont help
08:40:00 <Raymaen> ok maybe he could provide some plan how we could help with logs or what ever.
08:40:05 <sledges> and then getting updated blobs
08:40:14 <r0kk3rz> its going to be the firmware they released with AOSP
08:40:24 <r0kk3rz> which is probably different to the stock firmware
08:40:44 <sledges> Raymaen: ofono logger is golden, is just that some roaming issues are one-off per-country, so hard to get by. does anyone commute abroad daily/weekly? :D
08:40:47 <r0kk3rz> on other sony devices they stripped the modem firmware from the AOSP release
08:41:34 <r0kk3rz> but yeah, even if infrequently get the ofono logger, and hopefully catch the problem in the act
08:41:36 <sledges> r0kk3rz: so can't phone on those?
08:42:06 <r0kk3rz> sledges: you can, if you pull the firmware off a LOS image and build them in :)
08:42:15 <r0kk3rz> which isnt exactly legal, but whatever
08:42:15 <sledges> yowzer
08:43:14 <Raymaen> so the to do's are:...
08:44:09 <sledges> r0kk3rz: which devices and when did that happen?
08:44:30 <r0kk3rz> sledges: shinano platform, so scorpion tab, z2
08:44:57 <sledges> #info Ask monich for an update for the next meeting
08:45:53 <vknecht> s/info/action/ :)
08:46:12 <sledges> #undo
08:46:12 <merbot> Removing item from minutes: <MeetBot.items.Info object at 0x41199d0>
08:46:18 <sledges> #action Ask monich for an update for the next meeting
08:46:19 <sledges> ;)
08:46:32 <sledges> #topic Gen. Discussion (20 min)
08:47:09 <flypig> sledges, I should have mentioned at the time, but could you please # info your comment above so it goes in the minutes "we'll have an update during next meeting, i'll raise this during our iteration planning that will happen to happen in between these meetings ;)"
08:48:10 <sledges> #info
08:48:15 <sledges> #undo
08:48:15 <merbot> Removing item from minutes: <MeetBot.items.Info object at 0x4119850>
08:48:16 <sledges> lol
08:48:57 <vknecht> updater gui for community devices : could the one provided in sfos be modded to work on then, or should we really develop a specific one ?
08:49:10 <vknecht> *them
08:50:42 <sledges> #info More on the 1st topic (community contribs to non-oss): we'll have an update during next meeting, i'll raise this during our iteration planning that will happen to happen in between these meetings
08:51:03 <flypig> Thank you :)
08:53:07 <sledges> vknecht: mal has had an updater as one of his projects, because re-using Sailfish OS's store-client is too involved. maybe he could open it up?
08:54:34 <vknecht> there's a new nemomobile package updater from neochapay which could be useful
08:56:00 <vknecht> i'll look into this
08:58:16 <pketo> Some refactoring was done on the system updater recently, but I'm not sure if it helps with the community ports
08:58:17 <sledges> thanks, that would be swell (it would received hw adaptation updates even between sfos updates)
08:58:44 <vknecht> another question : does jolla have some framework or app to test vulnerabilities on devices ?
09:00:26 <vknecht> ah, and is there some doc/source for CSD, especially suspend test and its iteration count ?
09:01:04 <vknecht> eg. is higher iteration count good or bad ?
09:01:38 <sledges> pketo: as per my reply to vknecht, store-client would need to be modified to alert about any updates in the two new repos: adaptation-community and adaptation-community-common (and somehow version them?) and then install the update
09:02:50 <sledges> vknecht: suspend and reboot are soak/endurance tests. do you want to know if iteration count can be configurable (each device can have csd .ini file that tunes things)
09:03:35 <vknecht> it's just that sometimes it says 40 or 41 instead of 20
09:04:14 <vknecht> and I don't know what to make of it :)
09:04:36 <sledges> hm that's odd. on the same device?
09:05:06 <vknecht> yes, when running it several time
09:06:06 <sledges> wow you do endure-test your devices ;) Sage__ would you know? ^^
09:07:06 <sledges> time's up for this Gen.
09:07:06 <vknecht> since I make kernel updates, i like to check if device is at least as stable than before :)
09:07:27 <sledges> #topic Next meeting time & date (5 min)
09:08:07 <vknecht> thanks for replies :)
09:08:15 <sledges> thanks for asking!:)
09:09:25 <sledges> in two weeks Jolla will be doing the aforementioned planning (actually, Thursday will fall on the summer party right after the planning day)
09:09:35 <sledges> so let's meet-up in 3 weeks time
09:09:54 <sledges> (sorry James, you'll have to retweak internal calendar invitation recurrence again :D)
09:11:01 <sledges> all ok for the next meeting to be held on 13th September 2018 at 08:00 UTC ?
09:11:08 <r0kk3rz> make it so
09:11:13 <flypig> Looks good.
09:11:51 <sledges> #info Next meeting will be held on 13th September 2018 at 08:00 UTC
09:12:02 <sledges> thank y'all!!
09:12:04 <sledges> #endmeeting